Welcome to the North American Subaru Impreza Owners Club Friday September 4, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-03-2012, 03:23 PM   #1
Jerembo47
Scooby Newbie
 
Member#: 249219
Join Date: Jun 2010
Chapter/Region: SCIC
Location: San Diego, CA
Vehicle:
2007 WRX TR
World Rally Blue

Impreza WRX 07 WRX TR Boost issue only 6 psi?

Hello, I purchased an 07 wrx from the dealership and it has been pushing only 6 psi boost. I am no mechanic but I do have mechanical skills being in the navy. The car is pretty much stock except for the 5" exhaust. Ive been reading posts on here for over an hour now. I have checked most of the vacuum lines, well the ones I can see on the turbo, MBC, inter-cooler and stock BOV. They are nice and tight. I have reset my ECU and still only 6psi. I'm thinking either my boost gauge is degraded or installed in the incorrect spot. Im not sure if I am getting waste gate only. I have taken some pictures. Also does anyone know where I can find a vacuum diagram? Maybe that will help. Thanks! Let me know if I should post some more pics?










^^^^^This one shows where the boost gauge was tapped^^^^^





Jerembo47 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:18 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.