Welcome to the North American Subaru Impreza Owners Club Thursday October 20, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-06-2012, 02:12 PM   #1
Scooby Specialist
Member#: 337170
Join Date: Nov 2012
Location: hesperia, California
2003 wrx

Default help wiring my glow shift cluster?

i just picked up this glow shift cluster from a buddy and tossed it into my car, he tore it out before i could say wait and now we have no clue where anything went or goes. i have everything powered from the clock power/switch so they work and the boost gauge works but now i need to tackle the oil pressure and oil temperature. he claimed all 3 gauges worked perfectly when he pulled them out but i cant see any differences in the oil sensor below the alternator and there is no sandwich plate? oil temperature is sitting at 0 and oil pressure is sitting at 100, although there is NOTHING hooked up but power and ground. any help is appreciated! one thing i do know is the wires were routed right behind the radiator fan on passenger side. but none were hooked up to anything

rushdylan is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 09:40 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.