Welcome to the North American Subaru Impreza Owners Club Wednesday October 26, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-06-2012, 10:59 PM   #1
Scooby Specialist
Member#: 253442
Join Date: Jul 2010
Chapter/Region: BAIC
Location: Sacramento, Ca
Default Lovely Engine Noises! Audio INSIDE!

So i have recently been hearing this ticking noise coming from the engine bay. Its only between 2k-3k rpms. Does not get louder when going through the 2/3krpm range, and goes away after 3k rpm. Oil was recently changed with 5-40w rotella. Also had a compression test done recently 128-130 across the board. car runs fine, idles fine, pulls like a champ. Just had my tuner touch up my tune, everything is running perfectly, except this ticking noise is driving me nuts.

Its synced with the pistons i think. Its not loud by any means, just noticeable.

car has 72k miles.

I tried recording it with my iPhone, but i don't think its loud enough to be captured on the microphone. When the car is in neutral and i have the someone rev the engine it doesn't happen. only seems to be under load.

I will try and upload a video of the recording, since that seems to help peoples responses. It there is anything im leaving out let me know or any questions that would help. thanks

Last edited by rymaggi; 11-09-2012 at 11:35 PM.
rymaggi is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 12:04 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.