Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-07-2012, 01:09 PM   #51
wondras
Scooby Newbie
 
Member#: 337076
Join Date: Nov 2012
Chapter/Region: NESIC
Vehicle:
2013 XV Crosstrek

Default

If anyone has a spare CM621UB they're willing to part with for cheap or free, I'd love to have one to do some bench testing, and to try making a line-out mod.


JohnNevets: Nice work on the combo moves! The service manual does list "3+6+SOUND" for through mode, but it doesn't show 3+4 and 3+5 for sedan/wagon modes. 3+6 worked once for me, but I never saw it again because I didn't know about the other two. It all makes sense now.

flyboy1100: All of the audio specs in the service manual have a note that says "auto loud off" and "eq through mode", so I'm pretty sure through mode means flat EQ.

As for loudness, I can see why you might want to leave it on. It used to just add insult to injury, but with the EQ disabled, it's much more reasonable. I can change it on the fly with one hand now, but I think I'll mostly be leaving it off; I find the tonal balance often isn't great across volume levels and recordings, so I end up fussing with the tone controls. With loudness off, I can just keep the volume within a range where the tonal balance sounds right for a given recording and leave it at that.


One the way to work this morning, I caught myself just enjoying the music and not thinking about the system. I didn't think this was going to be possible with the stock setup.
* Registered users of the site do not see these ads.
wondras is offline   Reply With Quote
Old 11-07-2012, 01:27 PM   #52
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by wondras
If anyone has a spare CM621UB they're willing to part with for cheap or free, I'd love to have one to do some bench testing, and to try making a line-out mod.

JohnNevets: Nice work on the combo moves! The service manual does list "3+6+SOUND" for through mode, but it doesn't show 3+4 and 3+5 for sedan/wagon modes. 3+6 worked once for me, but I never saw it again because I didn't know about the other two. It all makes sense now.

flyboy1100: All of the audio specs in the service manual have a note that says "auto loud off" and "eq through mode", so I'm pretty sure through mode means flat EQ.

As for loudness, I can see why you might want to leave it on. It used to just add insult to injury, but with the EQ disabled, it's much more reasonable. I can change it on the fly with one hand now, but I think I'll mostly be leaving it off; I find the tonal balance often isn't great across volume levels and recordings, so I end up fussing with the tone controls. With loudness off, I can just keep the volume within a range where the tonal balance sounds right for a given recording and leave it at that.

One the way to work this morning, I caught myself just enjoying the music and not thinking about the system. I didn't think this was going to be possible with the stock setup.
Is that the stock radio from the impreza? I have one I will never use again.
flyboy1100 is offline   Reply With Quote
Old 11-07-2012, 03:47 PM   #53
wondras
Scooby Newbie
 
Member#: 337076
Join Date: Nov 2012
Chapter/Region: NESIC
Vehicle:
2013 XV Crosstrek

Default

Quote:
Originally Posted by flyboy1100 View Post
Is that the stock radio from the impreza? I have one I will never use again.
AFAIK 2011 and earlier came with a CZ624U1, which is similar, but has some wiring differences. I'm not sure which of the 2012s use the newer CM621UB.

I can use either one, though I'm hoping for a CM621UB so it will be an exact match. It supports the new(?) dimming disable position on the dashboard dimmer knob.

I'll PM you to see what we can do. Thanks!
wondras is offline   Reply With Quote
Old 11-07-2012, 04:29 PM   #54
dsn112
Scooby Specialist
 
Member#: 332561
Join Date: Sep 2012
Chapter/Region: Tri-State
Location: Tri-State
Vehicle:
2015 Legacy LTD
Twilight Blue

Default

So I did this this morning, am I the only one who thinks through mode is worse than wagon mode?

On through mode it also gets very low volume, I have it up at like 30 just to hear it.

I have an audiocontrol LC2i and a jlxd400/4 running my fronts and a sub.

Maybe I need to retune the amp and audiocontrol
dsn112 is offline   Reply With Quote
Old 11-07-2012, 06:04 PM   #55
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by dsn112
So I did this this morning, am I the only one who thinks through mode is worse than wagon mode?

On through mode it also gets very low volume, I have it up at like 30 just to hear it.

I have an audiocontrol LC2i and a jlxd400/4 running my fronts and a sub.

Maybe I need to retune the amp and audiocontrol
With my alpine 445 volume level 25 is way too loud, granted I lost a little volume when I disabled the eq (left loudness on) but I only have to listen at 3-4 steps higher now than with eq on. Gain is set to just below 1/2

Last edited by flyboy1100; 11-07-2012 at 06:15 PM.
flyboy1100 is offline   Reply With Quote
Old 11-07-2012, 06:21 PM   #56
carse
Scooby Newbie
 
Member#: 237993
Join Date: Feb 2010
Chapter/Region: MWSOC
Location: CBUS/N E OH
Vehicle:
75 MGB

Default

CZ624U1

Loundness works but none of the EQ options.
carse is offline   Reply With Quote
Old 11-07-2012, 06:30 PM   #57
wondras
Scooby Newbie
 
Member#: 337076
Join Date: Nov 2012
Chapter/Region: NESIC
Vehicle:
2013 XV Crosstrek

Default

Quote:
Originally Posted by carse View Post
CZ624U1

Loundness works but none of the EQ options.
Hm, weird. Did you have the power OFF at the time?

What year is your vehicle?
wondras is offline   Reply With Quote
Old 11-07-2012, 07:13 PM   #58
dsn112
Scooby Specialist
 
Member#: 332561
Join Date: Sep 2012
Chapter/Region: Tri-State
Location: Tri-State
Vehicle:
2015 Legacy LTD
Twilight Blue

Default

Quote:
Originally Posted by flyboy1100
With my alpine 445 volume level 25 is way too loud, granted I lost a little volume when I disabled the eq (left loudness on) but I only have to listen at 3-4 steps higher now than with eq on. Gain is set to just below 1/2
When I had the 445 I had similar issues, and the Bluetooth problem. Now with the JL XD and LC2i, my levels aren't as high at low volumes, but I also don't have the bluetooth issue

I guess I have more tuning to do
dsn112 is offline   Reply With Quote
Old 11-08-2012, 10:31 PM   #59
jandree22
Scooby Specialist
 
Member#: 100800
Join Date: Nov 2005
Chapter/Region: MAIC
Location: S Central PA
Default

Quote:
Originally Posted by dsn112 View Post
So I did this this morning, am I the only one who thinks through mode is worse than wagon mode?
Nope, unfortunately I feel the same. After trying Wagon and Through, Loudness On and Off... I've decided Wagon and Loudness Off is best for me.

FM is awful but bluetooth audio streamed from my android sounds awesome.

(CZ624U1 in a 2013 Premium Hatch)
jandree22 is offline   Reply With Quote
Old 11-08-2012, 11:36 PM   #60
Yeeman19
Scooby Newbie
 
Member#: 8
Join Date: Jun 1999
Chapter/Region: HIIC
Location: Honolulu,Hawaii
Vehicle:
2012 WRX
Ice Silver Metallic

Default

Quote:
Originally Posted by wondras View Post
YES, WE CAN!

I just picked up a 2013 Crosstrek with the CM621UB HU. (Do I get partial credit for having most of an Impreza?) By piecing together info from various posts here, the service manual, and documents filed with the FCC, I figured out that it *is* possible to disable both the loudness and fixed EQ.

To turn loudness on or off:

With the unit ON, press and hold 1, 6, and TUNE (right knob.) The display shows LOUD OFF or LOUD ON.



To disable fixed EQ:

With the unit OFF, press one of these combinations of buttons:

1 + 2 + TUNE for SEDAN
1 + 3 + TUNE for WAGON
1 + 4 + TUNE for THROUGH MODE



With these "features" disabled, it sounds significantly less awful, especially at lower volume levels. This should make it a much better candidate for use with upgraded speakers, or a line out converter and amps. From the schematics, I think it would be fairly easy to add proper RCA line outputs as well.

I don't know if these keys will work on earlier models, but hopefully they do.

Fantastic forum you've got here!
This worked for my 12 base WRX....thanks
Yeeman19 is offline   Reply With Quote
Old 11-09-2012, 06:12 PM   #61
Scoob_Noob
Scooby Newbie
 
Member#: 308149
Join Date: Jan 2012
Chapter/Region: NESIC
Vehicle:
2012 WRX 5-door
WR Blue Pearl

Default

This worked on my base 2012 WRX too. Can't honestly say if it made a huge difference or not. I prefer Loud On and Through Mode on the EQ. So does Through Mode disable the EQ and then Wagon and Sedan are the two EQ's you can choose from?
Scoob_Noob is offline   Reply With Quote
Old 11-09-2012, 06:39 PM   #62
Subie FA20
NASIOC Supporter
 
Member#: 72195
Join Date: Oct 2004
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2015 WRX
WRB Limited

Default

So trying this tonight!
Subie FA20 is offline   Reply With Quote
Old 11-09-2012, 11:20 PM   #63
Krazyjohnny
Scooby Newbie
 
Member#: 330435
Join Date: Aug 2012
Default

Does this lessen how bad the tuner sounds? My BT and CD sound great. The radio on the other hand sounds terrible.
Krazyjohnny is offline   Reply With Quote
Old 11-10-2012, 12:33 PM   #64
wondras
Scooby Newbie
 
Member#: 337076
Join Date: Nov 2012
Chapter/Region: NESIC
Vehicle:
2013 XV Crosstrek

Default

Quote:
Originally Posted by Krazyjohnny View Post
Does this lessen how bad the tuner sounds? My BT and CD sound great. The radio on the other hand sounds terrible.
Not really. It eliminates one layer of arguably sub-optimal EQ (or two with loudness), which may help a little, but the crazy loss of lows and highs relative to other inputs is still there.

If I'm reading it correctly, the service manual says it uses -6 dB at 70 Hz, and -17 dB at 7 KHz. FM music stations generally have heavy EQ, but this goes far beyond flattening them out a bit. It must be optimized for talk radio, though even that sounds rather dry to me.

I hate listening to music on FM anyway, so it's not a big deal for me. Still, when I get one of these on the bench, I will see if there's a way to bypass it in hardware. There are two ICs capable of EQ, one of which could be bypassed, but I don't know yet which gets used for what. This would probably be more than most people would want to take on, though.
wondras is offline   Reply With Quote
Old 11-10-2012, 01:46 PM   #65
Subie FA20
NASIOC Supporter
 
Member#: 72195
Join Date: Oct 2004
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2015 WRX
WRB Limited

Default

I can't tell much difference between the sedan, hatch and through mode. Loudness off helped music sound less muffled and over basy
Subie FA20 is offline   Reply With Quote
Old 11-10-2012, 01:50 PM   #66
SpicyPeaNut
Scooby Specialist
 
Member#: 43310
Join Date: Sep 2003
Chapter/Region: SCIC
Location: LA, California
Vehicle:
1978 Brat
Silver

Default

any idea if there is a service/diagnostic/secret menu in the '13 navigation unit? I was following this thread and wondered if I might be able to tinker and improve my own head unit sound.
SpicyPeaNut is offline   Reply With Quote
Old 11-11-2012, 06:18 PM   #67
RM_2
Scooby Specialist
 
Member#: 163058
Join Date: Oct 2007
Chapter/Region: MWSOC
Location: Central Indiana
Vehicle:
2011 Impreza WRX SWP
2001 Legacy L WGM

Default

In my 2011 WRX, I'm actually able to get to sedan/wagon/through mode by pressing 1+2, 1+3, 1+4 or 3+4, 3+5, 3+6 then pressing Tune. I can't tell much of a difference between the three. I think sedan mode is more distorted in terms of bass frequencies but I'm not sure. Either way, it sounds syrupy and crappy lol

Last edited by RM_2; 11-11-2012 at 09:34 PM.
RM_2 is offline   Reply With Quote
Old 11-11-2012, 07:30 PM   #68
09Subie
Scooby Newbie
 
Member#: 241163
Join Date: Mar 2010
Chapter/Region: Tri-State
Location: South Plainfield, NJ
Vehicle:
2012 WRX
Lightening Red

Default

"Loundness works but none of the EQ options."

Quote:
Originally Posted by wondras View Post
Hm, weird. Did you have the power OFF at the time?

What year is your vehicle?
Same problem im having 2012 base wrx
09Subie is offline   Reply With Quote
Old 11-11-2012, 09:05 PM   #69
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

you have to turn the radio off then press the combination of buttons to change the eq settings
flyboy1100 is offline   Reply With Quote
Old 11-11-2012, 09:15 PM   #70
09Subie
Scooby Newbie
 
Member#: 241163
Join Date: Mar 2010
Chapter/Region: Tri-State
Location: South Plainfield, NJ
Vehicle:
2012 WRX
Lightening Red

Default

Quote:
Originally Posted by flyboy1100
you have to turn the radio off then press the combination of buttons to change the eq settings
It was. Only thing that worked was the brightness and contrast and loudness
09Subie is offline   Reply With Quote
Old 11-11-2012, 09:32 PM   #71
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by 09Subie View Post
It was. Only thing that worked was the brightness and contrast and loudness
what is the radio model?

i find on mine you have to hit 3+4+knob then 3+6 will work for through mode.
flyboy1100 is offline   Reply With Quote
Old 11-11-2012, 09:34 PM   #72
RM_2
Scooby Specialist
 
Member#: 163058
Join Date: Oct 2007
Chapter/Region: MWSOC
Location: Central Indiana
Vehicle:
2011 Impreza WRX SWP
2001 Legacy L WGM

Default

Be sure to hold down the number buttons (e.g. 1+3) before hitting (just press it, no need to hold) the Tune knob.
RM_2 is offline   Reply With Quote
Old 11-12-2012, 02:35 AM   #73
carse
Scooby Newbie
 
Member#: 237993
Join Date: Feb 2010
Chapter/Region: MWSOC
Location: CBUS/N E OH
Vehicle:
75 MGB

Default

Quote:
Originally Posted by wondras

Hm, weird. Did you have the power OFF at the time?

What year is your vehicle?
Got it to work! Sounds much better with Loudness off and Wagon preset, not great but better.
carse is offline   Reply With Quote
Old 11-14-2012, 12:46 AM   #74
hakira
Scooby Specialist
 
Member#: 74211
Join Date: Nov 2004
Location: 34′33″S 3721
Vehicle:
2011
SSM WRX 4DR

Default

Quote:
Originally Posted by wondras View Post
YES, WE CAN!

I just picked up a 2013 Crosstrek with the CM621UB HU. (Do I get partial credit for having most of an Impreza?) By piecing together info from various posts here, the service manual, and documents filed with the FCC, I figured out that it *is* possible to disable both the loudness and fixed EQ.



With these "features" disabled, it sounds significantly less awful, especially at lower volume levels. This should make it a much better candidate for use with upgraded speakers, or a line out converter and amps. From the schematics, I think it would be fairly easy to add proper RCA line outputs as well.

I don't know if these keys will work on earlier models, but hopefully they do.

Fantastic forum you've got here!
Worked for me, bass doesn't sound distorted and everything is clearer, thanks!
hakira is online now   Reply With Quote
Old 11-14-2012, 01:53 PM   #75
erik11876
Scooby Specialist
 
Member#: 275888
Join Date: Mar 2011
Chapter/Region: MAIC
Location: Frederick MD
Vehicle:
2011 WRX Limited
SWP

Default

Works miracles if you already have dynamatted/sound reinforcement. Thanks! Works on my 2011 radio as well.
erik11876 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2011+ Impreza head unit into 2009? codingparadox Car Audio, Video & Security 6 12-31-2011 01:48 AM
2011 Stock Head Unit Audio Playlist Options cheezmunky Car Audio, Video & Security 2 12-02-2011 11:09 AM
WTB : WTB - non-navi 2011+ OEM Head Unit with Bluetooth. ofspunk7 Private 'Wanted' Classifieds 2 10-25-2011 01:40 PM
2011 STi head unit w/o nav RCA PORTS? sk8dc10 Car Audio, Video & Security 5 11-06-2010 11:01 PM
2011 stock head unit wiring question subiebosch Car Audio, Video & Security 10 10-08-2010 10:21 AM


All times are GMT -4. The time now is 10:33 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.