Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Proven Power Bragging

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 11-08-2012, 07:38 PM   #26
VladiWrX
Scooby Specialist
 
Member#: 145658
Join Date: Apr 2007
Location: NorCal
Vehicle:
On my 5th scoob
and lovin it

Default

I want the 45 seconds I spent skimming this thread back. fail and aids
* Registered users of the site do not see these ads.
VladiWrX is offline  
Old 11-08-2012, 08:22 PM   #27
Clark Turner
NASIOC Vendor
 
Member#: 178047
Join Date: Apr 2008
Chapter/Region: SWIC
Location: AZ/Vegas
Vehicle:
02 WRX STI Spec C
Black

Default

Not to mention the timing yank at 4k and 5.5k
Clark Turner is online now  
Old 11-08-2012, 08:26 PM   #28
Junior2JZ
Scooby Guru
 
Member#: 64908
Join Date: Jun 2004
Chapter/Region: Tri-State
Location: Tuning 8/9sec Subies @ P&L
Vehicle:
10.8 XT+10.0@143 GR+
9.0@170mph GTR

Default

That wasn't me.. lol

but

Safe in hot and cold is BS, especially on the OEM injectors. They are well past 100% IDC in cold weather at that power level.. probably why you trapped 101mph with 330whp. I am sure it was knocking nicely
Junior2JZ is offline  
Old 11-08-2012, 08:30 PM   #29
Clark Turner
NASIOC Vendor
 
Member#: 178047
Join Date: Apr 2008
Chapter/Region: SWIC
Location: AZ/Vegas
Vehicle:
02 WRX STI Spec C
Black

Default

Yep.. Just turn up boost, close laptop and let it RIDE.... LOL
Clark Turner is online now  
Old 11-08-2012, 08:31 PM   #30
st205wrx
Scooby Newbie
 
Member#: 193253
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Niles
Vehicle:
08 wrx 322/352
wrb

Default

Quote:
Originally Posted by nate_fisher
I am running the same whp as you with my 2011 automatic forester with a vf52 on e85 pushing 23psi.I am running 12.6 @ 110mph so i would think they are correct in that your numbers dont match your 1/4 time and trap speed you are missing 10mph some were unless you were granny shifting at 4k rpm.
I agree with you too that he has a very nice mod list and should be running more realistic power then he think he is. I am running an 18g and never tracked the car but still think I will be in the 12 sec range.
st205wrx is offline  
Old 11-09-2012, 12:09 AM   #31
bluepearlrex12
Scooby Newbie
 
Member#: 310184
Join Date: Feb 2012
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2012 WRX
Blue Pearl

Default

Quote:
Originally Posted by Clark Turner
Yep.. Just turn up boost, close laptop and let it RIDE.... LOL
You have to leave it open, so when your manifold pressure is too high, you can press the NOS button before your floor boards break away! Geez
bluepearlrex12 is offline  
Old 11-09-2012, 02:45 AM   #32
st205wrx
Scooby Newbie
 
Member#: 193253
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Niles
Vehicle:
08 wrx 322/352
wrb

Default

Quote:
Originally Posted by bluepearlrex12

You have to leave it open, so when your manifold pressure is too high, you can press the NOS button before your floor boards break away! Geez
Lmfao
st205wrx is offline  
Old 11-09-2012, 03:27 AM   #33
Spec R
Scooby Newbie
 
Member#: 187752
Join Date: Aug 2008
Chapter/Region: SCIC
Location: Hollywood, CA
Vehicle:
99 RS/X5/Volt

Default

i always hated the saying "they said it couldnt be done"

who is "they"?

then cue the "they" being the "haters" response.

then cue the "if they are hating, then I'm doing something right" response.

hey, if you'd rather be made fun of than ignored, then shoot, i'll make fun of you all you want.
Spec R is offline  
Old 11-09-2012, 08:42 AM   #34
lil jon
Scooby Specialist
 
Member#: 19044
Join Date: May 2002
Chapter/Region: Tri-State
Location: ppg/GT-k450/EJ205/
Default

So it wasn't dave brown, turbo mike, jr, or gimpy of even slowbaru. I'm going to say it was Vinny Ten?
lil jon is offline  
Old 11-09-2012, 11:34 AM   #35
kevinh211
Scooby Specialist
 
Member#: 56297
Join Date: Mar 2004
Chapter/Region: Tri-State
Location: Long Island NY
Vehicle:
2004 STi HTA Green
28psi, MSPT Tuned

Default

Ouch, I can hear the car knocking from over here. You can even see it pull timing while its on the dyno. You might have made that power for one pull but as soon as that car left the shop your ecu is going crazy trying to save the motor.
If the date on the dyno sheet is right your piston ring is already cracked.
Check the DAM with your access port and do a couple logs and post them up. I’d love to see the mess.
kevinh211 is offline  
Old 11-09-2012, 12:53 PM   #36
thorne
Scooby Newbie
 
Member#: 130063
Join Date: Oct 2006
Location: Ohio
Vehicle:
2003 WRX
Silb

Default

Wow, I'm not sure why you think this is a special number aside from if its truly real your probably running the car 2 lean for my personal taste.



I was out of injector on this car so I stopped. Stock Cat back on this car to.

I ran a 12.9 in this car for the client.
thorne is offline  
Old 11-09-2012, 12:54 PM   #37
thorne
Scooby Newbie
 
Member#: 130063
Join Date: Oct 2006
Location: Ohio
Vehicle:
2003 WRX
Silb

Default

Quote:
Originally Posted by kevinh211 View Post
Ouch, I can hear the car knocking from over here. You can even see it pull timing while its on the dyno. You might have made that power for one pull but as soon as that car left the shop your ecu is going crazy trying to save the motor.
If the date on the dyno sheet is right your piston ring is already cracked.
Check the DAM with your access port and do a couple logs and post them up. Id love to see the mess.
I'm with you 100% on this one
thorne is offline  
Old 11-09-2012, 01:54 PM   #38
PerformanceAutoSolutions
NASIOC Vendor
 
Member#: 853
Join Date: Feb 2000
Chapter/Region: Tri-State
Location: Deer Park, NY, USA
Vehicle:
2011 STI Sedan
Satin White Pearl

Default

Quote:
Originally Posted by Clark Turner View Post
Yep.. Just turn up boost, close laptop and let it RIDE.... LOL


hahahahaha this one still gets me..
PerformanceAutoSolutions is offline  
Old 11-09-2012, 02:29 PM   #39
Equilibrium Tuning
NASIOC Vendor
 
Member#: 26933
Join Date: Oct 2002
Chapter/Region: BAIC
Location: Fairfield, CA
Vehicle:
2006 STI
CGM

Default

is this a joke??
Equilibrium Tuning is offline  
Old 11-09-2012, 02:43 PM   #40
WTFJayJay
Scooby Newbie
 
Member#: 198725
Join Date: Dec 2008
Chapter/Region: South East
Location: Kennesaw, GA
Vehicle:
2004 WRX Hybrid 18g

Default

hey... maybe he just really sucks at driving and that was honestly his best time?
WTFJayJay is offline  
Old 11-09-2012, 03:24 PM   #41
SubieLuvin
Scooby Specialist
 
Member#: 248202
Join Date: May 2010
Chapter/Region: MWSOC
Location: Columbus, Ohio
Vehicle:
2013 WRX Sedan
SWP

Default

Quote:
Originally Posted by Clark Turner
Yep.. Just turn up boost, close laptop and let it RIDE.... LOL
My favorite post of the year haha
SubieLuvin is offline  
Old 11-09-2012, 08:00 PM   #42
BigRob74
Scooby Specialist
 
Member#: 305107
Join Date: Dec 2011
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2012 wrx
Protuned on E85

Default

we have been trolled
BigRob74 is online now  
Old 11-09-2012, 08:19 PM   #43
connorlug
Scooby Newbie
 
Member#: 275276
Join Date: Feb 2011
Chapter/Region: Tri-State
Location: Long Island, New York
Vehicle:
2007 FXT
CGM

Default

This is great...
connorlug is offline  
Old 11-10-2012, 03:39 PM   #44
CVR STi
Scooby Specialist
 
Member#: 127428
Join Date: Sep 2006
Chapter/Region: Tri-State
Default

DG motors?
CVR STi is offline  
Old 11-10-2012, 06:22 PM   #45
be0tch
Scooby Newbie
 
Member#: 66206
Join Date: Jul 2004
Chapter/Region: Tri-State
Location: Brooklyn, NY
Vehicle:
2005 WRX STi
FP HTA Green Turbo

Default

This car allegedly makes the same power as my hta green sti. O_o
be0tch is offline  
Old 11-10-2012, 06:40 PM   #46
thebigevilfoot
Scooby Specialist
 
Member#: 253836
Join Date: Aug 2010
Location: Central NJ
Vehicle:
2011 WRX-DGM
20g STImikey tune RIP CSK

Default

Lol, I ran a 12.8 @ 108 1.7 60 ft my first time at the track on my stock turbo. Plenty of time to be shaved too. Hoping to dip into the 11's when my 20g comes in
thebigevilfoot is offline  
Old 11-10-2012, 09:17 PM   #47
thisisntjared
Scooby Specialist
 
Member#: 177891
Join Date: Apr 2008
Chapter/Region: Tri-State
Location: south jersey
Vehicle:
06 wrx wagon
child seat/tow hitch cgm

Default

lemme guess: 60 degrees and 10% humidity

Last edited by thisisntjared; 11-10-2012 at 09:23 PM.
thisisntjared is offline  
Old 11-11-2012, 05:13 PM   #48
wrxtremeWGN
Scooby Specialist
 
Member#: 12281
Join Date: Nov 2001
Chapter/Region: Tri-State
Location: Stony Brook, NY
Vehicle:
08 FSXT
Tiger's Blood

Default

I guess "They" were right...
wrxtremeWGN is offline  
Old 11-11-2012, 07:31 PM   #49
HXC573
Scooby Newbie
 
Member#: 268007
Join Date: Dec 2010
Chapter/Region: MWSOC
Location: Sunrise Beach, Missouri
Vehicle:
2012 WRX
Ice Silver Metallic

Default

Yep , I ran 13.16 on my bone stock 2012 WRX at 103 I believe I don't have the ticket with me so I don't know what my 1/4 mph was
HXC573 is offline  
Old 11-11-2012, 10:53 PM   #50
kyouhakuteki
Scooby Newbie
 
Member#: 186079
Join Date: Aug 2008
Chapter/Region: SWIC
Location: Phoenix, Arizona
Vehicle:
2013 Impreza WRX STi
Dark Grey Metallic

Default

Quote:
Originally Posted by Badler View Post
You're missing 10mph somewhere?
I ran 13.4 @ 97 mph so his numbers seem ok to me~ (2003 Evo VIII)
kyouhakuteki is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.