Welcome to the North American Subaru Impreza Owners Club Thursday April 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Member's Car Gallery

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-12-2012, 03:37 AM   #11
Benhart21
Scooby Specialist
 
Member#: 149617
Join Date: May 2007
Chapter/Region: RMIC
Location: Boulder
Default

Quote:
Originally Posted by Hondaslayer View Post
Sounds like your car needed an alignment, or somebody that knows how to do an alignment.

I have had 3 sets of Grabbers now (one set is currently pushing 40k and has plenty of life left) and have had zero issues. I liked them so much I went out and bought a set of 5 for my Westfalia. The only "issue" I have had with mine is that the right front on my wifes car seems to have a magnet in it as that corner keeps picking up nails (seriously, she has had sooo many patches it's not even funny, Les Schwab knows her by name at this point)
Wasn't the alignment, had it done when they were installed and again at a different shop when I replaced them with something else and both times everthing was within factory specs. They were also rotated frequently every time I was working on the car at my buddy's shop. There were no signs of uneven wear, over/under inflation, or edges feathering, just how short they lasted.

Funny you mention a Vanagon, as I'm currently searching for a good set of metric tires for the one I just inherited.
Benhart21 is online now   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Chamois, or just plain Sham? Lifino Interior & Exterior Modification 8 10-02-2013 08:01 PM
SOA gotta love 'em or just plain hate 'em kalbo-1 Warranty Issues & SOA Problems 1 01-19-2004 08:29 PM
Hot or Not or Just Plain Ok.... n20x3whitewrx Member's Car Gallery 28 07-29-2002 10:05 AM
McRae: Dedicated or just plain nuts? SubaruStu Motorsports 2 03-20-2002 09:55 AM
Jinxed? Or just Plain UnLucky??!! silverSurfer General Forum Archive 6 06-30-2000 10:27 PM


All times are GMT -4. The time now is 11:22 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.