Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-12-2012, 02:36 PM   #1
pippen
Scooby Newbie
 
Member#: 171290
Join Date: Feb 2008
Chapter/Region: SCIC
Location: San Diego, CA
Vehicle:
2008 STi
Aspen White

Default Broken ringland?

My car:

2008 STi
ID1000's
GS EBCS
TBE (catless)
DW65c fuel pump
E85 tuned by Phat Ron

Things to consider:

1. After removing the stock TMIC I found around a 1/4cup of oil where the Ypipe meets the turbo (compressor housing??).

2. While in the process of tuning with Phatbotti it seems that I am continuing to have slight knock on 3rd gear pulls. I don't feel anything, don't really hear anything and it seems to idle fine most of the time with the exception of the occasional idle flutter I guess you could say where it goes up and down on cold starts (not as bad as a vacuum leak just is a little weird sometimes).

3. The car seems to run good, maybe not as strong as I remember, though.

4. I had recently switched back to stock heat range copper spark plugs after the one step colders I had installed seemed to be making things a little worse on E85. (Idle, misfires)

5. Cold starts are retarded. The temp this morning was like 57 degrees and the thing will just crank forever. I feel like I'm going to burn up the starter before the car starts.

6. I had the car tuned for the above mods maybe 5 months ago. 2 months ago I had recurring CEL's with misfires on Cylinder #1. Following these CEL's I got a System too lean code and contacted Ron. He followed up with an update that contained something like 25% fuel increase. The car still wanted more fuel. I pulled the injectors and found out I had effed up and didn't put injector #1 o-ring on. The injector was very gunked up so I then pulled all 4 to verify o-rings and clean them. That fixed my rough idle problems and I have not had a misfire or any other code since. Ron updated the MAF scaling and we moved on to 3rd gear pulls. This is where the knock comes in.



Uploaded with ImageShack.us

With the combination of the oil in the turbo and or burning of oil (less on dipstick), apparent loss of power and knock, Ron suggests it could be a ringland failure, problem with the pcv or blown turbo. My question is what is the easiest way to narrow it down to one of these and or what are your opinions? Ron suggested I let the car idle and pull off the oil cap and if it sputters crap and has hard hits of air coming out then it's a ringland. Should I also do a compression test / leak down test at this point also? The turbo seems to make boost just fine on paper, does that eliminate it being blown or do I have to pull the downpipe and inspect? And I'm really not sure how to check the pcv system..

One more thing is I see Autozone sells a compression tester but I don't have an air compressor to do a leak down test. Can I just take it to a shop and have them do it? Any suggestions for a shop in San Diego?

Thanks for all the help I'm about to just burn this car.
pippen is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:13 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.