Welcome to the North American Subaru Impreza Owners Club Wednesday October 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-12-2012, 06:59 PM   #1
RallyBot 6.0
Scooby Newbie
 
Member#: 337195
Join Date: Nov 2012
Chapter/Region: NWIC
Location: MT. HOOD Vancouver, WA
Vehicle:
2002 WRX
Maroon/black

Default Fresh oil change, but no oil on dipstick. what the!

just got my oil changed at firestone because i dont have ramps or a jack low enough to get under the car. drove it all night (about 40 miles) and then started it up the next day (sunday) and it was whinning really loud, popped the hood, could hear a knocking from pass side of engine, and ticking from right side, along with the whining. no oil on dipstick, started it up after today and it wasnt really knocking or ticking as bad but still whining just not as loud, also no oil on dipstick. they should be at my house any minute to take a look at it. just thought id post this and see if theres any precautions i should take in case they did forget to put oil in it and theres damage to my motor. i really dont know how i could prove that i didnt empty it or something.
RallyBot 6.0 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.