Welcome to the North American Subaru Impreza Owners Club Saturday December 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-12-2012, 09:54 PM   #1
Ebal
Scooby Newbie
 
Member#: 337115
Join Date: Nov 2012
Default 2003 wrx looses boost

I am experiencing problems with loosing boost towards 4500 rpm the car will go from 16.5 to 10 and hold at ten pounds any help would be appreciated thank you.
* Registered users of the site do not see these ads.
Ebal is offline   Reply With Quote
Old 11-12-2012, 10:19 PM   #2
jthatch12
Scooby Specialist
 
Member#: 321715
Join Date: May 2012
Chapter/Region: Tri-State
Location: Philly/SJ
Vehicle:
03 Big 16G WRX
PSM

Default

Quote:
Originally Posted by Ebal
I am experiencing problems with loosing boost towards 4500 rpm the car will go from 16.5 to 10 and hold at ten pounds any help would be appreciated thank you.
Normal . boost will taper down as you get closer to redline. My car hits peak(20 psi) at 3k and tapers down to 11 at redline
jthatch12 is offline   Reply With Quote
Old 11-12-2012, 10:23 PM   #3
WhiteBgeye02
Scooby Specialist
 
Member#: 224785
Join Date: Sep 2009
Chapter/Region: MWSOC
Location: neenah
Vehicle:
2005 wrx-jdm207
i went black...

Default

^ i hope yours is tuned for that. as far as the taper it should hit 12 around 5600 and then to ten above 5800 rpms according to a stock wrx rom target boost map. do a boost leak test. some basic searches on here will help!
WhiteBgeye02 is offline   Reply With Quote
Old 11-12-2012, 10:26 PM   #4
jthatch12
Scooby Specialist
 
Member#: 321715
Join Date: May 2012
Chapter/Region: Tri-State
Location: Philly/SJ
Vehicle:
03 Big 16G WRX
PSM

Default

Quote:
Originally Posted by WhiteBgeye02
^ i hope yours is tuned for that. as far as the taper it should hit 12 around 5600 and then to ten above 5800 rpms according to a stock wrx rom target boost map. do a boost leak test. some basic searches on here will help!
Of course I'm tuned for it! lol. My brother in law and I tune our scoobs ourselves. I'm currently at 231 whp and 244 ft/lb.
jthatch12 is offline   Reply With Quote
Old 11-12-2012, 10:36 PM   #5
Ebal
Scooby Newbie
 
Member#: 337115
Join Date: Nov 2012
Default

I am currently running the cobb stage 2 with catless exhaust and cobb ebcs
Ebal is offline   Reply With Quote
Old 11-12-2012, 10:37 PM   #6
Ebal
Scooby Newbie
 
Member#: 337115
Join Date: Nov 2012
Default

It was doing fine then all the sudden it started is it possible that it could be a exhaust leak per turbo?
Ebal is offline   Reply With Quote
Old 11-12-2012, 11:05 PM   #7
WhiteBgeye02
Scooby Specialist
 
Member#: 224785
Join Date: Sep 2009
Chapter/Region: MWSOC
Location: neenah
Vehicle:
2005 wrx-jdm207
i went black...

Default

no boost leak post turbo pre engine is prob whats up! do a boost leak test and go from there! make sure no post maf leaks between the turbo and the maf as well. the turbo inlet is known to leak/rip

to jthatch12. thats it? my ej205 on 93 mad 250whp and 280wtq from my own personal tune. went to 280/315 on e85!

post back after you do the leak tests. its something everyone should do on there car once a year at the very least! my guess is there is a leak because that little of boost up top is not what the map calls for it i remember correctly
WhiteBgeye02 is offline   Reply With Quote
Old 11-12-2012, 11:10 PM   #8
Ebal
Scooby Newbie
 
Member#: 337115
Join Date: Nov 2012
Default

I have all new hoses coming tomorrow for my intercooler I already have a new turbo inlet Perrin what kind of boost leak can I do
Ebal is offline   Reply With Quote
Old 11-12-2012, 11:13 PM   #9
jthatch12
Scooby Specialist
 
Member#: 321715
Join Date: May 2012
Chapter/Region: Tri-State
Location: Philly/SJ
Vehicle:
03 Big 16G WRX
PSM

Default

Quote:
Originally Posted by WhiteBgeye02
no boost leak post turbo pre engine is prob whats up! do a boost leak test and go from there! make sure no post maf leaks between the turbo and the maf as well. the turbo inlet is known to leak/rip

to jthatch12. thats it? my ej205 on 93 mad 250whp and 280wtq from my own personal tune. went to 280/315 on e85!

post back after you do the leak tests. its something everyone should do on there car once a year at the very least! my guess is there is a leak because that little of boost up top is not what the map calls for it i remember correctly
On the TD04? I'd like to see some of your roms if you still have them around. I'm not done fully tuning yet, just hit a milestone
jthatch12 is offline   Reply With Quote
Old 11-12-2012, 11:16 PM   #10
Ebal
Scooby Newbie
 
Member#: 337115
Join Date: Nov 2012
Default

I also have a friend coming tomorrow with a vacum pump to check the wastegate
Ebal is offline   Reply With Quote
Old 11-13-2012, 07:10 PM   #11
Ebal
Scooby Newbie
 
Member#: 337115
Join Date: Nov 2012
Default

Ok so I had no idea of how to check for leaks I sea foamed my car and smoke come from the passenger side near the timing belt cover maybe lower than that near the header please help
Ebal is offline   Reply With Quote
Old 11-13-2012, 07:51 PM   #12
Travisty
Scooby Specialist
 
Member#: 241216
Join Date: Mar 2010
Chapter/Region: MWSOC
Location: Grand Rapids, MI
Vehicle:
1995 LX Wagon
2013 SWP BRZ

Default

Quote:
Originally Posted by Ebal
Ok so I had no idea of how to check for leaks I sea foamed my car and smoke come from the passenger side near the timing belt cover maybe lower than that near the header please help
Head-to-manifold gasket, or the up pipe gasket.
Travisty is online now   Reply With Quote
Old 11-13-2012, 08:22 PM   #13
Ebal
Scooby Newbie
 
Member#: 337115
Join Date: Nov 2012
Default

Would those gaskets just go out at once
Ebal is offline   Reply With Quote
Old 11-13-2012, 08:39 PM   #14
Travisty
Scooby Specialist
 
Member#: 241216
Join Date: Mar 2010
Chapter/Region: MWSOC
Location: Grand Rapids, MI
Vehicle:
1995 LX Wagon
2013 SWP BRZ

Default

Quote:
Originally Posted by Ebal
Would those gaskets just go out at once
Gaskets do fail with age, although it's rare. They're cheap and easy to do, so do them. Order some proper gaskets from some place like Rally Sport Direct, not some crap Ebay fiber things.

I always buy gaskets with a fire ring, and I suggest you do as well.
Travisty is online now   Reply With Quote
Old 11-13-2012, 09:39 PM   #15
Ebal
Scooby Newbie
 
Member#: 337115
Join Date: Nov 2012
Default

Got them ordered I will install in a few days I think that it is the pass side one cuz when I stand with the hood open and rev it has a small backfire it sounds like it is coming from there
Ebal is offline   Reply With Quote
Old 11-14-2012, 07:55 PM   #16
Ebal
Scooby Newbie
 
Member#: 337115
Join Date: Nov 2012
Default

Well I took the uppipe off and bam a gasket was missing a 1 inch chunk out of it
Ebal is offline   Reply With Quote
Old 11-14-2012, 08:20 PM   #17
HinshawWRX
Medium Frank
Moderator
 
Member#: 140114
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Common Sense, VA
Vehicle:
2014 Porsche
GT3 (Currently on Fire)

Default

Quote:
Originally Posted by Ebal View Post
I am currently running the cobb stage 2 with catless exhaust and cobb ebcs
Curious how you are running Stage 2 tune with an EBCS as the EBCS is not supported for your tune. Unless yo are running a protune by cobb. Likely this is PART of your problem.
HinshawWRX is offline   Reply With Quote
Old 11-14-2012, 09:19 PM   #18
Ebal
Scooby Newbie
 
Member#: 337115
Join Date: Nov 2012
Default

What would that do
Ebal is offline   Reply With Quote
Old 11-14-2012, 09:22 PM   #19
jthatch12
Scooby Specialist
 
Member#: 321715
Join Date: May 2012
Chapter/Region: Tri-State
Location: Philly/SJ
Vehicle:
03 Big 16G WRX
PSM

Default

Quote:
Originally Posted by HinshawWRX

Curious how you are running Stage 2 tune with an EBCS as the EBCS is not supported for your tune. Unless yo are running a protune by cobb. Likely this is PART of your problem.
^this
jthatch12 is offline   Reply With Quote
Old 11-14-2012, 09:28 PM   #20
Ebal
Scooby Newbie
 
Member#: 337115
Join Date: Nov 2012
Default

I know but why would it run fine then a few days later not have the consultancy and how could that have anything to do with a gasket.
Ebal is offline   Reply With Quote
Old 11-14-2012, 10:48 PM   #21
Ebal
Scooby Newbie
 
Member#: 337115
Join Date: Nov 2012
Default

Consisting
Ebal is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:45 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.