Welcome to the North American Subaru Impreza Owners Club Saturday May 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-13-2012, 04:39 PM   #1
psok80
Scooby Newbie
 
Member#: 295875
Join Date: Sep 2011
Default Please help...Burning smell from engine bay!

Hello MAIC,

I was driving my 2002 WRX last week and noticed a very bad burning smell coming from my engine bay. At first I thought it was someone else's car so I ignored it. The smell went away but then it came back but this time not as strong. I pulled over to investigate. I opened the hood and couldn't smell anything and didnt see anything leaking. I drove home and the smell was gone. I've driven my car a few times since and the smell comes and goes. I cant pin point the problem. It smells almost like a burnt clutch or belt. I have an automatic so its not me burning the clutch and I checked the drive belts and they look fine. Could this be my timing belt??? Or maybe a coolant leak somewhere I cant see??? The smell is very faint when I have the hood open but I can smell it when I have the heat on and the vent open from inside the car as well. The smell seems to be coming from towards the front of the engine bay. The car seems to be driving normal.

Any advice, solution, or point me to a good Subaru mechanic would be great!

addition info: The car has no engine mods.
psok80 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:32 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.