Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-15-2012, 06:27 PM   #11
alphaproject
Scooby Newbie
 
Member#: 147588
Join Date: Apr 2007
Default

PCV Valve....lol. You know it's not working right if something is loose in it so you could even check the old one to see if it was even broken. We replaced ours but only because we had the CEL come on, but it's for a minor Evap leak that my friend ducktaped. He's eventually going to replace all the hoses instead of getting a smoke test. He used to be a mechanic. I don't think that PCV valve replacement is going to do anything...but I hope it deducts that reasons to get even more fixed.
alphaproject is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
05 Impreza RS burning oil @ 60K miles? OneDailyShot Service & Maintenance 6 05-19-2010 02:20 PM
fs: ej22 longblock from 2000 impreza burns oil bad xionide NWIC Private Classifieds 1 10-06-2009 05:04 PM
1993 Subaru Impreza burning oil at idle after oil change Joe Pollock Service & Maintenance 3 08-15-2005 11:15 PM


All times are GMT -4. The time now is 08:48 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.