Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-11-2012, 03:23 AM   #1
DabiDa
Scooby Newbie
 
Member#: 307041
Join Date: Jan 2012
Chapter/Region: BAIC
Location: Nor*Cal
Vehicle:
2002 impreza wrx
psm

Default Boost issue in 3rd,4th & 5th gear.Bad EBCS?Turbo?Confused

So my 2002 wrx started this weird issue last week and i have been trying to find out what could cause this and wanted to see if anyone on here has had this issue or can guide me a bit.I have not gotten any CEL.When i go WOT in 3rd,4th & 5th gear my boost gauge goes up to .1(16)lbs then goes down to the .05 then back to .1(16) back to .05 then goes to .15 and just bounces and the car feels like im depressing and pressing the gas while WOT i can feel the car get boost lose boost then get boost lose boost.So far i have changed out all the lines from the EBCS (2 lines) & the line after the T to the turbo and still have the issue.What ive read was EBCS,Fuel pump,02 sensor or maybe even the Cobb AP could cause a issue??Maybe a Vac leak?I have been searching to find out how to test the EBCS but no luck here are my mods.I can take vid with cam if needed to show exactly what it is doing,i also noticed that it has been killing me on gas aswell,is that a sign of the pump?

2002 Wrx
166k miles
JDM Sti V7 up pipe
Cobb Sf intake
HKS Down pipe
Tanabe Racing Med exhaust
Cobb AP Stage 2 OTS map V3.10 Map
* Registered users of the site do not see these ads.
DabiDa is offline   Reply With Quote
Old 11-11-2012, 12:46 PM   #2
NVAKeith
Scooby Newbie
 
Member#: 26525
Join Date: Oct 2002
Chapter/Region: MAIC
Location: Alexandria, VA
Vehicle:
Sold 2002 WRX :(
2011 LGT Blue

Default

My stock '02 had this issue intermittently for a few years. Sometimes it would do it everyday for a week then it wouldn't happen again for 3 months. Because it was intermittent mechanics couldn't replicate or diagnose it. Last year I replaced the BCS with a new one and the problem hasn't resurfaced.
NVAKeith is offline   Reply With Quote
Old 11-11-2012, 03:00 PM   #3
DabiDa
Scooby Newbie
 
Member#: 307041
Join Date: Jan 2012
Chapter/Region: BAIC
Location: Nor*Cal
Vehicle:
2002 impreza wrx
psm

Default

Thanks for the response ill ask my buddy if i can swap him EBCS and see what happens.Also sometimes i can keep & hold boost in 3rd and its only 4th & 5th i have the issue.One time i even just moved the lines around and the car ran fine then bam came back very weird issue..The car runs fine besides this issue and the only reason i noticed was because i was changing lanes and had to press the gas and noticed the car jerking and the gauge going crazy..
DabiDa is offline   Reply With Quote
Old 11-11-2012, 03:32 PM   #4
jthatch12
Scooby Specialist
 
Member#: 321715
Join Date: May 2012
Chapter/Region: Tri-State
Location: Philly/SJ
Vehicle:
03 Big 16G WRX
PSM

Default

Have you recently gotten your car retuned? If boost is oscillating like that then your WGDC needs to be adjusted
jthatch12 is offline   Reply With Quote
Old 11-11-2012, 10:40 PM   #5
DabiDa
Scooby Newbie
 
Member#: 307041
Join Date: Jan 2012
Chapter/Region: BAIC
Location: Nor*Cal
Vehicle:
2002 impreza wrx
psm

Default

Quote:
Originally Posted by jthatch12 View Post
Have you recently gotten your car retuned? If boost is oscillating like that then your WGDC needs to be adjusted
I have been running the Stage 2 V3.10 OTS map from Cobb for about 2-3 months with no issues then it started.I have been debating on selling the AP buying a Grimspeed EBCS & doing a pro tune now that i have 2 ECU's i can keep one stock and the other with a pro tune,Im just worried with the miles as i do not know much of the cars history i do know the Pro Tune would be best so that is were im at right now.Thank you all
DabiDa is offline   Reply With Quote
Old 11-11-2012, 10:59 PM   #6
dburgoon
NASIOC Supporter
 
Member#: 310366
Join Date: Feb 2012
Chapter/Region: South East
Location: Ft Myers, FL
Vehicle:
03 vf37'd WRB
Bugeye

Default

If you changed the hoses make sure you get the restrictor pill! I had the same problem and it was because I changed the cracked hoses from the boost controller and forgot the restrictor pill so make sure you have that
dburgoon is offline   Reply With Quote
Old 11-11-2012, 11:15 PM   #7
DabiDa
Scooby Newbie
 
Member#: 307041
Join Date: Jan 2012
Chapter/Region: BAIC
Location: Nor*Cal
Vehicle:
2002 impreza wrx
psm

Default

Quote:
Originally Posted by dburgoon View Post
If you changed the hoses make sure you get the restrictor pill! I had the same problem and it was because I changed the cracked hoses from the boost controller and forgot the restrictor pill so make sure you have that
I got the pill in the hose.I changed out the one line before and noticed that the other line was hard when checking the car out(line that goes to the intake)So just to be safe i swapped all of them out thinking that it may have just cracked etc and did not help,I have located a OEM EBCS so that will be my next step.Thanks for all the help and will update with progress aswell
DabiDa is offline   Reply With Quote
Old 11-11-2012, 11:33 PM   #8
jthatch12
Scooby Specialist
 
Member#: 321715
Join Date: May 2012
Chapter/Region: Tri-State
Location: Philly/SJ
Vehicle:
03 Big 16G WRX
PSM

Default

Quote:
Originally Posted by DabiDa
I got the pill in the hose.I changed out the one line before and noticed that the other line was hard when checking the car out(line that goes to the intake)So just to be safe i swapped all of them out thinking that it may have just cracked etc and did not help,I have located a OEM EBCS so that will be my next step.Thanks for all the help and will update with progress aswell
Dumb the stock boost control system, it's garbage. I have the gm 3 ebcs, seems to be a popular choice. Of course do this when you get a protune. you need to tune for it
jthatch12 is offline   Reply With Quote
Old 11-12-2012, 03:30 PM   #9
DabiDa
Scooby Newbie
 
Member#: 307041
Join Date: Jan 2012
Chapter/Region: BAIC
Location: Nor*Cal
Vehicle:
2002 impreza wrx
psm

Default

Yeah i have been looking at the Grimmspeed and the cobb unit the GS seems to be the popular choice i have def been looking into them and strongly leaning toward selling the AP and going pro tune.
DabiDa is offline   Reply With Quote
Old 11-16-2012, 03:48 PM   #10
DabiDa
Scooby Newbie
 
Member#: 307041
Join Date: Jan 2012
Chapter/Region: BAIC
Location: Nor*Cal
Vehicle:
2002 impreza wrx
psm

Default

Just wanted to update! Got a used OEM ebcs was told it has about 40-50k miles.All is well car feels smoother boost seems to to build slightly faster very happy thanks for all the help. Maybe look into a better system Grimspeed..
DabiDa is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:27 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.