Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-16-2012, 07:25 PM   #1
scoobyaru
Scooby Newbie
 
Member#: 303193
Join Date: Dec 2011
Location: Troy, Michigan
Vehicle:
2002 WRX
SRP

Default Looking to buy a 02 WRX. Have some concerns

Hi guys, thanks for your time. I found a dealer local with a 02 bugeye wagon WRX... Has 135k on the clock, had one owner, clean title no accidents. A some concerns. When I started it, I did the HG check while the engine was warm, having my friend look in the coolant overflow tank for bubbles, he said he saw one when it started, but when I revved it up a bit none were seen. So OK. Maybe the HG is good? The exhaust smelled sweeter than normal. Took it for a drive, when I let out the clutch to go into first I noticed a knocking/ticking noise coming from the trans. It only made the noise while I was driving, in every single gear, the noise would go with my speed, so the more gas I gave it, the more I would hear the noise. What could that be? I can tell its not a good noise, its pretty loud too. The dealer said they would get that fixed before it was sold...any advice with this? Can I trust that they fix it? My plan was to take it to oakos (subaru performance shop in my area) but they were closed at the time. Any advice throw it at me. Thanks!
scoobyaru is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:15 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.