Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Motorsports

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-10-2012, 07:07 PM   #1
leonbmx
Scooby Specialist
 
Member#: 82864
Join Date: Mar 2005
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2005 MPS Wagon HTA35
Domtuned Stage $$$$$

Default Pegasus 4430 Kill Switch ignition cut, which wire?

I have a 2005 STi, the other day I installed a pegassus racing 4430 kill switch , but when I flip the switch, nothing happens and the car just keeps running.

This is the diagram that I used:



For the ignition cut, I used the Main relay wire (Plug B136, wire 7, main switch), under the assumption that if I cut that, the engine would die.

What am I doing wrong? Is there a different wire I should have interrupted instead?
* Registered users of the site do not see these ads.
leonbmx is offline   Reply With Quote
Old 11-11-2012, 12:33 PM   #2
Token-Negro
Scooby Specialist
 
Member#: 81659
Join Date: Feb 2005
Chapter/Region: NWIC
Location: Sammamish
Vehicle:
2010 Fozzy XT
Ice Silver Metallic

Default



I used on the otherside of the weather pack connector two green wires, if my memory servers me correct they were the coil pack power wire green/red and the ignition swtich.

W= Resistor to ground
1 = Just a jumper from main power to car
Z = Ignition coil power wire Green/Red
2 = Ignition switch wire, I believe is also Green base
Token-Negro is offline   Reply With Quote
Old 11-12-2012, 10:04 AM   #3
leonbmx
Scooby Specialist
 
Member#: 82864
Join Date: Mar 2005
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2005 MPS Wagon HTA35
Domtuned Stage $$$$$

Default

As usual that looks like a work of art

However, now I am even more confused... My impression was that I needed to find a wire, cut it in half and route it through the relay. From your post it sounds like Z and 2 are different wires?
leonbmx is offline   Reply With Quote
Old 11-18-2012, 02:44 PM   #4
leonbmx
Scooby Specialist
 
Member#: 82864
Join Date: Mar 2005
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2005 MPS Wagon HTA35
Domtuned Stage $$$$$

Default

bump for confusion still here
leonbmx is offline   Reply With Quote
Old 11-18-2012, 02:55 PM   #5
Token-Negro
Scooby Specialist
 
Member#: 81659
Join Date: Feb 2005
Chapter/Region: NWIC
Location: Sammamish
Vehicle:
2010 Fozzy XT
Ice Silver Metallic

Default

Ok this makes since to me now, yes the green wire is the coil wire, that goes to the ignition normally, but you connect the Kill switch inline to the ignition. So the Green wire that’s going to the ignition switch now, cut it and have it go to Z then connect another lead from 2 back to the ignition switch.
Token-Negro is offline   Reply With Quote
Old 11-18-2012, 04:05 PM   #6
leonbmx
Scooby Specialist
 
Member#: 82864
Join Date: Mar 2005
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2005 MPS Wagon HTA35
Domtuned Stage $$$$$

Default

so which pin are we talking about then with the "green coil wire", as right now I used the "main switch" (05 STi ECU Diagram - Plug B136, wire 7, main switch)

Almost sounds like I should be using "B137, Pin 14, Ignition Switch" instead

Last edited by leonbmx; 11-18-2012 at 04:13 PM.
leonbmx is offline   Reply With Quote
Old 11-18-2012, 07:14 PM   #7
Token-Negro
Scooby Specialist
 
Member#: 81659
Join Date: Feb 2005
Chapter/Region: NWIC
Location: Sammamish
Vehicle:
2010 Fozzy XT
Ice Silver Metallic

Default

Quote:
Originally Posted by leonbmx View Post
so which pin are we talking about then with the "green coil wire", as right now I used the "main switch" (05 STi ECU Diagram - Plug B136, wire 7, main switch)

Almost sounds like I should be using "B137, Pin 14, Ignition Switch" instead
I would look at the diagram for the ignition swtich not at the ECU.
Token-Negro is offline   Reply With Quote
Old 11-18-2012, 07:21 PM   #8
leonbmx
Scooby Specialist
 
Member#: 82864
Join Date: Mar 2005
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2005 MPS Wagon HTA35
Domtuned Stage $$$$$

Default

Good point! Any leads on where on the interwebs I may find that?
leonbmx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:16 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.