Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-23-2012, 12:21 AM   #1
legacybov
Scooby Newbie
 
Member#: 285229
Join Date: Jun 2011
Default 2003 Legacy Wagon moon roof leaking....

So we found out that our Wagon has a leak coming from the passenger side rear ceiling hook (used for car seat latches).

I removed the headliner enough to see that the two drain tubes on the rear of the pan were still attached. I also flushed out both sides and made sure the drains were still letting water out.

It still looks like it is leaking and the water is dripping from where the copper pipe attaches to the pan (to the left of the drain nipple plug).

Any other ideas on why it is leaking?
* Registered users of the site do not see these ads.
legacybov is offline   Reply With Quote
Old 11-24-2012, 09:00 PM   #2
k2snow
Scooby Specialist
 
Member#: 10449
Join Date: Sep 2001
Chapter/Region: NWIC
Location: PDX, OR
Vehicle:
03 Legacy BH
Silver

Default

I just recently had the same problem on mine. the drains might be clogged and mine was leaking through the map light. I ended up just taking mine to the dealer to clean out as my normal shop couldn't figure it out.
k2snow is offline   Reply With Quote
Old 11-28-2012, 08:58 AM   #3
Charlie-III
Scooby Specialist
 
Member#: 30669
Join Date: Dec 2002
Chapter/Region: Tri-State
Location: 07456, North NJ
Vehicle:
1998 Legacy 2.5GT
Silver Sleeper Wagon

Default

Likely clogged drain tubes. Letting leaves & crap build up, or not washing enough usually makes this worse.
Sometimes snaking a piece of 18ga building wire down the tube will clear it out.
Charlie-III is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:35 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.