Welcome to the North American Subaru Impreza Owners Club Monday October 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-25-2012, 02:13 AM   #1
91legacyawdturbo
Scooby Newbie
 
Member#: 177706
Join Date: Apr 2008
Default obd-2 q's

I'm in the process of wiring in an jdm v7 sti into a 97 legacy outback, I'm trying to figure out why the obd-2 port isn't working. I have the powers and grounds working properly, There's a few wires I'm not sure when it
comes to wiring. what I can figure out because the fsm and other diagrams are wrong when it comes to pin 8 is actually pin 9 which is the ignition power.
pin# 1: not used
pin# 2: ssm/gst communications A134 pin 21 ecu side
pin# 3: not used
pin# 4: Ground
pin# 5: ground
pin# 6: not used
pin# 7: not used
pin# 8: not used
pin # 9: ignition power (jdm harness black/ red stripe)
pin# 10: not used
pin# 11: not used
pin# 12: brown/ white stripe ?
pin# 13: Green/red stripe ?
pin# 14: red/ white stripe ?
pin# 15: not used
Pin# 16: battery power

So pin 12/13/14 where do these land at the ecu side? and which is the k-line and l-line?
Any help please Thanks, Brian.
* Registered users of the site do not see these ads.
91legacyawdturbo is offline   Reply With Quote
Old 11-25-2012, 02:00 PM   #2
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

My data shows the following:

OBD-2 Pin ECU pin
4-----------92
5-----------91
10----------93

12 gnd
13 gnd
Cougar4 is offline   Reply With Quote
Old 11-27-2012, 10:24 PM   #3
91legacyawdturbo
Scooby Newbie
 
Member#: 177706
Join Date: Apr 2008
Default

Quote:
Originally Posted by Cougar4 View Post
My data shows the following:

OBD-2 Pin ECU pin
4-----------92
5-----------91
10----------93

12 gnd
13 gnd


Can you tell me what the 91-92 pins are? end check connector? signal 1 & 2??
91legacyawdturbo is offline   Reply With Quote
Old 11-28-2012, 04:11 AM   #4
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

The info doesn't show there function, just where they go.
Cougar4 is offline   Reply With Quote
Old 11-28-2012, 05:59 PM   #5
91legacyawdturbo
Scooby Newbie
 
Member#: 177706
Join Date: Apr 2008
Default

Quote:
Originally Posted by Cougar4 View Post
The info doesn't show there function, just where they go.

Yeah that's where I'm getting to, I realized inwas looking at the connector wrong and upside down, I have everything but those two wired in. The biggest problem is that I'm wiring the v7 connector to the v7 harness/Ecu, some how the wires got cut
While strippig the bulk head harness away from the engine harness . 4-5 on the v7 fsm doesn't show up as 4-5 neither or in the 02/03 fsm. The 97 ecu wiring diagram doesn't even show 91/92/93 on the pin diagram. I tried to trace them on a 03 wrx and they correspond with the grounds if you use a 6 volt battery plugged into the obd connector and take a volt meter to the ecu connectors. With the ecu disconnected.

Last edited by 91legacyawdturbo; 11-28-2012 at 06:04 PM.
91legacyawdturbo is offline   Reply With Quote
Old 11-30-2012, 09:40 PM   #6
jose_a_v31
Scooby Newbie
 
Member#: 280138
Join Date: Apr 2011
Chapter/Region: South East
Location: Jacksonville, FL
Vehicle:
2006 Impreza STi
WRB

Default Android app

There is an app for Android, its Electrodriod. It has every pinout for almost all connectors. OBD-II is in the list.

Last edited by jose_a_v31; 11-30-2012 at 09:48 PM. Reason: additional info
jose_a_v31 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:36 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.