Welcome to the North American Subaru Impreza Owners Club Thursday October 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-02-2012, 11:07 PM   #1
mikemike616
Scooby Newbie
 
Member#: 308317
Join Date: Jan 2012
Vehicle:
2006 WRX
Black

Default Peak Boost Levels Dropping

A few months ago I got my WRX road tuned by IA Performance and we had it peaking at about 16.5 psi. I swapped in the GS EBCS just before the tune and on the first WOT run I was only hitting 10 pounds. He had me double check that the EBCS was hooked up correctly and I triple checked that it was. He had me tighten up the wastegate actuator arm a bit and that still didn't help achieve higher boost levels. So he cranked up the wastegate duty cycle to around 90% which had me a bit worried. But being that I am pretty new to turbo cars and know nothing about tuning, I asked him and he reassured me that it would be fine. I've noticed over the last few months that I'm hitting lower and lower peak boost levels at WOT and now I'm maxing it at about 12-13 pounds.

Is running the wastegate at 90% duty cycle wearing it out and making the wastegate door open sooner or wider or something and dropping my boost levels? Does this IA Performance guy have no idea what he's doing or what? And if the wastegate is bad, can I replace it or fix it?

Thanks.

/Long story bro.
mikemike616 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:40 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.