Welcome to the North American Subaru Impreza Owners Club Thursday September 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-03-2012, 12:22 PM   #25
promted
Scooby Newbie
 
Member#: 282888
Join Date: May 2011
Chapter/Region: RMIC
Location: SLC, Utah
Vehicle:
2002 WRX
Rally Blue

Default

I just put in the ebay version the other day. I did the same as most by cutting off the old one, lubing the new one and sliding it in. It didn't seem to be fitting quite right and I ended up taking it out 3 times to triple check everything. By the 3rd time, I was pro and could slip in the inlet easy peasy. The connection to the turbo was really tough, but it ended up working for me by slipping a hose clamp on the inlet, tightening a little bit, letting all lube (WD-40) dry off so the inlet was sticky enough to hold the hose clamp, then wedging a flat head against the corner bolt on the intake and the screw on the hose clamp and slowly prying in onto the turbo. The first go pulled the hose clamp off, so I put it back on and tightened a little more and it went right on. The BPV line was definitely tough as well like most have said. I battled with it for a while then got smart and slipped a shoe lace around the inlet connection and just lifted up. That pulled up the piece enough for me to get on the BPV hose with my other hand. Hope that'll help someone.
promted is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:13 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.