Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-03-2012, 11:59 AM   #14726
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by subiedude676 View Post
Can someone tell me if I am the only one lacking a light in the glove box on my 2012 2.0i, or is there not supposed to be one on our models?
i have a led one in mine? do you have the base model or some higher level trim?
* Registered users of the site do not see these ads.
flyboy1100 is offline   Reply With Quote
Old 12-03-2012, 12:16 PM   #14727
danstheman7
Scooby Newbie
 
Member#: 331089
Join Date: Sep 2012
Chapter/Region: Tri-State
Location: Bellmore NY
Vehicle:
2012 Impreza Base
DGM/Dark Grey Metallic

Default

Quote:
Originally Posted by flyboy1100 View Post
i have a led one in mine? do you have the base model or some higher level trim?
I have the base 2.0i, and do not have any light at all in my glove box. 2012.
danstheman7 is offline   Reply With Quote
Old 12-03-2012, 12:21 PM   #14728
subiedude676
Scooby Newbie
 
Member#: 241369
Join Date: Mar 2010
Chapter/Region: MAIC
Location: Emmaus, PA
Vehicle:
2012 2.0i Premium
Ice Silver Metallic

Default

Quote:
Originally Posted by flyboy1100 View Post

i have a led one in mine? do you have the base model or some higher level trim?
I have a premium model all weather package and moonroof. I thought that the upgraded models would have it but I guess mine doesn't.
subiedude676 is offline   Reply With Quote
Old 12-03-2012, 12:30 PM   #14729
Zauri
Scooby Newbie
 
Member#: 333487
Join Date: Sep 2012
Chapter/Region: MAIC
Location: MD
Vehicle:
2012 Impreza 4DR 2.0
Limited DGM CVT

Default

Quote:
Originally Posted by subiedude676 View Post
I have a premium model all weather package and moonroof. I thought that the upgraded models would have it but I guess mine doesn't.
Limited '12.. No light either
Zauri is offline   Reply With Quote
Old 12-03-2012, 12:33 PM   #14730
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by Zauri View Post
Limited '12.. No light either
are you sure? have actually looked inside? (not supposed to be a snide remark) i will doublecheck mine tonight, i swear it has one
flyboy1100 is offline   Reply With Quote
Old 12-03-2012, 12:39 PM   #14731
subiedude676
Scooby Newbie
 
Member#: 241369
Join Date: Mar 2010
Chapter/Region: MAIC
Location: Emmaus, PA
Vehicle:
2012 2.0i Premium
Ice Silver Metallic

Default

Quote:
Originally Posted by flyboy1100 View Post

are you sure? have actually looked inside? (not supposed to be a snide remark) i will doublecheck mine tonight, i swear it has one
There's been multiple times that I have opened the glove box at night with the headlights and parking lights turned on while the car is in park, in motion etc and no light for me. My 2008 2.5i base model with no upgrades at all even had a light in the glove box. Wonder why they took it out on '12+ models.
subiedude676 is offline   Reply With Quote
Old 12-03-2012, 12:46 PM   #14732
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by subiedude676 View Post
There's been multiple times that I have opened the glove box at night with the headlights and parking lights turned on while the car is in park, in motion etc and no light for me. My 2008 2.5i base model with no upgrades at all even had a light in the glove box. Wonder why they took it out on '12+ models.
i am pretty dang sure mine has one, i remember seeing and saying to myself "cool, led glovebox light"
flyboy1100 is offline   Reply With Quote
Old 12-03-2012, 12:50 PM   #14733
Zeeper
Scooby Specialist
 
Member#: 299286
Join Date: Oct 2011
Chapter/Region: NESIC
Location: Upstate NY
Vehicle:
2015 WRX CVT
White

Default

There is one, but it only turns on if your headlights are on (at least in my Sport).
Zeeper is online now   Reply With Quote
Old 12-03-2012, 12:54 PM   #14734
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by Zeeper View Post
There is one, but it only turns on if your headlights are on (at least in my Sport).
horray, i'm not crazy!
flyboy1100 is offline   Reply With Quote
Old 12-03-2012, 01:05 PM   #14735
Zauri
Scooby Newbie
 
Member#: 333487
Join Date: Sep 2012
Chapter/Region: MAIC
Location: MD
Vehicle:
2012 Impreza 4DR 2.0
Limited DGM CVT

Default

Quote:
Originally Posted by Zeeper View Post
There is one, but it only turns on if your headlights are on (at least in my Sport).
Explains alot. I only look in that thing when the car is off lol

SN: Happen to see a silver XV out in Waldorf (first time I seen it in person yesterday)
I must say it looks rather nice

Back on topic now. There is a slight "whine" that I hear at certain times while driving. It's coming from the right side front/ or just right in general(i think). Can't really tell what it is since it pops up randomly but tends be come around around 60mph+ and usually during highway driving. Any clue?
Zauri is offline   Reply With Quote
Old 12-03-2012, 01:14 PM   #14736
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Tire noise that changes depending on the road's surface?
sgoldste01 is offline   Reply With Quote
Old 12-03-2012, 01:35 PM   #14737
Zauri
Scooby Newbie
 
Member#: 333487
Join Date: Sep 2012
Chapter/Region: MAIC
Location: MD
Vehicle:
2012 Impreza 4DR 2.0
Limited DGM CVT

Default

Quote:
Originally Posted by sgoldste01 View Post
Tire noise that changes depending on the road's surface?
sounds more like an electrical winding noise. Cars running fine, no grinding, no wobble or nothing like that. You know the high pitch you get when you turn a vacuum cleaner on? it kinda sounds like that, though a bit muffled. Can only hear it when it's dead quiet in the car and only comes up when I'm up at speed
Zauri is offline   Reply With Quote
Old 12-03-2012, 02:14 PM   #14738
jr0bb5
Scooby Specialist
 
Member#: 315353
Join Date: Apr 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sp Prem
5MT OBP/DGM

Default

I have the glove box LED in my 12 Sport Premium. BTW, does anyone know what size LED that is so I can change it out with something a little brighter and less yellowish?
jr0bb5 is offline   Reply With Quote
Old 12-03-2012, 02:15 PM   #14739
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by jr0bb5 View Post
I have the glove box LED in my 12 Sport Premium. BTW, does anyone know what size LED that is so I can change it out with something a little brighter and less yellowish?
I thought it was already pretty white in color, any more and it would be blue
flyboy1100 is offline   Reply With Quote
Old 12-03-2012, 02:19 PM   #14740
jr0bb5
Scooby Specialist
 
Member#: 315353
Join Date: Apr 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sp Prem
5MT OBP/DGM

Default

Quote:
Originally Posted by flyboy1100 View Post
I thought it was already pretty white in color, any more and it would be blue
Really? Mines a very dim, yellowish color for some reason...
jr0bb5 is offline   Reply With Quote
Old 12-03-2012, 02:29 PM   #14741
von Wachtstain
Scooby Newbie
 
Member#: 52726
Join Date: Jan 2004
Location: CT, USA
Default

Quote:
Originally Posted by Zauri View Post

sounds more like an electrical winding noise. Cars running fine, no grinding, no wobble or nothing like that. You know the high pitch you get when you turn a vacuum cleaner on? it kinda sounds like that, though a bit muffled. Can only hear it when it's dead quiet in the car and only comes up when I'm up at speed
Be happy you don't hear what I hear from my car. At times when I hit approximately 60mph I have this weird loud grind from front so maybe transmission. It sound like driving over rumble strips on highway. No vibration, car drives normal. I think it might be cvt belt (chain!?) Once I take my foot of gas pedal or press it harder it goes away. Sometimes it happens at lower speeds too but very rarely. Dealership mechanics think I'm crazy since they can't reproduce it. I can't believe I am the only one since I have not see anybody complaining about it here. If that went away somehow this car would be perfect.
von Wachtstain is offline   Reply With Quote
Old 12-03-2012, 02:29 PM   #14742
Zeeper
Scooby Specialist
 
Member#: 299286
Join Date: Oct 2011
Chapter/Region: NESIC
Location: Upstate NY
Vehicle:
2015 WRX CVT
White

Default

mine is dim yellow also. I almost never open the glove box, so I haven't really thought about changing it.
Zeeper is online now   Reply With Quote
Old 12-03-2012, 02:36 PM   #14743
Penguin44
Scooby Newbie
 
Member#: 315883
Join Date: Apr 2012
Chapter/Region: E. Canada
Vehicle:
2012 IMPREZA
Silver

Default

Quote:
Originally Posted by danstheman7 View Post

I have the base 2.0i, and do not have any light at all in my glove box. 2012.
Same. Base, no glove light
Penguin44 is offline   Reply With Quote
Old 12-03-2012, 02:36 PM   #14744
subiedude676
Scooby Newbie
 
Member#: 241369
Join Date: Mar 2010
Chapter/Region: MAIC
Location: Emmaus, PA
Vehicle:
2012 2.0i Premium
Ice Silver Metallic

Default

I just went out to my car on my lunch break. It's parked in the basement of a parking garage and I turned my car on and the lights and there is no light inside of my glove box. I looked around everywhere for one. No light at all.

I would have thought it would have been put on a premium over a base model since people with limiteds are saying they have one.
subiedude676 is offline   Reply With Quote
Old 12-03-2012, 02:47 PM   #14745
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by subiedude676 View Post
I just went out to my car on my lunch break. It's parked in the basement of a parking garage and I turned my car on and the lights and there is no light inside of my glove box. I looked around everywhere for one. No light at all.

I would have thought it would have been put on a premium over a base model since people with limiteds are saying they have one.
i have a sport premium, sorry you don't have one (the light, not the car)

Last edited by flyboy1100; 12-03-2012 at 07:05 PM.
flyboy1100 is offline   Reply With Quote
Old 12-03-2012, 06:06 PM   #14746
aeoporta
Scooby Specialist
 
Member#: 334126
Join Date: Oct 2012
Chapter/Region: Tri-State
Location: New York
Vehicle:
2013 5mt Sp Premium
Venetian Red & Dark Gray

Default

whinning noise could be transmission or could be weather stripping by your window, maybe it went out of alignment so you are hearing wind noise. I would venture it was more the weather stripping probably near one of the side mirrors or such.

flyboy1100 oh behave
aeoporta is offline   Reply With Quote
Old 12-03-2012, 06:07 PM   #14747
JohnNevets
Scooby Newbie
 
Member#: 331193
Join Date: Sep 2012
Location: Central Wisconsin
Vehicle:
2012 Impreza
Camellia Red Pearl

Default

My '12 4 door premium has the light in the glove box. It's just right of the center part at the top that sticks out. The holder feels a little loose, like it is a separate module, not just molded into the surrounding plastic. Oh, and it's yellow and turns on when I turn on the lights no matter if the car is on or off. I don't think this would make a difference, but I have the winter package as well.
JohnNevets is offline   Reply With Quote
Old 12-03-2012, 06:29 PM   #14748
gt601
Scooby Newbie
 
Member#: 308387
Join Date: Jan 2012
Vehicle:
2012 Impreza Sport
white

Default

My sport premium has the glovebox light as well.
gt601 is offline   Reply With Quote
Old 12-03-2012, 06:48 PM   #14749
von Wachtstain
Scooby Newbie
 
Member#: 52726
Join Date: Jan 2004
Location: CT, USA
Default

Orange light in glovebox. Limited 2.0
von Wachtstain is offline   Reply With Quote
Old 12-03-2012, 06:49 PM   #14750
Commander Keen
Scooby Specialist
 
Member#: 319157
Join Date: May 2012
Chapter/Region: MAIC
Vehicle:
2012 Impreza 4DR 5MT

Default

My non-sport premium has it as well. It appears to be a single amber LED that's tied in with the parking lights.
Commander Keen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 Impreza STI concept art khaki_man Member's Car Gallery 37 03-15-2011 03:02 AM
Newsflash: 2012 Impreza looks like BigElm's Butt WagonMonster Off-Topic 4 02-28-2011 08:11 PM
2012 Impreza Concept Zakster87 General Community 14 11-17-2010 05:09 PM
Possibly looking into a 2011 or 2012 Impreza? xenonk Mid Atlantic Impreza Club -- MAIC 1 08-05-2010 10:48 PM


All times are GMT -4. The time now is 09:52 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.