Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-03-2012, 05:35 PM   #1
datzun90
Scooby Newbie
 
Member#: 331317
Join Date: Sep 2012
Default Wagon w/ STi suspension Camber Issues

Hey Everyone, I just recently finished putting a complete '04 STi suspension in my '05 2.5 RS wagon. The rear went together perfectly and I have just a slight amount of negative camber. However, when it comes to the front I have some issues. I used 04 STi front LCA's and 04 STi front struts with 07 WRX sedan knuckes. However, no matter what I do it looks like I have .5 - 1 deg positive camber on the driver's side and like 5 deg on the passenger side. I realize the right side is totally out of whack but I figured that with the driver's side I should be able to get a small amount of negative camber. I think maybe both of the knuckles I bought are wrecked. I just wanted to make sure I didn't miss something, was I supposed to use the wagon knuckles even though I used sedan arms and struts? Should this setup allow me to get at least a little bit of negative camber (like -.5 deg). I have included a few pics below and these are what the wheels look like with the camber bolts fully maxed out. Its hard to tell in the first picture but the wheel has slightly positive camber ( I figured with stock bolts I should be able to get a least a little bit of negative camber up front)







I apologize if this has been covered before but its a bit of an emergency seeing as I need to get this on the road ASAP. Thanks for all of your help.
* Registered users of the site do not see these ads.
datzun90 is offline   Reply With Quote
Old 12-03-2012, 05:50 PM   #2
jamal
Scooby Guru
 
Member#: 71875
Join Date: Oct 2004
Location: Montana
Vehicle:
98 2.5GT
my wheels fit

Default

Yeah, something is bent, likely the upright. If the strut was that bent you would be able to tell just by looking at it.

The knuckles are the same between sedan, wagon, and 04 sti so you didn't need to change them for the struts to work.
jamal is offline   Reply With Quote
Old 12-03-2012, 06:11 PM   #3
Bikelok
Scooby Specialist
 
Member#: 254851
Join Date: Aug 2010
Chapter/Region: BAIC
Location: Nor-Cal Bay Area
Vehicle:
2002 Wrx wagon 5mt
PSM

Default

Put your old knuckles on. Unless they were damaged, they will work just fine.
Bikelok is offline   Reply With Quote
Old 12-03-2012, 06:13 PM   #4
Bikelok
Scooby Specialist
 
Member#: 254851
Join Date: Aug 2010
Chapter/Region: BAIC
Location: Nor-Cal Bay Area
Vehicle:
2002 Wrx wagon 5mt
PSM

Default

If it still is not right after doing that then something else is bent.
Bikelok is offline   Reply With Quote
Old 12-04-2012, 11:16 AM   #5
datzun90
Scooby Newbie
 
Member#: 331317
Join Date: Sep 2012
Default

Quote:
Originally Posted by Bikelok View Post
Put your old knuckles on. Unless they were damaged, they will work just fine.
Both ball joint pinch bolts broke off in the spindles so instead of trying to get them out I figured I'd get some nice used ones.
datzun90 is offline   Reply With Quote
Old 12-04-2012, 12:52 PM   #6
Bikelok
Scooby Specialist
 
Member#: 254851
Join Date: Aug 2010
Chapter/Region: BAIC
Location: Nor-Cal Bay Area
Vehicle:
2002 Wrx wagon 5mt
PSM

Default

Then drill out the broken bolts or get better knuckles.
Bikelok is offline   Reply With Quote
Old 12-06-2012, 09:35 AM   #7
datzun90
Scooby Newbie
 
Member#: 331317
Join Date: Sep 2012
Default

Thanks for all of the feedback guys. I went and got another set of knuckles yesterday. I'll give them a try today and see how it looks.
datzun90 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:50 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.