Welcome to the North American Subaru Impreza Owners Club Thursday September 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-02-2012, 03:14 PM   #126
Geerolla
Scooby Specialist
 
Member#: 264827
Join Date: Nov 2010
Chapter/Region: NWIC
Location: WA, USA
Vehicle:
2011 2.5i 5D
DGM

Default

Many thanks for this. Set Loudness off and put it on Through Mode... much, much better.
* Registered users of the site do not see these ads.
Geerolla is offline   Reply With Quote
Old 12-06-2012, 09:21 PM   #127
SubiGT
Scooby Newbie
 
Member#: 195841
Join Date: Nov 2008
Chapter/Region: BAIC
Location: NorCal
Default

2012 2.0i Sport Premium 5MT, Kicker Audio Package/Sub. Wife was pulling her hair out, that's how craptacular this thing sounded.

Before, was faded 3R, B -1. Just did the Loud off, EQ through. O.M.G. Now F0, B2, M1, T3. Sounds sooo much better. The Kickers actually do a pretty good job now!!

I had checked this thread and the others in the past, but a buddy told me it was updated with hidden menus for the Premium. Awesome!!

Didn't tell her I made adjustments. See if she figures it out....
SubiGT is offline   Reply With Quote
Old 12-07-2012, 03:33 PM   #128
riccnick
Scooby Newbie
 
Member#: 311152
Join Date: Feb 2012
Location: Home
Vehicle:
2012 Impreza
Ice Silver Metallic

Default

Did this the other day, so much less "booming" now. I also balanced the eq so that the bass was set to 0, the mid at -5, and the treb at -2. gives the same balance that I had before, but its not over-driving the speakers to get it. Sounds a ton better.
riccnick is offline   Reply With Quote
Old 12-07-2012, 04:12 PM   #129
wondras
Scooby Newbie
 
Member#: 337076
Join Date: Nov 2012
Chapter/Region: NESIC
Vehicle:
2013 XV Crosstrek

Post

I'm so happy this is working out for people!

I just learned that the loudness sometimes turns itself back on if the battery is disconnected for a long period of time. It's strange that a hidden setting wouldn't be persistent, but hey, at least it's there.

It *does* remember the Sedan/Wagon/Through EQ setting, though.

Last edited by wondras; 12-20-2012 at 02:24 PM.
wondras is offline   Reply With Quote
Old 12-08-2012, 05:12 PM   #130
DKsiazek
Scooby Newbie
 
Member#: 314375
Join Date: Mar 2012
Chapter/Region: Tri-State
Location: Syracuse, NY
Vehicle:
2012 Impreza Sport
Marine Blue Pearl

Default

Thank you for this hidden option!

I was really disappointed with the stock stereo sound, now at least I am okay with it till I replace the HU early next year. The default EQ settings seemed to hide entire segments of frequency playback, heavy bass in some frequencies, none in others. I kind of want to know how they came upon that stock EQ.
DKsiazek is offline   Reply With Quote
Old 12-10-2012, 10:43 PM   #131
mixplate
Scooby Newbie
 
Member#: 340257
Join Date: Dec 2012
Location: NorCal
Vehicle:
2011 WRX Limited
SWP

Default

Another happy owner here! Thanks to all who made this possible!! I was ready to go out and buy some speakers! I still may buy a small sub later to give it some bass though...
mixplate is offline   Reply With Quote
Old 12-10-2012, 10:44 PM   #132
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by DKsiazek View Post
Thank you for this hidden option!

I was really disappointed with the stock stereo sound, now at least I am okay with it till I replace the HU early next year. The default EQ settings seemed to hide entire segments of frequency playback, heavy bass in some frequencies, none in others. I kind of want to know how they came upon that stock EQ.
people in their early 20's want bass
flyboy1100 is offline   Reply With Quote
Old 12-11-2012, 04:07 AM   #133
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Folks -- please post your radio model number (the one printed on the front), especially if it's a new one nobody else has documented here.
SVXdc is offline   Reply With Quote
Old 12-11-2012, 10:49 PM   #134
DKsiazek
Scooby Newbie
 
Member#: 314375
Join Date: Mar 2012
Chapter/Region: Tri-State
Location: Syracuse, NY
Vehicle:
2012 Impreza Sport
Marine Blue Pearl

Default

Quote:
Originally Posted by flyboy1100 View Post
people in their early 20's want bass
I am in my mid 20's... I do like bass, but only if it is clean. Booming sucks.
DKsiazek is offline   Reply With Quote
Old 12-12-2012, 11:22 AM   #135
db9
Scooby Newbie
 
Member#: 302440
Join Date: Nov 2011
Default Additional settings for SAT available?

While the Stereo in my 2012 Forester Touring (CP625U1) is OK I have a issue with the built in SAT side of the unit.
Can someone tell me why the display can't work like most FM stations, when on FM - the display can be set to scroll the station, artist and song.. so why can't the SAT system do the same? Is there a firmware upgrade or setting that I'm missing?

Thanks
db9 is offline   Reply With Quote
Old 12-12-2012, 11:35 AM   #136
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by db9 View Post
While the Stereo in my 2012 Forester Touring (CP625U1) is OK I have a issue with the built in SAT side of the unit.
Can someone tell me why the display can't work like most FM stations, when on FM - the display can be set to scroll the station, artist and song.. so why can't the SAT system do the same? Is there a firmware upgrade or setting that I'm missing?

Thanks
That would be nice
flyboy1100 is offline   Reply With Quote
Old 12-13-2012, 04:57 PM   #137
msuth1
Scooby Newbie
 
Member#: 338505
Join Date: Nov 2012
Default

Quote:
Originally Posted by db9 View Post
While the Stereo in my 2012 Forester Touring (CP625U1) is OK I have a issue with the built in SAT side of the unit.
Can someone tell me why the display can't work like most FM stations, when on FM - the display can be set to scroll the station, artist and song.. so why can't the SAT system do the same? Is there a firmware upgrade or setting that I'm missing?

Thanks
This has also been driving me insane. Every mode scrolls except SAT. And that's the mode I use most! Everyone at Subaru has told me it just is the way it is and is likely an oversight.
msuth1 is offline   Reply With Quote
Old 12-13-2012, 09:55 PM   #138
Jejunum
Scooby Specialist
 
Member#: 15773
Join Date: Feb 2002
Chapter/Region: MWSOC
Location: Madison
Vehicle:
2011 Impreza WRX
Silver

Default

Quote:
Originally Posted by db9 View Post
While the Stereo in my 2012 Forester Touring (CP625U1) is OK I have a issue with the built in SAT side of the unit.
Can someone tell me why the display can't work like most FM stations, when on FM - the display can be set to scroll the station, artist and song.. so why can't the SAT system do the same? Is there a firmware upgrade or setting that I'm missing?

Thanks

our (2011 wrx) mp3 via usb and cd doesn't scroll either.
Jejunum is offline   Reply With Quote
Old 12-14-2012, 12:05 PM   #139
screemindemon
Scooby Newbie
 
Member#: 340596
Join Date: Dec 2012
Location: missouri
Vehicle:
2011 Impreza2.5iPrem
white

Default Worked perfectly!

Quote:
Originally Posted by wondras View Post
YES, WE CAN!

I just picked up a 2013 Crosstrek with the CM621UB HU. (Do I get partial credit for having most of an Impreza?) By piecing together info from various posts here, the service manual, and documents filed with the FCC, I figured out that it *is* possible to disable both the loudness and fixed EQ.

To turn loudness on or off:

With the unit ON, press and hold 1, 6, and TUNE (right knob.) The display shows LOUD OFF or LOUD ON.



To disable fixed EQ:

With the unit OFF, press one of these combinations of buttons:

1 + 2 + TUNE for SEDAN
1 + 3 + TUNE for WAGON
1 + 4 + TUNE for THROUGH MODE



With these "features" disabled, it sounds significantly less awful, especially at lower volume levels. This should make it a much better candidate for use with upgraded speakers, or a line out converter and amps. From the schematics, I think it would be fairly easy to add proper RCA line outputs as well.

I don't know if these keys will work on earlier models, but hopefully they do.

Fantastic forum you've got here!
Muchas gracias! Both loudness and eq changes worked perfectly on my 2011 impreza 2.5i premium (CZ624U1). Might leave HU in a while longer and upgrade speakers / amp first!
screemindemon is offline   Reply With Quote
Old 12-14-2012, 01:37 PM   #140
Commander Keen
Scooby Specialist
 
Member#: 319157
Join Date: May 2012
Chapter/Region: MAIC
Vehicle:
2012 Impreza 4DR 5MT

Default

Thank you wondras and JohnNevets! I knew the components I'm running were capable of better sound. I was ready to give up on this head unit. I have it set to through mode, no loudness, flat tone. The improvement in clarity and imaging is significant and I no longer have to run bass at -7.

I also installed a subwoofer recently and was driving myself mad constantly adjusting the gain thanks to the 8dB swings of the loudness feature. Bass is consistent now and blends in much better.

Last edited by Commander Keen; 12-14-2012 at 04:48 PM.
Commander Keen is offline   Reply With Quote
Old 12-20-2012, 09:42 AM   #141
nightdown fox
Scooby Specialist
 
Member#: 309636
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
2015 STI LE
WRB on Gold!

Default

Wow, you guys are amazing.... I gave up trying to find hidden settings for my CZ624U1 (12 WRX Limited sedan) after finding out most other Subie radios had them...

Quote:
Originally Posted by DKsiazek View Post
I was really disappointed with the stock stereo sound, now at least I am okay with it till I replace the HU early next year.
This. I stumbled on this thread trying to look up 96SVX info since I'm buying a AVIC-Z140BH early next year... Low and behold, the answers I've been searching for since I bought this car.

Loudness off, Through Mode: Suddenly, a wild subwoofer appears! I have a Rockford 2-channel pushing a Rockford 12 in the trunk, and I thought a bass bomb went off on this setting. Definitely cost me some ear health, use caution with this one.

Loudness off, Hatch Mode: Sounds less boomy than Through Mode, but definitely more boomy than Sedan mode. Obviously I'm running the sub off the rear speakers, probably the reason.

Loudness off, Sedan Mode: The Goldilocks fav porridge for my setup. The loudness off makes the sound at least passable until I get the new unit.
nightdown fox is offline   Reply With Quote
Old 12-20-2012, 11:32 AM   #142
bigalpha
Scooby Newbie
 
Member#: 110485
Join Date: Mar 2006
Chapter/Region: SWIC
Location: AZ
Vehicle:
2011 Impreza Outback
Blue

Default

Quote:
Originally Posted by carse View Post
CZ624U1

Loundness works but none of the EQ options.
Same HU - EQ options work, but not loudness.
bigalpha is offline   Reply With Quote
Old 12-20-2012, 01:15 PM   #143
screemindemon
Scooby Newbie
 
Member#: 340596
Join Date: Dec 2012
Location: missouri
Vehicle:
2011 Impreza2.5iPrem
white

Default

Strangely, i was able to adjust the eq a few days ago. Today, i went to adjust and hu is behaving different. When this worked, "subaru" was displayed on hu. Now when i try, subaru displays but disappears rather quickly and hu goes dark.?
screemindemon is offline   Reply With Quote
Old 12-20-2012, 01:28 PM   #144
screemindemon
Scooby Newbie
 
Member#: 340596
Join Date: Dec 2012
Location: missouri
Vehicle:
2011 Impreza2.5iPrem
white

Default

Oops nevermind. It didnt respond because i was selecting option it was already set on. If you do this, it wont display anything.
screemindemon is offline   Reply With Quote
Old 12-20-2012, 01:34 PM   #145
bigalpha
Scooby Newbie
 
Member#: 110485
Join Date: Mar 2006
Chapter/Region: SWIC
Location: AZ
Vehicle:
2011 Impreza Outback
Blue

Default

1 + 6 + TUNE still doesn't change the loudness for me.
bigalpha is offline   Reply With Quote
Old 12-20-2012, 02:23 PM   #146
wondras
Scooby Newbie
 
Member#: 337076
Join Date: Nov 2012
Chapter/Region: NESIC
Vehicle:
2013 XV Crosstrek

Default

Quote:
Originally Posted by nightdown fox View Post
Loudness off, Through Mode: Suddenly, a wild subwoofer appears! I have a Rockford 2-channel pushing a Rockford 12 in the trunk, and I thought a bass bomb went off on this setting. Definitely cost me some ear health, use caution with this one.
Back in this post you can see that the bass is seriously cut to the rears in the sedan and wagon EQ modes. I suggested caution to avoid damage to the rears, but I didn't think about the ramifications of a sub on the rear outputs.


Quote:
Originally Posted by nightdown fox View Post
Loudness off, Hatch Mode: Sounds less boomy than Through Mode, but definitely more boomy than Sedan mode.
Which model do you have? When I tested the CZ624U1, sedan and wagon measurements appeared to be identical. It's possible I mixed them up somehow, though.


Quote:
Originally Posted by riccnick View Post
Did this the other day, so much less "booming" now. I also balanced the eq so that the bass was set to 0, the mid at -5, and the treb at -2. gives the same balance that I had before, but its not over-driving the speakers to get it. Sounds a ton better.
These settings work well for me with the stock non-upgrade 6-speaker system. I dropped the treble another notch or two and haven't touched it since. At medium-high volumes, I'd go so far as to say it sounds "good."


Quote:
Originally Posted by bigalpha View Post
1 + 6 + TUNE still doesn't change the loudness for me.
Are you doing this with the radio turned on? The EQ has to be set with the radio OFF, and the loudness is set with the radio ON.

Perhaps a video would be helpful...? It's easier to show than to describe.

Last edited by wondras; 12-20-2012 at 02:44 PM.
wondras is offline   Reply With Quote
Old 12-20-2012, 02:38 PM   #147
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by bigalpha View Post
1 + 6 + TUNE still doesn't change the loudness for me.
all 3 at the exact same time? it only works if you get them all at the same time
flyboy1100 is offline   Reply With Quote
Old 12-20-2012, 02:40 PM   #148
bigalpha
Scooby Newbie
 
Member#: 110485
Join Date: Mar 2006
Chapter/Region: SWIC
Location: AZ
Vehicle:
2011 Impreza Outback
Blue

Default

Quote:
Originally Posted by wondras View Post
Are you doing this with the radio turned on? The EQ has to be set with the radio OFF, and the loudness is set with the radio ON.

Perhaps a video would be helpful...? It's easier to show than the describe.
Oh ...

I'm a dumbass
bigalpha is offline   Reply With Quote
Old 12-20-2012, 10:24 PM   #149
Sti_Kent
Scooby Newbie
 
Member#: 290645
Join Date: Aug 2011
Chapter/Region: South East
Location: S.E. Louisiana
Vehicle:
2011 Sti Hatch
SWP

Default

Im in a 2011 sti hatch, going to try playing with the radio tonight wish me luck!
Hopefully I will return with many thanks for the thread.
Sti_Kent is offline   Reply With Quote
Old 12-20-2012, 10:58 PM   #150
nightdown fox
Scooby Specialist
 
Member#: 309636
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
2015 STI LE
WRB on Gold!

Default

Quote:
Originally Posted by wondras View Post
Back in this post you can see that the bass is seriously cut to the rears in the sedan and wagon EQ modes. I suggested caution to avoid damage to the rears, but I didn't think about the ramifications of a sub on the rear outputs.
Haha yeah I saw that post, but I had no idea it would be THAT ridiculous!

Quote:
Originally Posted by wondras View Post
Which model do you have? When I tested the CZ624U1, sedan and wagon measurements appeared to be identical. It's possible I mixed them up somehow, though.
I've got the CZ624U1 and I could hear a difference based on the sub... But like butt dyno versus real dyno, my experience is completely subjective to your actual measurements.
nightdown fox is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2011+ Impreza head unit into 2009? codingparadox Car Audio, Video & Security 6 12-31-2011 12:48 AM
2011 Stock Head Unit Audio Playlist Options cheezmunky Car Audio, Video & Security 2 12-02-2011 10:09 AM
WTB : WTB - non-navi 2011+ OEM Head Unit with Bluetooth. ofspunk7 Private 'Wanted' Classifieds 2 10-25-2011 12:40 PM
2011 STi head unit w/o nav RCA PORTS? sk8dc10 Car Audio, Video & Security 5 11-06-2010 10:01 PM
2011 stock head unit wiring question subiebosch Car Audio, Video & Security 10 10-08-2010 09:21 AM


All times are GMT -4. The time now is 01:29 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.