Welcome to the North American Subaru Impreza Owners Club Saturday August 29, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-18-2012, 12:40 AM   #1
theSNOOTRS
Scooby Newbie
 
Member#: 151508
Join Date: Jun 2007
Chapter/Region: SWIC
Location: Albuquerque
Vehicle:
2004 WRX
Platinum Silver

Default Rear Axle. Need tech advice. Albuquerque NM


Well Wolf Creek was awesome this weekend! Four feet of powder and the riding was awesome...Also very crappy driving conditions, obviously Hit a snow bank and f'd upped the drive train somewhere.


Found my right rear axle separated from the diff. CV grease sprayed everywhere but the boot wasn't torn, just separated from the diff. Getting maybe 20% power to the wheels from 1st-2nd gear. Once the car is rolling 3rd-5th gears powers isn't as bat maybe 50-60% power to the wheels (as approximated by driving habits), I can tell the drive train is slipping alot.

Any ideas? Suggestions on what to check?

Thanks much appreciated..
theSNOOTRS is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:40 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.