Welcome to the North American Subaru Impreza Owners Club Tuesday October 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-25-2012, 02:52 PM   #1
emericareaper2
Scooby Newbie
 
Member#: 323008
Join Date: Jun 2012
Chapter/Region: MWSOC
Location: Indiana
Vehicle:
2006 WRX
OBP

Default 03 WRX weird sound from turbo?

So I picked up my 1st WRX a couple days ago. Keep in mind this is my 1st turbo. Newbie alert! There has been this weird sound that I think but really don't know, coming from what seems like the turbo. Is sort of a raspy dingyish sound...sorta. My mods are a Cobb downpipe, STi catback & Stage 2 93 tune. I have a couple videos displaying the sound & where it seems to be coming from. The previous owner said it might have something to do with the wastegate. I have no idea. Maybe it's just a downpipe leak? I know it's not coming from the rest of the exhaust. I have no CEL's. Although I do see a small lag of boost. That's it. I have no idea. Also, the car got a new OEM turbo at 175k (the car has 201k miles) Just see what you can diagnose from my vids. Thanks
http://www.flickr.com/photos/6202754...n/photostream/
http://www.flickr.com/photos/6202754...n/photostream/
emericareaper2 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:17 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.