Welcome to the North American Subaru Impreza Owners Club Friday November 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-28-2012, 08:39 PM   #1
Ghost22
Scooby Newbie
 
Member#: 271362
Join Date: Jan 2011
Chapter/Region: RMIC
Location: Gunnison, Colo
Vehicle:
1999 RS
Silver

Default Coolant froze! Car wont start

I hope this is the relevant forum.... I need ideas on what to do next.


So, I moved to colorado in july. I had a hose pop off on the 1800 mile trip to colorado. Refilled the coolant with the 50/50 mix i had in the trunk for emergency's. Never thought anything of it again.

It gets cold where I am now, VERY COLD Potentially -40 -50 F on record nights. . People had just started to warn me that 50/50 mix would not work, and that i desperately needed a block heater, when my car froze up.

It did not hit -30 yet, so im surprised it froze on me. Two weeks ago, i went to the store a couple blocks away. It was -17. My heater wasn't working, and its occasionally not worked on and off for years, never been able to find the problem. I did not think much of it. Oh god I wish I had.

I drive about 3 miles or so, and im on my way home, when I start losing all electrical power. I thought my alternator had just taken the piss, but i was only 2 blocks from home so i kept going. One block from home my temp guage spikes to the max. I drive for about 8 seconds, plow through 4 foot snow drift, and turn the car off as i coast into my driveway.

Open the car to see steam and ice everywhere. The alternator and battery were completely soaked in a coolant mixutre, and there was GREEN ICE all over the place.

I do not have a garage to take this too to thaw, and my tools and resources right now are extremely limited as Im an unemployed person, about to be evicted 1800 miles away from friends and family.

What I know so far is, that the 50/50 coolant I have froze long before it should have, the antifreeze has what appears to be a small amount of light brown liquid occasionally floating in it. Which i can only assume is oil(sigh). and the car will not start, even at a mild 28 degrees F.

What do I do now? What process should i be doing next? Quickest way for me to assess the final damages? Why in the earth would the coolant have frozen like that? Does the lower atmospheric pressure at 8,000 feet change the freezing point?

This is an engine with only 64,000 miles that i just put in, in january. I'd really be screwed if its toast.


I apologize for long winded story, or if its in wrong subforum, with everything going on in my life im not thinking straight, or very rationally , and with my car went my soul.


Thanks for any help or suggestions.
Ghost22 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:12 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.