Welcome to the North American Subaru Impreza Owners Club Monday November 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-11-2011, 03:44 PM   #176
Harley2390
Scooby Newbie
 
Member#: 275378
Join Date: Feb 2011
Default I'm Having Issues with Loading my Stock Ecu Map

NEED HELP DAILY DRIVER IN NEED OF INFO!!!! lol

Alright so i have Romraider downloaded with ECU def's downloaded. I also have Logger Def's Downloaded with ECU Flash, I am driving a 2008 Subaru Legacy Gt 2.5, i connected the test wires and what seems to be a log with ecu flash. It saved as "Read Image.hex" Now i am trying to open it up in romraider but is not allowing me to, nor can i open it back up in ecuflash. I sent it to a buddy Via Mediafire and he couldnt open it in his either. Is there something like some software im missing thats not allowing me to open it or log???

i have Tactrix openport 2.0 and i have the logger def's configured into romraider. just having the issue of why cant i open my test log that i did with ecuflash

this is what it showed that i logged:

http://www.mediafire.com/?6xdhyhlr6ddx5sd

Call me: 407-451-9981
Harley
_____Or Post_____
* Registered users of the site do not see these ads.
Harley2390 is offline   Reply With Quote
Old 07-23-2011, 04:29 PM   #177
BuGS
Scooby Specialist
 
Member#: 81353
Join Date: Feb 2005
Chapter/Region: NWIC
Location: East Wenatchee, WA
Vehicle:
06 STI
Blackness...

Default

BUMP for update with VAGCOM cable info. I think that would help a lot of ppl.
BuGS is offline   Reply With Quote
Old 07-31-2011, 10:52 AM   #178
daddyphatsax304
Scooby Newbie
 
Member#: 248075
Join Date: May 2010
Chapter/Region: MWSOC
Location: Flint, MI
Vehicle:
02' WRX Wagon
Aspen White

Default

Quote:
Originally Posted by Harley2390 View Post
NEED HELP DAILY DRIVER IN NEED OF INFO!!!! lol

Alright so i have Romraider downloaded with ECU def's downloaded. I also have Logger Def's Downloaded with ECU Flash, I am driving a 2008 Subaru Legacy Gt 2.5, i connected the test wires and what seems to be a log with ecu flash. It saved as "Read Image.hex" Now i am trying to open it up in romraider but is not allowing me to, nor can i open it back up in ecuflash. I sent it to a buddy Via Mediafire and he couldnt open it in his either. Is there something like some software im missing thats not allowing me to open it or log???

i have Tactrix openport 2.0 and i have the logger def's configured into romraider. just having the issue of why cant i open my test log that i did with ecuflash

this is what it showed that i logged:

http://www.mediafire.com/?6xdhyhlr6ddx5sd

Call me: 407-451-9981
Harley
_____Or Post_____
I realize this was a few months ago and i would hope you figured this out by now but maybe this will help some others as well...you are trying to open ur map w/ romraider. ECUflash gets and sends maps to your ECU...you did not log anything...in order to log you have to run romraider set your parameters.. WITHOUT green plugs connected and log some data...this gives you the necessary input to then do some calculations and make changes the map you downloaded via ECUflash.

log files are in .csv
maps are in .hex

green plugs are only required to send and recieve maps
daddyphatsax304 is offline   Reply With Quote
Old 05-20-2012, 02:21 AM   #179
JohnnyWas
Scooby Guru
 
Member#: 91010
Join Date: Jul 2005
Chapter/Region: Tri-State
Location: Brooklyn, NY
Vehicle:
2002 Subaru WRX
OG Blueberry

Default

Great thread! Looking forward to take a crack at all this tomorrow.
JohnnyWas is offline   Reply With Quote
Old 08-24-2012, 10:35 PM   #180
jdiwatts
Scooby Newbie
 
Member#: 302836
Join Date: Dec 2011
Location: Atlanta, GA
Vehicle:
2006 WRX
Silver

Default

Did it and now I truly love driving my 06 WRX wagon!
jdiwatts is offline   Reply With Quote
Old 09-01-2012, 06:59 PM   #181
JDM_J03
Scooby Newbie
 
Member#: 258435
Join Date: Sep 2010
Chapter/Region: MWSOC
Location: NW Suburbs, IL
Vehicle:
06 STi

Default

Hey guys,

Having a bit of trouble running the program. I have followed the steps very closely.. The problem I am having is everytime I open the RomRaider Logger it keeps telling me: "logger definition not configured". I have unzipped the file and resaved the .xml file to the romraider directory. I have also did the whole settings-> Logger definition location->selected the file.. But it KEEPS bringing up the window: "logger definition not configured" this is very irritating and annoying. can anyone please help?!

Last edited by JDM_J03; 09-02-2012 at 12:03 AM.
JDM_J03 is offline   Reply With Quote
Old 09-02-2012, 10:29 AM   #182
ckswanecamp
Scooby Newbie
 
Member#: 299861
Join Date: Nov 2011
Chapter/Region: MAIC
Location: Hanover, PA
Vehicle:
2002 Impreza WRX
Metallic Silver

Default

Is it the "cars" file stated in the error window? Because my RomRaider says that every time i open my logger. But all the parameters are listed on the left side of the app, and it works perfectly.
ckswanecamp is offline   Reply With Quote
Old 10-29-2012, 01:47 PM   #183
frederik
Scooby Specialist
 
Member#: 64405
Join Date: Jun 2004
Chapter/Region: E. Canada
Location: St-Georges, QC, Canada
Vehicle:
2003 WRX Sedan
WRB - Cobb Stg 2

Default

Quote:
Originally Posted by Tea cups View Post
If it is Accessport ver 1 cable, then you can log with RomRaider if you get a serial to USB converter (Belkin is a good one). However, that is it. You will not be able to flash your ECU (i.e. tune).
Is this still true? Until now when I (rarely) had to log something I was logging with EcuExplorer and my serial Accessport V1 cable, and I want to do the switch to RomRaider. No need to flash, only logging.

Thanks

Edit: nevermind. I thought you were saying romraider absolutely needs usb connection or something. I have a serial port on my work laptop (for older applications and stuff) so I'm all good.

Last edited by frederik; 10-29-2012 at 06:10 PM.
frederik is offline   Reply With Quote
Old 12-18-2012, 01:25 PM   #184
AWDkidRS
Scooby Specialist
 
Member#: 254133
Join Date: Aug 2010
Chapter/Region: MAIC
Location: Lancaster, PA
Vehicle:
2001 RS *EJ205*
White

Default

I know this has probally been covered in here a million times but i just dont have time to go through the pages but is the opensource tactrix cable the only cable that works? The regular vagcom ones dont? Sorry and thanks
AWDkidRS is offline   Reply With Quote
Old 12-18-2012, 01:44 PM   #185
Black94Snake
Scooby Specialist
 
Member#: 274499
Join Date: Feb 2011
Chapter/Region: NESIC
Location: RI
Vehicle:
2007 CGM VF'd WRX
12.70 @ 108.4mph

Default

Quote:
Originally Posted by AWDkidRS View Post
I know this has probally been covered in here a million times but i just dont have time to go through the pages but is the opensource tactrix cable the only cable that works? The regular vagcom ones dont? Sorry and thanks
Wow... You suck, seriously.

You don't have time to research, but you found enough of it to post this pile of crap.

Good job. I'm sure someone will be along to spoon feed you shortly. #damnlazykids
Black94Snake is offline   Reply With Quote
Old 12-18-2012, 02:51 PM   #186
cosseywrx
Scooby Specialist
 
Member#: 276443
Join Date: Mar 2011
Chapter/Region: TXIC
Location: Abilene, TX
Vehicle:
2005 2.1 stroker WRX
OBP

Default

Hash tag **** is childish.

And yes you should read the whole thread. Or search key words
cosseywrx is offline   Reply With Quote
Old 12-19-2012, 11:47 AM   #187
AWDkidRS
Scooby Specialist
 
Member#: 254133
Join Date: Aug 2010
Chapter/Region: MAIC
Location: Lancaster, PA
Vehicle:
2001 RS *EJ205*
White

Default

I was at work but read through and found out thanks for your "lame" help though.
AWDkidRS is offline   Reply With Quote
Old 12-19-2012, 12:00 PM   #188
ozunadel
Scooby Newbie
 
Member#: 313772
Join Date: Mar 2012
Chapter/Region: Tri-State
Location: Northern NJ
Vehicle:
2011 Impreza
DGM

Default

is there any to convert the .hex file you get from ecuflash,so i can send it via email to my tuner. once i leave ecuflash i cannot seem to find the file at all.

i dont think this was discussed in any of these 8 pages
ozunadel is offline   Reply With Quote
Old 12-19-2012, 12:38 PM   #189
cosseywrx
Scooby Specialist
 
Member#: 276443
Join Date: Mar 2011
Chapter/Region: TXIC
Location: Abilene, TX
Vehicle:
2005 2.1 stroker WRX
OBP

Default

Try and do a search for it? Make sure the folder its suppose to be in that in the properties no folders are being hidden. Make sure you actually saved it to the computer. To channge the file just edit it
cosseywrx is offline   Reply With Quote
Old 12-19-2012, 03:03 PM   #190
ozunadel
Scooby Newbie
 
Member#: 313772
Join Date: Mar 2012
Chapter/Region: Tri-State
Location: Northern NJ
Vehicle:
2011 Impreza
DGM

Default

ive done all of the above but the .hex file seems to vanish but when i do a search it shows up but i cant do anything with it
ozunadel is offline   Reply With Quote
Old 12-29-2012, 07:42 AM   #191
my0six
Scooby Newbie
 
Member#: 341826
Join Date: Dec 2012
Chapter/Region: International
Location: QLD Australia
Vehicle:
2005 WRX MY06
Light Bluish Silver

Default

Okay, so I don't know if this is the right place to write this, but can anybody tell me; would it be considered acceptable for a person with no tuning experience to go out and buy a tactrix and start learning how to use it?

I have an MY06 and the air pump has died. After weeks of speaking to my mechanic mates, dealerships and looking through these and other Subaru forums, I've decided to remove the pump and delete the CEL codes...

I've already wasted $50 having a tuner that didn't listen to me "clear" my CEL codes 4 times in a row, and then tell me after I said "I specifically asked for the codes GONE and the thing REFLASHED" that he couldn't do that, but I still had to pay for what he had done... And another tuner has quoted me a few hundred to do this...

If I can get the tools to do a job myself for cheaper than to have the service performed, I always try to do it myself.

So when I found out I could get the Tactrix OpenPort 2.0 for less than the cost of the tune (reminder, this is just some CEL codes for a secondary air pump delete, not a performance tune or anything), I decided that I'd look into doing it myself.

Anyway, I tend to waffle on a bit, but basically, what I'm asking is this:

Is this thread for qualified tuners? Or are there people out there teaching themselves to do this stuff??
my0six is offline   Reply With Quote
Old 12-29-2012, 10:32 AM   #192
Black94Snake
Scooby Specialist
 
Member#: 274499
Join Date: Feb 2011
Chapter/Region: NESIC
Location: RI
Vehicle:
2007 CGM VF'd WRX
12.70 @ 108.4mph

Default

Quote:
Originally Posted by my0six View Post
Okay, so I don't know if this is the right place to write this, but can anybody tell me; would it be considered acceptable for a person with no tuning experience to go out and buy a tactrix and start learning how to use it?

I have an MY06 and the air pump has died. After weeks of speaking to my mechanic mates, dealerships and looking through these and other Subaru forums, I've decided to remove the pump and delete the CEL codes...

I've already wasted $50 having a tuner that didn't listen to me "clear" my CEL codes 4 times in a row, and then tell me after I said "I specifically asked for the codes GONE and the thing REFLASHED" that he couldn't do that, but I still had to pay for what he had done... And another tuner has quoted me a few hundred to do this...

If I can get the tools to do a job myself for cheaper than to have the service performed, I always try to do it myself.

So when I found out I could get the Tactrix OpenPort 2.0 for less than the cost of the tune (reminder, this is just some CEL codes for a secondary air pump delete, not a performance tune or anything), I decided that I'd look into doing it myself.

Anyway, I tend to waffle on a bit, but basically, what I'm asking is this:

Is this thread for qualified tuners? Or are there people out there teaching themselves to do this stuff??
IMHO, your best bet would be to buy a Cobb Accessport. You can quickly and easily remove the CEL codes, and learn how to tune with its software. Once you have a good handle on what you are doing, you can sell the AP... Recoup your money and tune open source if you want to.

You will get much better support from the guys at Cobb, you will be less likely to brick your ECU, and don't need to keep a laptop in the car to gather datalogs. (I know the OP2.0 can too... but you can't view data without a pc.)
Black94Snake is offline   Reply With Quote
Old 12-29-2012, 11:32 AM   #193
my0six
Scooby Newbie
 
Member#: 341826
Join Date: Dec 2012
Chapter/Region: International
Location: QLD Australia
Vehicle:
2005 WRX MY06
Light Bluish Silver

Default

Thanks bro, but no Cobb in Australia
Not sure why, but that's the word...

...and everybody's heard...
my0six is offline   Reply With Quote
Old 12-29-2012, 03:07 PM   #194
frederik
Scooby Specialist
 
Member#: 64405
Join Date: Jun 2004
Chapter/Region: E. Canada
Location: St-Georges, QC, Canada
Vehicle:
2003 WRX Sedan
WRB - Cobb Stg 2

Default

I think it is perfectly fine to equip with the cable even if you dont intent to actually tune or change anything. It is a great maintenance and diagnosing tool.

If you look at romraider forum you will find detailed explanation of what to install, how it works, and what to log. There is also different explanations depending if you want to only datalog or actually tune. I read the part for datalog and diagnosing and I thing it is a great tool to be able to do the basic. Then when you have an issue and someone asks if you have a datalog you can say yes and post the information and get better help.

Resetting the ecu will clear the check engine light, but if your issue is still there (which is likely if you didnt do any change to the car) the check engine will come back.
frederik is offline   Reply With Quote
Old 12-31-2012, 01:57 AM   #195
hunterjm
Scooby Newbie
 
Member#: 314744
Join Date: Mar 2012
Default

As Black94Snake mentioned, the OpenPort 2.0 has a micro SD slot for standalone logging. I created an online tool that will take a RomRaider profile.xml file and generate the required logcfg.txt from it. It makes it really easy to take your RomRaider profiles and create a config for standalone logging without having to match addresses from the definitions yourself. It also supports calculated parameters. I built it for myself, but figured I would polish it up and put it out there in case it would be useful for anyone else.

http://subaru.hunterjm.com/

If it gains enough traction (or upon recommendation) I can create a separate post, but I thought it related pretty well to this FAQ. To learn more about what you need to do to get your Tactrix configured for standalone logging, visit: http://forums.openecu.org/viewtopic.php?f=57&t=4319
hunterjm is offline   Reply With Quote
Old 01-02-2013, 07:34 PM   #196
my0six
Scooby Newbie
 
Member#: 341826
Join Date: Dec 2012
Chapter/Region: International
Location: QLD Australia
Vehicle:
2005 WRX MY06
Light Bluish Silver

Default

Okay, having a little trouble guys, I'm trying to get "The latest RomRaider ECU definitions", as instructed on RomRaider's site, but in their list on the below page, I cannot find my car. It's an ADM (aussie) MY06 WRX

http://www.romraider.com/forum/viewtopic.php?t=360

I am sure RomRaider supports my car, as I can see it in black and white on their "supported ECUs" page, where it states my year as having two models (06 A8DH200O (MT)*, A8DH200U (MT)*)...

My question is, does anybody know where I might find the specific RomRaider ECU definitions for my car??

Or should I be posting this on the RomRaider site?
my0six is offline   Reply With Quote
Old 01-02-2013, 09:45 PM   #197
quazimoto
Scooby Guru
 
Member#: 70395
Join Date: Sep 2004
Chapter/Region: MAIC
Location: Da-boonies,Va
Default

The definitions will work.........
quazimoto is offline   Reply With Quote
Old 01-03-2013, 06:38 AM   #198
my0six
Scooby Newbie
 
Member#: 341826
Join Date: Dec 2012
Chapter/Region: International
Location: QLD Australia
Vehicle:
2005 WRX MY06
Light Bluish Silver

Default

Thanks very much. Does anybody have any idea WHERE I might find the definitions for an AMD MY06 WRX?
my0six is offline   Reply With Quote
Old 01-03-2013, 09:09 AM   #199
quazimoto
Scooby Guru
 
Member#: 70395
Join Date: Sep 2004
Chapter/Region: MAIC
Location: Da-boonies,Va
Default

Quote:
Originally Posted by my0six View Post
Thanks very much. Does anybody have any idea WHERE I might find the definitions for an AMD MY06 WRX?
Yeah,right here............
http://www.romraider.com/forum/topic360.html
The definitions are bundled together. If your ECU is shown as supported then the definition is there. The ones listed on the definition page are new ones that have been added..........
quazimoto is offline   Reply With Quote
Old 01-03-2013, 09:55 AM   #200
my0six
Scooby Newbie
 
Member#: 341826
Join Date: Dec 2012
Chapter/Region: International
Location: QLD Australia
Vehicle:
2005 WRX MY06
Light Bluish Silver

Default

Okay, sorry Quaz, I didn't mean to be painful... I TOTALLY misread something and was looking for a download... Hahah, nice emoticon
my0six is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
romraider/ecuflash? weaponstroop Open Source Reflashes 8 10-21-2008 11:04 AM
reading logs - FAQ or getting started guide? jmc9809 Newbies & FAQs 2 08-05-2005 07:40 PM
I want to get started racing! Where to start? wayne_rx Motorsports 27 12-23-2004 04:00 AM
Auto-Xing Newbe, How to get started? Ed_RS New England Impreza Club Forum -- NESIC 7 01-31-2001 12:34 PM
how to get started jjp New England Impreza Club Forum -- NESIC 5 11-09-2000 07:26 AM


All times are GMT -4. The time now is 12:38 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.