Welcome to the North American Subaru Impreza Owners Club Saturday September 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-02-2013, 09:40 AM   #1
RHDNEAL
Scooby Newbie
 
Member#: 342132
Join Date: Dec 2012
Chapter/Region: MAIC
Location: gaithersburg
Vehicle:
1997 outback sport
white/gray

Default Maryland newb with parasitic draw

Hello nasioc,
I am the new owner of a 1997 OBS that was converted to right hand drive(usdm firewall) and swapped with a hybrid 2.5/2.0 turbo....As of yesterday i was happier than a gazelle with night vision goggles but now i have a starting issue. Ive been driving the car with no issue for 2-3 days now everything was fine, but then it decided to leave me stranded. I get in the car dome light comes on door ajar but as soon as i turn the key i get one click and everything is dead. I can jump start the vehicle and drive it around fine but once i leave it overnight it will do the same thing over again. Battery is new alternator is producing normal voltage. I guess what im trying to say is are there any common issues with these cars that draw power, say the power locks pulling voltage or a sticking relay. While i am a mechanic by trade im just seeing if there are some things i should go for right away. Once i get home im going to check my ground wires possibly pull a few fuses and put my multimeter to use, any leads would be nice though. Thanks in advanced
RHDNEAL is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:25 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.