Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
North West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > North West Impreza Club Forum -- NWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-01-2013, 01:39 PM   #3326
gmhl10
Scooby Newbie
 
Member#: 158695
Join Date: Sep 2007
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
2013 GVB STi
World Rally Blue

Default

Washed the car for the first time. Only 1300 miles on odometer and there are lots of bumper rock chips. Also put in a Grimmspeed lightweight crank pulley. That Gates stretch belt is kind of annoying if you've never dealt with it before.
* Registered users of the site do not see these ads.
gmhl10 is offline   Reply With Quote
Old 01-01-2013, 08:03 PM   #3327
Etownwrx
Scooby Specialist
 
Member#: 288003
Join Date: Jul 2011
Chapter/Region: NWIC
Location: Edmonds, Wa
Default

Repairing my front lip after my father in law decided to move my car this weekend and ran it into a snow pile, mangling my front lip and tearing it off the car, !
Etownwrx is offline   Reply With Quote
Old 01-01-2013, 09:50 PM   #3328
jcwrx
Scooby Specialist
 
Member#: 25989
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Bend, OR
Vehicle:
2009 WRX Stage 2+
Lightning Red Hatchback

Default The answer is clear, ClearBra!

Quote:
Originally Posted by gmhl10 View Post
Washed the car for the first time. Only 1300 miles on odometer and there are lots of bumper rock chips. Also put in a Grimmspeed lightweight crank pulley. That Gates stretch belt is kind of annoying if you've never dealt with it before.
Get in touch with ClearBra of Oregon (Hillsboro, OR). Shell out the cash and keep your new '13 in good shape.

It will be the best $550 you will spend on your car if you give a **** about your crappy Subaru paint. I've had them install a kit on both my '03, and '09 WRX's. $550 is a tough pill to swallow, but it is worth the investment.
jcwrx is offline   Reply With Quote
Old 01-01-2013, 10:02 PM   #3329
jcwrx
Scooby Specialist
 
Member#: 25989
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Bend, OR
Vehicle:
2009 WRX Stage 2+
Lightning Red Hatchback

Default

Did a full front light conversion on my 2009 WRX.

Low beams: H11 ---> H9
DRL/High beams: 9005 ----> 9011
OEM fogs: 9006 ---> 9012
Turn Signals: 1157NA ----> Sliver Star 1157A (look clear/flash amber)

Rear:
Revers lights: PIAA Xtreme White Bulb H.I.D.

With some leveling adjustment this conversion has made a night and day difference.
jcwrx is offline   Reply With Quote
Old 01-01-2013, 10:19 PM   #3330
jcwrx
Scooby Specialist
 
Member#: 25989
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Bend, OR
Vehicle:
2009 WRX Stage 2+
Lightning Red Hatchback

Default

Custom mid-pipe from Custom Exhaust Specialties (Bend, Oregon).

After recognizing a exhaust leak at the Perrin DP and OEM mid-pipe I took my car to CES. I was hoping I just needed a gasket replacement, only to find out that the matting of a Perrin DP and OEM mid-pipe is WRONG!! Mind you I purchased the car with the TBE already on the car, and I assumed that since the car came stock with an 3" SPT exhaust, that the mid-pipe was also 3". This is not the case. At the DP/mid-pipe junction the exhaust is 2.5", making for a rig-job install. Disappointing to say the least, but none the less CES hooked up a nice mid-pipe (not cheap mind you).

The mid-pipe was built up including the following parts:

3"X6" flex joint
3" V band clamp
Magnaflow 18129 SS resonator
3x mandrel bends

It's only money, and now the TBE is complete and has a lifetime warranty.
jcwrx is offline   Reply With Quote
Old 01-02-2013, 02:39 PM   #3331
bclodfelter
Scooby Newbie
 
Member#: 288878
Join Date: Jul 2011
Chapter/Region: NWIC
Location: Sandy Oregon
Vehicle:
2011 WRB STI Hatch
World Rally Blue

Default

Found out why my rear defrost wasn't working.... When the tinter re tinted the back window due to problems with the original tint, he ripped off sections of the stripping causing the malfunctions. Friday my car is getting a whole new back window... Tinted of course.
bclodfelter is offline   Reply With Quote
Old 01-02-2013, 04:36 PM   #3332
DaishaFlegel
Scooby Newbie
 
Member#: 315501
Join Date: Apr 2012
Chapter/Region: NWIC
Location: bonney lake
Vehicle:
2005 wrx sti
black

Default

New wheels and pink lugs took the pink wheels off. And mud flaps are on
DaishaFlegel is offline   Reply With Quote
Old 01-02-2013, 04:46 PM   #3333
enjoilife1991
Scooby Newbie
 
Member#: 322400
Join Date: Jun 2012
Chapter/Region: MWSOC
Location: Reno
Vehicle:
03 WRX 360whp
PSM

Default

Quote:
Originally Posted by bclodfelter
Found out why my rear defrost wasn't working.... When the tinter re tinted the back window due to problems with the original tint, he ripped off sections of the stripping causing the malfunctions. Friday my car is getting a whole new back window... Tinted of course.
Glad to hear you figured that one out! Now go get ur money back from that tinter!
enjoilife1991 is offline   Reply With Quote
Old 01-02-2013, 06:22 PM   #3334
tobigforhisshoes
Scooby Specialist
 
Member#: 251434
Join Date: Jul 2010
Chapter/Region: NWIC
Location: Portland
Vehicle:
04 WRX
WRB 319/285 bobby tuned!

Default

Quote:
Originally Posted by bclodfelter View Post
Found out why my rear defrost wasn't working.... When the tinter re tinted the back window due to problems with the original tint, he ripped off sections of the stripping causing the malfunctions. Friday my car is getting a whole new back window... Tinted of course.
Take it to Tommys tint next time!
tobigforhisshoes is offline   Reply With Quote
Old 01-02-2013, 07:28 PM   #3335
bradze
Scooby Specialist
 
Member#: 103208
Join Date: Dec 2005
Chapter/Region: NWIC
Location: Yelm, Wa
Vehicle:
2011 Outback
Azurite Blue

Default

finished making a skid plate out of an aluminum sign my father in law wasnt using
bradze is offline   Reply With Quote
Old 01-02-2013, 08:34 PM   #3336
a93x
Scooby Specialist
 
Member#: 320732
Join Date: May 2012
Chapter/Region: NWIC
Location: Bend
Vehicle:
2011 WRX sedan
AllWheelsDriven

Default

boosted all the way to work. I love a cold morning drive

a93x is offline   Reply With Quote
Old 01-02-2013, 09:06 PM   #3337
03sportwagon
Scooby Newbie
 
Member#: 252943
Join Date: Jul 2010
Chapter/Region: NWIC
Location: boise id
Vehicle:
2003 wrx sport wagon
silver

Default

Got my windows tinted today
03sportwagon is offline   Reply With Quote
Old 01-02-2013, 11:11 PM   #3338
ImNOrobo
Scooby Specialist
 
Member#: 255716
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Where the simpsons live.
Vehicle:
Oh, It's a JDM STI?
Pretty close.

Default

She is packed full of crap and on a car carrier behind a moving truck. We are headed home.......
















........Tomorrow.
ImNOrobo is offline   Reply With Quote
Old 01-03-2013, 01:21 AM   #3339
mw1484
Scooby Specialist
 
Member#: 239546
Join Date: Feb 2010
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2011 WRX TP Stg2+AEM
Spark Silver Sedan

Default

Crossed over 17k miles on my way to work...
mw1484 is offline   Reply With Quote
Old 01-03-2013, 05:46 PM   #3340
Nighthawkra
Scooby Specialist
 
Member#: 292655
Join Date: Aug 2011
Location: Dunnellon, FL
Vehicle:
2012 WRX limited
WRB pearl

Default

Oil change!!!! ..... Not that exciting :/
Nighthawkra is offline   Reply With Quote
Old 01-03-2013, 10:27 PM   #3341
Sideways_STi
Scooby Newbie
 
Member#: 258679
Join Date: Sep 2010
Chapter/Region: NWIC
Location: Bellingham, WA
Vehicle:
2008 STi Hatch
Lightning Red

Default

Quote:
Originally Posted by jcwrx View Post
Did a full front light conversion on my 2009 WRX.

Low beams: H11 ---> H9
DRL/High beams: 9005 ----> 9011
OEM fogs: 9006 ---> 9012
Turn Signals: 1157NA ----> Sliver Star 1157A (look clear/flash amber)

Rear:
Revers lights: PIAA Xtreme White Bulb H.I.D.

With some leveling adjustment this conversion has made a night and day difference.
Mind if I ask why? I mean no disrespect, just curious Im always looking for a way for more light output while keeping the front of the car OEM-ish looking
Sideways_STi is offline   Reply With Quote
Old 01-03-2013, 10:41 PM   #3342
gmhl10
Scooby Newbie
 
Member#: 158695
Join Date: Sep 2007
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
2013 GVB STi
World Rally Blue

Default

Put the winter wheels on the car. No more Prodrives... back to stock wheels.
gmhl10 is offline   Reply With Quote
Old 01-03-2013, 11:24 PM   #3343
NWRSDRIVER05
Scooby Newbie
 
Member#: 250506
Join Date: Jun 2010
Chapter/Region: NWIC
Location: Bellingham, WA
Vehicle:
2004 WRX Wagon
WRB

Default

Accessport installation running stage 1, picked it up from the PO Box after work today!
NWRSDRIVER05 is offline   Reply With Quote
Old 01-04-2013, 12:46 AM   #3344
XRamboX
Scooby Newbie
 
Member#: 341081
Join Date: Dec 2012
Chapter/Region: NWIC
Location: Newberg, OR
Vehicle:
2003 WRX Sedan StgII
MBP

Default

Tweaked the AKC tables on my Stage II map. Hopefully get a few more logs in tomorrow, but so far no knock!
XRamboX is offline   Reply With Quote
Old 01-04-2013, 09:51 AM   #3345
AspenWagon02
Scooby Newbie
 
Member#: 334407
Join Date: Oct 2012
Default

Picked up my AccessPort from UPS and installed stage 2, installed some hella tones I got for Xmas from a buddy, and changed my oil.
AspenWagon02 is offline   Reply With Quote
Old 01-04-2013, 09:18 PM   #3346
SuperScubi
Scooby Specialist
 
Member#: 233407
Join Date: Dec 2009
Chapter/Region: NWIC
Location: Kirkland, WA
Vehicle:
2004 Aspen White STi
PIA Tune 347whp 327tq

Default

Installed a Perrin light weight crank pulley

Last edited by SuperScubi; 01-04-2013 at 09:32 PM.
SuperScubi is offline   Reply With Quote
Old 01-04-2013, 09:55 PM   #3347
cody04wgn
Scooby Newbie
 
Member#: 339063
Join Date: Nov 2012
Chapter/Region: NWIC
Location: medford oregon
Vehicle:
2004 wrx wagon
red

Default

got my windows tinted at 35% by sunscape here in the valley thanks to a gift certificate i got for x-mas from my sister
cody04wgn is offline   Reply With Quote
Old 01-04-2013, 10:13 PM   #3348
cuztomimportz
Scooby Specialist
 
Member#: 97904
Join Date: Oct 2005
Chapter/Region: Tri-State
Vehicle:
2002 WRX
World Rally Blue

Default

Nice gift
cuztomimportz is offline   Reply With Quote
Old 01-04-2013, 10:44 PM   #3349
Wesley1184
Scooby Newbie
 
Member#: 301484
Join Date: Nov 2011
Chapter/Region: NWIC
Location: eugene oregon
Vehicle:
2002 wrx
red

Default

I got a Perrin 25mm front sway bar Perrin rad cover and a new set of Enkei's will install tomorrow
Wesley1184 is offline   Reply With Quote
Old 01-05-2013, 02:53 AM   #3350
I'mFineW/Slow
Scooby Specialist
 
Member#: 260395
Join Date: Oct 2010
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2004 Impreza 2.5 RS
Blue

Default

Satin Black on the roof. I do not recommend doing this without a helper. Climbing on top of the car to get it to lay down how I wanted was when I realized I definitely needed help. Overall I'm happy with the results. An obviously amateur job upon inspection but seemingly perfect from 4 feet away.





I'mFineW/Slow is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What did you do to your Subie Today? Version 3 TrickNipple North West Impreza Club Forum -- NWIC 3796 09-07-2011 02:52 AM
What did you do to your Subie Today? Version 2 Smoke North West Impreza Club Forum -- NWIC 1978 05-21-2010 12:43 AM
What did you do to your Suby today? BREWPUBEAVER North West Impreza Club Forum -- NWIC 1197 11-01-2009 12:06 PM
What did you do to your subie today?! 07imprezadrifter General Community 277 06-14-2009 11:42 PM


All times are GMT -4. The time now is 07:40 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.