Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-10-2013, 08:41 AM   #1
avikm289
Scooby Newbie
 
Member#: 315748
Join Date: Apr 2012
Chapter/Region: Tri-State
Location: Queens NY
Vehicle:
2012 wrx
White pearl

Default 2012 wrx intercooler leak

I've had the throttle body to intercooler seal on the throttle body come loose and leak air this past month 3 times and was wondering if there was a better seal for it. I'll post pics up in a few of what I'm talking about
* Registered users of the site do not see these ads.
avikm289 is offline   Reply With Quote
Old 01-10-2013, 09:10 AM   #2
avikm289
Scooby Newbie
 
Member#: 315748
Join Date: Apr 2012
Chapter/Region: Tri-State
Location: Queens NY
Vehicle:
2012 wrx
White pearl

Default

avikm289 is offline   Reply With Quote
Old 01-10-2013, 09:57 AM   #3
SenorDucK
Scooby Specialist
 
Member#: 327511
Join Date: Jul 2012
Chapter/Region: MWSOC
Location: Chicagoland
Vehicle:
13' WRX 6 Speed
11sec VF52 EL-EWG-E85

Default

SenorDucK is offline   Reply With Quote
Old 01-10-2013, 11:40 AM   #4
xluben
Scooby Guru
 
Member#: 261612
Join Date: Oct 2010
Location: Minneapolis, MN
Vehicle:
2012 Forester 2.5X
2002 WRX Sedan

Default

Remove those rubber gasket/caps from BOTH ends of the throttle body hose.
xluben is offline   Reply With Quote
Old 01-10-2013, 01:14 PM   #5
madshad
Scooby Newbie
 
Member#: 328892
Join Date: Aug 2012
Chapter/Region: MWSOC
Location: Shelbyville, IN
Vehicle:
2009
dgm

Default

Quote:
Originally Posted by xluben View Post
Remove those rubber gasket/caps from BOTH ends of the throttle body hose.
This, I had the same problem. Took the rubber ends off, clamped onto the hose itself. 11k miles ago, no problems yet.
madshad is offline   Reply With Quote
Old 01-10-2013, 06:04 PM   #6
avikm289
Scooby Newbie
 
Member#: 315748
Join Date: Apr 2012
Chapter/Region: Tri-State
Location: Queens NY
Vehicle:
2012 wrx
White pearl

Default

Ill give that a shot tomorrow, thanks
avikm289 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:30 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.