Welcome to the North American Subaru Impreza Owners Club Friday November 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-13-2013, 10:30 PM   #1
RancerEvorution
Scooby Newbie
 
Member#: 235190
Join Date: Jan 2010
Chapter/Region: Tri-State
Location: North Jersey
Vehicle:
2011 STi
WRB

Default Rats nest of plumbing with Crawford AOS

Anyone with a GR STi that is running a FMIC also running the Crawford AOS ? I just finished installing mine (PITA) and I'm not too happy with how it looks. My engine bay looks very cluttered with thick black tubes running all over the place. If you are front mounted and you're rocking the Crawford AOS, post a pic so I can see how the tubes are routed.

Thanks

EDIT: Heres a pic

* Registered users of the site do not see these ads.

Last edited by RancerEvorution; 01-13-2013 at 11:05 PM.
RancerEvorution is offline   Reply With Quote
Old 01-13-2013, 10:40 PM   #2
drewvdw
Scooby Guru
 
Member#: 255776
Join Date: Aug 2010
Chapter/Region: MWSOC
Location: Laramie, WY
Vehicle:
2010 LR WRX
MPS powered.

Default

I'm going to be doing the same soon. When I got the AOS kit, I was amazed at how much tubing there is...
drewvdw is offline   Reply With Quote
Old 01-13-2013, 10:43 PM   #3
RancerEvorution
Scooby Newbie
 
Member#: 235190
Join Date: Jan 2010
Chapter/Region: Tri-State
Location: North Jersey
Vehicle:
2011 STi
WRB

Default

Seriously... I'm a function over form kinda guy, but this is too far. I'll get a picture up soon. There has got to be a cleaner way to route all these tubes but after that install I dont even want to go near my garage
RancerEvorution is offline   Reply With Quote
Old 01-13-2013, 11:05 PM   #4
RancerEvorution
Scooby Newbie
 
Member#: 235190
Join Date: Jan 2010
Chapter/Region: Tri-State
Location: North Jersey
Vehicle:
2011 STi
WRB

Default

added a pic to OP
RancerEvorution is offline   Reply With Quote
Old 01-15-2013, 10:03 AM   #5
kabob.master
Scooby Specialist
 
Member#: 258791
Join Date: Sep 2010
Chapter/Region: SCIC
Location: CA
Vehicle:
2011 wrx 5dr lmtd.
299awhp / 322tq @ 17.6psi

Default

Time to get some of those shiny oil caps for distraction!!!!
kabob.master is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:42 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.