Welcome to the North American Subaru Impreza Owners Club Thursday July 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South East Region Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Regional Areas > South East Region Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-17-2013, 03:57 PM   #526
dnldmelton
Scooby Newbie
 
Member#: 340314
Join Date: Dec 2012
Default

Quote:
Originally Posted by myblusti View Post
my gf has a nice sony cybershot. yea we can do a shoot, get some rolling shots and what not.. i know some decent spots...

on another note i have been under the impression for over a year now that my 240 had blown rings. well i retested all cylinders last night warm with all plugs removed at wot and got approximatly 150 across all cylinders. so apparently the block is healthy. which still doesnt explain what is wrong with it. its basically is acting like it is hitting the rev limiter but its hitting it at 2500 rpms and its very intermittant and will only do it when the engine is at operating temp.
Mass air flow sensor, almost 100 % sure just from if it's hitting the rev limit at 2500 or atleast feels like it and if it falls on it's face that's exactly what it is, it's either bad or it's being blocked by the intake at some point try that
* Registered users of the site do not see these ads.
dnldmelton is offline   Reply With Quote
Old 01-17-2013, 06:54 PM   #527
yongsik_park
Scooby Newbie
 
Member#: 228107
Join Date: Oct 2009
Chapter/Region: South East
Location: Beaufort SC
Vehicle:
2005 Impreza WRX
Dark Grey Metallic

Default

When's the next photo shoot
yongsik_park is offline   Reply With Quote
Old 01-18-2013, 07:18 AM   #528
myblusti
Scooby Newbie
 
Member#: 337871
Join Date: Nov 2012
Chapter/Region: South East
Location: beaufort
Vehicle:
2010 5-door STI
blue/gold

Default

Quote:
Originally Posted by dnldmelton View Post
Mass air flow sensor, almost 100 % sure just from if it's hitting the rev limit at 2500 or atleast feels like it and if it falls on it's face that's exactly what it is, it's either bad or it's being blocked by the intake at some point try that
its possible. the thing that getts me is why does it only do it at operating temp and why is it intermittant?
myblusti is offline   Reply With Quote
Old 01-18-2013, 07:20 AM   #529
myblusti
Scooby Newbie
 
Member#: 337871
Join Date: Nov 2012
Chapter/Region: South East
Location: beaufort
Vehicle:
2010 5-door STI
blue/gold

Default

Quote:
Originally Posted by yongsik_park View Post
When's the next photo shoot
unsure. if i get my car today then ill be at sonic tonight. if not then sav tmrw i guess. i will not be beating it though. break in period...but i suppose i could bring the sony out to play.
myblusti is offline   Reply With Quote
Old 01-18-2013, 07:31 AM   #530
dnldmelton
Scooby Newbie
 
Member#: 340314
Join Date: Dec 2012
Default

Quote:
Originally Posted by myblusti View Post

its possible. the thing that getts me is why does it only do it at operating temp and why is it intermittant?
I had a stang that was doing the same thing, and somedays it would run primo and others I wouldn't have any power and it would fall on it's face after like 4000 rpm and my boss had the same with with his, the intake was covering part of the sensor on his and on mine the sensor was just bad
dnldmelton is offline   Reply With Quote
Old 01-20-2013, 01:45 PM   #531
flippymcbean
Scooby Specialist
 
Member#: 198546
Join Date: Dec 2008
Chapter/Region: South East
Location: Beaufort, South Carolina
Vehicle:
2003 Evolution VIII
Lightning Yellow

Default

Any word on the 240??
flippymcbean is offline   Reply With Quote
Old 01-20-2013, 05:41 PM   #532
flippymcbean
Scooby Specialist
 
Member#: 198546
Join Date: Dec 2008
Chapter/Region: South East
Location: Beaufort, South Carolina
Vehicle:
2003 Evolution VIII
Lightning Yellow

Default

Planning on installing my coilovers next weekend for sure! My son got sick this weekend. Who's down to help? I was thinking Friday.
flippymcbean is offline   Reply With Quote
Old 01-20-2013, 08:27 PM   #533
flippymcbean
Scooby Specialist
 
Member#: 198546
Join Date: Dec 2008
Chapter/Region: South East
Location: Beaufort, South Carolina
Vehicle:
2003 Evolution VIII
Lightning Yellow

Default

$400 JDM genome axle back!!! Anybody want one?? Let me know
flippymcbean is offline   Reply With Quote
Old 01-20-2013, 08:30 PM   #534
myblusti
Scooby Newbie
 
Member#: 337871
Join Date: Nov 2012
Chapter/Region: South East
Location: beaufort
Vehicle:
2010 5-door STI
blue/gold

Default

i'll help you. i just ordered a new pioneer nav deck and some polk component speakers. a little birthday gift to myself. so ill have that to install next week also. should have the sti back on tuesday if all goes well. i also have to break it in and reinstall the injectors and get it tuned properly. but i'll have the house to myself friday and saturday. we can do it all over here. who's bringing the beer. ya'll can crash here if need be but i doubt it'll come to that.
myblusti is offline   Reply With Quote
Old 01-20-2013, 10:10 PM   #535
flippymcbean
Scooby Specialist
 
Member#: 198546
Join Date: Dec 2008
Chapter/Region: South East
Location: Beaufort, South Carolina
Vehicle:
2003 Evolution VIII
Lightning Yellow

Default

Sweet! What kind of deck? I'm looking to replace my kenwood.

You still haven't got your car back yet?
flippymcbean is offline   Reply With Quote
Old 01-21-2013, 11:18 AM   #536
myblusti
Scooby Newbie
 
Member#: 337871
Join Date: Nov 2012
Chapter/Region: South East
Location: beaufort
Vehicle:
2010 5-door STI
blue/gold

Default

myblusti is offline   Reply With Quote
Old 01-21-2013, 02:46 PM   #537
flippymcbean
Scooby Specialist
 
Member#: 198546
Join Date: Dec 2008
Chapter/Region: South East
Location: Beaufort, South Carolina
Vehicle:
2003 Evolution VIII
Lightning Yellow

Default

Those are going all around? That deck is money dude!!!!! I'm interested in some components for my car. That should be in easy install. For the most part...
flippymcbean is offline   Reply With Quote
Old 01-21-2013, 02:58 PM   #538
myblusti
Scooby Newbie
 
Member#: 337871
Join Date: Nov 2012
Chapter/Region: South East
Location: beaufort
Vehicle:
2010 5-door STI
blue/gold

Default

well the 240 is back on the road. i think it must have been a vacuum leak. i redid a bunch of hoses and did a boost leak test and started fixing all the leaks i found. then i seafoamed the intake manifold. it is much more smooth and even idles much better than before it started acting up. it just runs better period.
myblusti is offline   Reply With Quote
Old 01-21-2013, 03:01 PM   #539
myblusti
Scooby Newbie
 
Member#: 337871
Join Date: Nov 2012
Chapter/Region: South East
Location: beaufort
Vehicle:
2010 5-door STI
blue/gold

Default

yea im putting the components in also. they had some good reviews and for the money components are the best buy. plus polk usually does good stuff audio wise. im hoping this still holds true. ive read mixed reviews on the H/U. its there flagship model so hopfully it doesnt dissapoint...
myblusti is offline   Reply With Quote
Old 01-21-2013, 03:42 PM   #540
flippymcbean
Scooby Specialist
 
Member#: 198546
Join Date: Dec 2008
Chapter/Region: South East
Location: Beaufort, South Carolina
Vehicle:
2003 Evolution VIII
Lightning Yellow

Default

Oops....
flippymcbean is offline   Reply With Quote
Old 01-22-2013, 12:10 AM   #541
yongsik_park
Scooby Newbie
 
Member#: 228107
Join Date: Oct 2009
Chapter/Region: South East
Location: Beaufort SC
Vehicle:
2005 Impreza WRX
Dark Grey Metallic

Default

Lol I just installed a walbro 255 fuel pump, just got my AVO top mount intercooler and my invidia divorced downpipe. Then getting my tune done this weekend.
yongsik_park is offline   Reply With Quote
Old 01-22-2013, 06:55 AM   #542
flippymcbean
Scooby Specialist
 
Member#: 198546
Join Date: Dec 2008
Chapter/Region: South East
Location: Beaufort, South Carolina
Vehicle:
2003 Evolution VIII
Lightning Yellow

Default

New down pipe huh? Damn I'm in the market for one....my hks one sucks. Boost creep. My target boost is 17lb but because of this downpipe I've hit 20 lbs. I'm now afraid to go fast.
flippymcbean is offline   Reply With Quote
Old 01-22-2013, 06:55 AM   #543
flippymcbean
Scooby Specialist
 
Member#: 198546
Join Date: Dec 2008
Chapter/Region: South East
Location: Beaufort, South Carolina
Vehicle:
2003 Evolution VIII
Lightning Yellow

Default

Where you getting tuned at????
flippymcbean is offline   Reply With Quote
Old 01-22-2013, 07:30 AM   #544
myblusti
Scooby Newbie
 
Member#: 337871
Join Date: Nov 2012
Chapter/Region: South East
Location: beaufort
Vehicle:
2010 5-door STI
blue/gold

Default

Quote:
Originally Posted by yongsik_park View Post
Lol I just installed a walbro 255 fuel pump, just got my AVO top mount intercooler and my invidia divorced downpipe. Then getting my tune done this weekend.
if you need help with the install swing by on saturday.
myblusti is offline   Reply With Quote
Old 01-22-2013, 07:32 AM   #545
myblusti
Scooby Newbie
 
Member#: 337871
Join Date: Nov 2012
Chapter/Region: South East
Location: beaufort
Vehicle:
2010 5-door STI
blue/gold

Default

Quote:
Originally Posted by flippymcbean View Post
New down pipe huh? Damn I'm in the market for one....my hks one sucks. Boost creep. My target boost is 17lb but because of this downpipe I've hit 20 lbs. I'm now afraid to go fast.
its probably your waste gate that sucks. it cant kkep up with the downpipe. they suck on the sti's also. hks is known for quality. you will have the same problem with any decent downpipe. you need to upgrade the wg. or get an electronic boost controller to help.
myblusti is offline   Reply With Quote
Old 01-22-2013, 07:46 AM   #546
myblusti
Scooby Newbie
 
Member#: 337871
Join Date: Nov 2012
Chapter/Region: South East
Location: beaufort
Vehicle:
2010 5-door STI
blue/gold

Default

Quote:
Originally Posted by flippymcbean View Post
Where you getting tuned at????
??? ???
myblusti is offline   Reply With Quote
Old 01-22-2013, 10:10 AM   #547
flippymcbean
Scooby Specialist
 
Member#: 198546
Join Date: Dec 2008
Chapter/Region: South East
Location: Beaufort, South Carolina
Vehicle:
2003 Evolution VIII
Lightning Yellow

Default

I read that hks is known for boost creep. It has the flat face flange vs the bell mouth and divorced. Is this true?? I'm looking for a new one for this reason.
flippymcbean is offline   Reply With Quote
Old 01-22-2013, 10:11 AM   #548
flippymcbean
Scooby Specialist
 
Member#: 198546
Join Date: Dec 2008
Chapter/Region: South East
Location: Beaufort, South Carolina
Vehicle:
2003 Evolution VIII
Lightning Yellow

Default

Why would I need a new boost controller? I'm tuned at 17psi. They raised boost when I got tuned so...I don't know what to do anymore.
flippymcbean is offline   Reply With Quote
Old 01-22-2013, 10:58 AM   #549
adesso
Scooby Specialist
 
Member#: 59892
Join Date: Apr 2004
Chapter/Region: South East
Location: Summerville, SC
Vehicle:
2004 Harman Tuned
GT30R .82 JBP STi

Default

Quote:
Originally Posted by flippymcbean View Post
Why would I need a new boost controller? I'm tuned at 17psi. They raised boost when I got tuned so...I don't know what to do anymore.
Are you on your factory turbo? Any work been done to the hot side? Boost creep is a mechanical issue and can't be tuned out. Sure, you can lower the amount of boost, but that's just a band aid. There's tons of info on here about boost creep and what to do about it. The best method for dealing with it short of going external wastegate set up is to port the factory wastegate opening. This is a very common issue when upgrading DP's. This was one of the reasons why STi's went from the VF39 to the VF43. Same size turbo, just with a factory ported wastegate.
adesso is online now   Reply With Quote
Old 01-22-2013, 11:39 AM   #550
flippymcbean
Scooby Specialist
 
Member#: 198546
Join Date: Dec 2008
Chapter/Region: South East
Location: Beaufort, South Carolina
Vehicle:
2003 Evolution VIII
Lightning Yellow

Default

Yeah stick turbo. I'm at a stage 2 tune. All I have os a downpipe. I understand that boost creep is a mechanical issue, but to my understanding its because of the flow coming out of the wastegate dumping into the. DP. With the way the HKS is designed it causes some kind of disturbance with the flow causing the wastegate to briefly stay stuck open which then causing boost creep. That's to my understanding that is.
flippymcbean is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:35 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.