Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-20-2013, 07:24 PM   #1
Damien
Scooby Newbie
 
Member#: 25234
Join Date: Sep 2002
Chapter/Region: International
Location: Wandering the World
Vehicle:
2013 Black WRX
287 Igg-Points just `cuz

Default Axxess ASWC working with bluetooth controls in `13 WRX with aftermarket stereo?

Hey guys.. just as the title says, I'm wondering if the Axxess ASWC is working with OEM bluetooth steering controls on an aftermarket stereo (Pioneer DEH X8500BS). I see that the Axxess works with the head unit listed but it's not confirmed to work in the `13 WRX. I'm assuming it will work as it worked with the `12 WRX. Thanks..

-Damien
* Registered users of the site do not see these ads.
Damien is online now   Reply With Quote
Old 01-20-2013, 10:36 PM   #2
rlight
Scooby Newbie
 
Member#: 344281
Join Date: Jan 2013
Default

I just installed a AVH-X5500BHS today in a 2013 WRX base with an Axxess ASWC. Make sure you have a solid connection, don't use those vampire clips, I made that mistake and then went back and soldered them.

All of the buttons including the bluetooth buttons work. Well... all except the voice control button.

I followed ae64.com's instructions.
rlight is offline   Reply With Quote
Old 01-21-2013, 01:19 PM   #3
nporcaro
Scooby Newbie
 
Member#: 330751
Join Date: Aug 2012
Vehicle:
2013 Impreza Sport
Grey

Default

I have a Pioneer AVH-X2500BT w/AWSC in my 2013 Sport Premium also, are you saying your BT on-hook/off buttons work to pickup and hang up the phone? Because my buttons work but not with phone on the my HU.
nporcaro is offline   Reply With Quote
Old 01-21-2013, 03:44 PM   #4
Damien
Scooby Newbie
 
Member#: 25234
Join Date: Sep 2002
Chapter/Region: International
Location: Wandering the World
Vehicle:
2013 Black WRX
287 Igg-Points just `cuz

Default

rlight, Thank you for the info and welcome to the forum!

-Damien
Damien is online now   Reply With Quote
Old 01-21-2013, 05:03 PM   #5
dysrhythmic
Scooby Newbie
 
Member#: 342668
Join Date: Jan 2013
Default

I also just installed the ASWC with a JVC KW-NT800HDT. The "hang up" and "pick up" buttons work on the steering wheel but I had to program them manually. I had to program them in opposite order according to the ASWC manual ("pickup up" button as "hang up" and "hang up" button as "pick up").

My voice control button also does not work. Though, it may be a limitation on the HU I have.
dysrhythmic is offline   Reply With Quote
Old 01-21-2013, 05:48 PM   #6
rlight
Scooby Newbie
 
Member#: 344281
Join Date: Jan 2013
Default

The instructions said to hook it up, hold down the up volume until the red light went solid, then press the Bluetooth buttons for them to program. Worked like a charm, I would love for my "voice control" button to activate the HU voice control, but ill have to read through the pioneer documentation on if there is even an option for doing it.

from documentation
8) For vehicles with OE Bluetooth buttons please press hang up or pick up on your steering wheel control after the LED on the ASWC goes solid. If the OE Bluetooth buttons are able to be used, the LED will go out after three seconds. Your OE Bluetooth buttons are now programmed to your aftermarket radios Bluetooth buttons. (Aftermarket radio must have Bluetooth capabilities)

Last edited by rlight; 01-21-2013 at 05:58 PM.
rlight is offline   Reply With Quote
Old 01-21-2013, 06:46 PM   #7
Damien
Scooby Newbie
 
Member#: 25234
Join Date: Sep 2002
Chapter/Region: International
Location: Wandering the World
Vehicle:
2013 Black WRX
287 Igg-Points just `cuz

Default

Thanks guys.. put in an order for the Axxess.

-Damien
Damien is online now   Reply With Quote
Old 01-21-2013, 07:52 PM   #8
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by rlight View Post
The instructions said to hook it up, hold down the up volume until the red light went solid, ...
In Subarus, you do not hold the volume button during the ASWC's auto programming. That technique is required in some other cars.
SVXdc is offline   Reply With Quote
Old 01-21-2013, 08:15 PM   #9
rlight
Scooby Newbie
 
Member#: 344281
Join Date: Jan 2013
Default

Just letting people know what I did and how it worked. Might not need to be done, but I've seen a lot of people on nosioc have issues with their controls not working and if this method helps someone out...
rlight is offline   Reply With Quote
Old 01-21-2013, 09:33 PM   #10
floods
Scooby Newbie
 
Member#: 337069
Join Date: Nov 2012
Chapter/Region: TXIC
Vehicle:
2013 WRX
SWP

Default

I actually installed a Pioneer Appradio 2 w/ an Axxess ASWC in my 2013 this afternoon!

Installation was pretty easy, and you can always reset it if you miss a step. I ordered both the ASWC and harness from 96svx.dc.

http://ae64.com/aswc-install.htm

Once you hook everything up, power it on and the ASWC's LED will flash for a bit as it auto-programs and then stay on. At that time press and hold the "on hook" (hang up) button on your BT steering wheels controls for about 5 seconds. It'll shut the LED off and your BT controls should be programmed. This is Pioneer-specific, so it should work with your 8500.

HTH.
floods is offline   Reply With Quote
Old 01-22-2013, 10:38 PM   #11
Damien
Scooby Newbie
 
Member#: 25234
Join Date: Sep 2002
Chapter/Region: International
Location: Wandering the World
Vehicle:
2013 Black WRX
287 Igg-Points just `cuz

Default

ok.. so installation was tonight.. Didn't work out so well and I may be kicking myself for a stupid issue.

ASWC arrived today. I didn't buy it from ae64.com. Didn't buy the harness from SVXdc.

I got it wired as I thought it was supposed to go using the harness Audio express sold me... Soldered all fittings but when it programs, goes into program mode and detects both subaru and pioneer categories but Vol Up on the steering wheel turns the volume down and pauses music and no solid light when I press and hold the on hook button. Please help!

-Damien
Damien is online now   Reply With Quote
Old 01-22-2013, 11:55 PM   #12
floods
Scooby Newbie
 
Member#: 337069
Join Date: Nov 2012
Chapter/Region: TXIC
Vehicle:
2013 WRX
SWP

Default

Have you updated the firmware on the ASWC, or did you install it straight out of the box?
floods is offline   Reply With Quote
Old 01-22-2013, 11:59 PM   #13
Damien
Scooby Newbie
 
Member#: 25234
Join Date: Sep 2002
Chapter/Region: International
Location: Wandering the World
Vehicle:
2013 Black WRX
287 Igg-Points just `cuz

Default

straight out of the box.. I can always go grab a laptop and a long cord and try to update.. No go.. popped the cover and it's a 4 pin plug.. no USB or micro usb..

-Damien

Last edited by Damien; 01-23-2013 at 12:26 AM.
Damien is online now   Reply With Quote
Old 01-23-2013, 12:53 AM   #14
Damien
Scooby Newbie
 
Member#: 25234
Join Date: Sep 2002
Chapter/Region: International
Location: Wandering the World
Vehicle:
2013 Black WRX
287 Igg-Points just `cuz

Default

So, I think I have it wired wrong.. I get 7 quick (no long flashes) flashes followed by 6 flashes. It detects the right head unit...

-Damien
Damien is online now   Reply With Quote
Old 01-23-2013, 01:56 AM   #15
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by Damien View Post
straight out of the box.. I can always go grab a laptop and a long cord and try to update.. No go.. popped the cover and it's a 4 pin plug.. no USB or micro usb..
Good thing you didn't have anything you thought would fit. The port in the ASWC is not USB. Metra's programming cable is not just wires with connectors -- it has interface electronics. See this thread.

What version does your module have? (on the white sticker, what are the last 3 digits of the long number before the date?) I'm guessing it's "308" (for version 3.08). See this thread.

Quote:
Originally Posted by Damien View Post
So, I think I have it wired wrong.. I get 7 quick (no long flashes) flashes followed by 6 flashes. It detects the right head unit..
Yep, definitely a problem with how it's wired (not wired) to your factory SWC wires. Did you remember to connect the car's common lead (pin 14) to ground?
SVXdc is offline   Reply With Quote
Old 01-23-2013, 03:03 PM   #16
Damien
Scooby Newbie
 
Member#: 25234
Join Date: Sep 2002
Chapter/Region: International
Location: Wandering the World
Vehicle:
2013 Black WRX
287 Igg-Points just `cuz

Default

yeah.. it turned out to be a ground wire issue. Good to go.

-Damien
Damien is online now   Reply With Quote
Old 01-23-2013, 04:20 PM   #17
Wavemandan
Scooby Newbie
 
Member#: 341351
Join Date: Dec 2012
Chapter/Region: South East
Location: Stuart, fl
Vehicle:
2007 Sti
Pearl White

Default

Good you got it to work.
Wavemandan is offline   Reply With Quote
Old 09-21-2013, 08:18 PM   #18
tyranotron
Scooby Newbie
 
Member#: 368970
Join Date: Sep 2013
Vehicle:
2013 WRX
Silver

Default

Quote:
Originally Posted by floods View Post
I actually installed a Pioneer Appradio 2 w/ an Axxess ASWC in my 2013 this afternoon!

Installation was pretty easy, and you can always reset it if you miss a step. I ordered both the ASWC and harness from 96svx.dc.

http://ae64.com/aswc-install.htm

Once you hook everything up, power it on and the ASWC's LED will flash for a bit as it auto-programs and then stay on. At that time press and hold the "on hook" (hang up) button on your BT steering wheels controls for about 5 seconds. It'll shut the LED off and your BT controls should be programmed. This is Pioneer-specific, so it should work with your 8500.

HTH.
Hey man. I'm new to this website and just recently purchased a 2013 base WRX. I'm looking to swap the stock audio system with the AppRadio 2 and that sounds like exactly what you did. Could you explain the process you went through to DIY? Specifically, how to remove the old radio unit. I tried fooling around with the panels this afternoon to see how easy it is to remove before I order any parts. I couldn't seem to get them to budge and I'm hesitant to really yank on anything still (because the car is brand new). Also, how do you like the set up? Does everything work well and integrate with the vehicle? Does the blue tooth feature come though the cars microphone?

Just to be clear, the parts that I need are as follows:
1.) ASWC steering wheel control adapter.
2.) 20-pin combined harness.
3.) Pioneer Appradio.
tyranotron is offline   Reply With Quote
Old 09-22-2013, 06:39 PM   #19
Ct Drummer
Scooby Newbie
 
Member#: 256749
Join Date: Sep 2010
Location: The shoreline of Ct
Vehicle:
2013 XV Crosstrek
Dark Grey Metallic

Default

Quote:
Originally Posted by tyranotron View Post
Just to be clear, the parts that I need are as follows:
1.) ASWC steering wheel control adapter.
2.) 20-pin combined harness.
3.) Pioneer Appradio.
If you are smart, you'll get the ASWC and the harness from SVXdc. That way your ASWC will have the latest firmware. SVXdc's wiring harnesses are nicely made, and he backs everything up as far as tech support, etc.

JMTCW,

Mike
Ct Drummer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:04 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.