Welcome to the North American Subaru Impreza Owners Club Wednesday July 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 01-25-2013, 06:50 PM   #1
Pengu
Scooby Newbie
 
Member#: 341101
Join Date: Dec 2012
Chapter/Region: MAIC
Location: VA
Vehicle:
2005 STI
World Rally Blue

Default 05 Smells of Gasoline in Cabin

In the last few days my car smells like gasoline but only with the heat on. Once the heat gets turned off there is no smell.

Other changing variables:

Very cold last few days
Only when heat is on (typically defrost)

I'd appreciate any input and thanks in advance!
* Registered users of the site do not see these ads.
Pengu is offline  
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-25-2013, 09:01 PM   #2
Type2
NASIOC Supporter
 
Member#: 200436
Join Date: Jan 2009
Chapter/Region: MWSOC
Location: Lawrence, KS
Vehicle:
2004 Forester XT
Black

Default

Million threads on this including mine. Look em up, but the short answer is you have a leaky fuel line or maybe injector line. Mine was both. I solved it by replacing all the lines and using tbolt clamps. In warm weather the lines don't leak. To be safe before you replace your lines get a fire extinguisher in your car handy asap. Good luck!
Type2 is offline  
Old 01-25-2013, 09:41 PM   #3
Unabomber
Big Ron
Moderator
 
Member#: 18062
Join Date: Apr 2002
Chapter/Region: MAIC
Location: I can save you a ton of cash
Vehicle:
on car parts so PM
me b4 j00 buy

Default

Unabomber is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:15 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.