Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-31-2013, 08:38 AM   #1
orndog
Scooby Specialist
 
Member#: 34670
Join Date: Mar 2003
Chapter/Region: South East
Location: Atlanta
Vehicle:
2013 No gears!
Saltine American

Default Converting back to Legacy

After 10 years in an Impreza I'm supposed to pick up my new Legacy today. The last one I owned was a '90 model
However, now I hear some have oil consumption issues, is this a widespread thing? Any other issues to watch out for?
* Registered users of the site do not see these ads.
orndog is online now   Reply With Quote
Old 02-06-2013, 02:37 AM   #2
tuma1979
Scooby Newbie
 
Member#: 346131
Join Date: Feb 2013
Chapter/Region: NWIC
Location: Portland Oregon
Vehicle:
2002 Legacy
Dark Maroon

Default

Quote:
Originally Posted by orndog View Post
After 10 years in an Impreza I'm supposed to pick up my new Legacy today. The last one I owned was a '90 model
However, now I hear some have oil consumption issues, is this a widespread thing? Any other issues to watch out for?
Not an answer, just saying that I just bought my first legacy today and I am excited to start working on it!
tuma1979 is offline   Reply With Quote
Old 02-06-2013, 07:10 AM   #3
orndog
Scooby Specialist
 
Member#: 34670
Join Date: Mar 2003
Chapter/Region: South East
Location: Atlanta
Vehicle:
2013 No gears!
Saltine American

Default

Quote:
Originally Posted by tuma1979 View Post
Not an answer, just saying that I just bought my first legacy today and I am excited to start working on it!
Awesome, what did you get???
orndog is online now   Reply With Quote
Old 02-06-2013, 07:57 PM   #4
DugsSin
Scooby Newbie
 
Member#: 296503
Join Date: Oct 2011
Vehicle:
'11 Legacy
Azurite

Default

Glad you stayed with AWD with that weather you've been getting this year.

11K on my leggy and no oil issues at all. She rides much nicer than a Rex.
DugsSin is offline   Reply With Quote
Old 02-07-2013, 10:39 AM   #5
orndog
Scooby Specialist
 
Member#: 34670
Join Date: Mar 2003
Chapter/Region: South East
Location: Atlanta
Vehicle:
2013 No gears!
Saltine American

Default

Rides nicer than a new Impreza too, if only it cornered better. I'm not after race car flat or a rough ride, but less lean would be appreciated.
What year is your Legacy DugsSin? I'm thinking the oil consumption applies to the timing chain engines.
orndog is online now   Reply With Quote
Old 02-07-2013, 06:51 PM   #6
DugsSin
Scooby Newbie
 
Member#: 296503
Join Date: Oct 2011
Vehicle:
'11 Legacy
Azurite

Default

Both of my subies are 2011's
DugsSin is offline   Reply With Quote
Old 02-07-2013, 10:49 PM   #7
rubaru_wagon_love
Scooby Newbie
 
Member#: 346334
Join Date: Feb 2013
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
90 Legacy
Silver

Default

Quote:
Originally Posted by orndog View Post
After 10 years in an Impreza I'm supposed to pick up my new Legacy today. The last one I owned was a '90 model
However, now I hear some have oil consumption issues, is this a widespread thing? Any other issues to watch out for?
I own a 90 leg now. As far as the oil consumption goes. I thought every Scooby ate oil. Maybe it's just the ones I've had, they haven't ever been brand new though.
rubaru_wagon_love is offline   Reply With Quote
Old 02-08-2013, 07:21 AM   #8
orndog
Scooby Specialist
 
Member#: 34670
Join Date: Mar 2003
Chapter/Region: South East
Location: Atlanta
Vehicle:
2013 No gears!
Saltine American

Default

I haven't had one use oil, but I bought a new '03 OBS and a used '90 Legacy that was babied before I got it. It was also silver :P
orndog is online now   Reply With Quote
Old 02-08-2013, 05:50 PM   #9
tuma1979
Scooby Newbie
 
Member#: 346131
Join Date: Feb 2013
Chapter/Region: NWIC
Location: Portland Oregon
Vehicle:
2002 Legacy
Dark Maroon

Default

I had an '02 WRX back in the day, but I lost it due to very unfortunate circumstances. I have had five Subarus in my life and can't find any reason to ever but another make of car... I just replaced my old 1987 gl wagon 4X4 with an '02 Legacy sedan, and I LOVE it!
tuma1979 is offline   Reply With Quote
Old 02-08-2013, 05:53 PM   #10
orndog
Scooby Specialist
 
Member#: 34670
Join Date: Mar 2003
Chapter/Region: South East
Location: Atlanta
Vehicle:
2013 No gears!
Saltine American

Default

Love the bugeye cars, was sad to have to trade mine.
orndog is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:29 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.