Welcome to the North American Subaru Impreza Owners Club Sunday October 23, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-01-2013, 07:49 PM   #1
Scooby Newbie
Member#: 337463
Join Date: Nov 2012
Chapter/Region: MAIC
Location: Glen Burnie Maryland
03 Wrx

Default car going rich after a drive in hard rain?

Im stuck! I have a 03 wrx. i just recently did a hybrid swap. and am in the process of tuning it through phatbotti. but im having some issues. i was driving in a hard rain the other day to go home. and my wideband started showing the car going really rich if i gave the car any more than quarter throttle. the car would drop in the 10.0-10.9 even at 2ish psi. it wasnt like this before. we got to the point where i needed to get injectors and a pump. anyway i did notice the air filter got wet. i removed the filter and made sure it was dry. and replaced the MAF sensor with a buddies. and it is still the same. any ideas?
Jcoleman134 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:35 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.