Welcome to the North American Subaru Impreza Owners Club Sunday December 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-02-2013, 05:04 PM   #1
zackg
Scooby Newbie
 
Member#: 248581
Join Date: Jun 2010
Chapter/Region: MAIC
Location: Pittsburgh
Vehicle:
2012 STI
WRB

Default Inconsistent brake performance

A few months ago I got into my car (cold day) and when I went to stop at a stop sign moving slowly, I pressed the brakes and it was like I was not pressing them at all. I had to basically press them to the floor to get the car to stop. The ABS did kick in and i felt that pulsation in the pedal. After a few brake pumps, the car was fine.

This has happened a few times since then. Mostly on cold days. It happens mostly when I first turn the car on, but I have had it happen after driving on the highway for 30 miles. Sometimes it happens when it's moist out, sometimes it does not. I have threw the ABS code where it's the brake light switch and the dealership has fixed that.

But the problem I am experiencing the most is my brake feel/performance is very inconsistent. Sometimes it is rock hard, and sometimes I feel that I need to really get on the brakes to make the car stop. All of this is on winter wheels as well. I know the car won't stop as great with winter wheels over the summer tires, but this is too extreme for that. The car has 27k on it and the problems probably first appeared around 23k. I almost think it's air in the line from how it feels, but I think that would attribute to the brakes being bad all the time. I am to the point where I feel unsafe if I have to slam on the brakes to avoid an accident.

Any thoughts/ideas? When I took it to the dealer for the ABS light, I told them about the pedal feel and of course.. "could not duplicate". Thanks for any help.
* Registered users of the site do not see these ads.
zackg is online now   Reply With Quote
Old 02-04-2013, 11:49 AM   #2
Mr Wrex
Scooby Specialist
 
Member#: 332887
Join Date: Sep 2012
Chapter/Region: Tri-State
Location: Orange County, NY
Vehicle:
2012 WRX stage 2+
DGM (sedan)

Default

I suggest getting the Grimmspeed master cylinder brace to eliminate the way the firewall flexes while braking. It could be a simple fix like bleeding your brakes.
Mr Wrex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:51 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.