Welcome to the North American Subaru Impreza Owners Club Wednesday September 3, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-02-2013, 08:33 PM   #1
stragen
Scooby Newbie
 
Member#: 218682
Join Date: Jul 2009
Chapter/Region: South East
Location: USA
Vehicle:
2006 WRX Stage 9001
DrunkMann'd @ GCM

Default Abnormal front disc wear pattern

Hey guys,

I noticed a weird brake pattern on my left driver's side front rotor today. I recently had Hawk HPS pads and stainless lines installed with Super blue fluid, and the were rotors turned. That was about a month and a half ago.

Today was the first time I have really dogged the brakes since the installation, enough such that some fluid apparently spilled on the caliper was smoking off when I stopped. The rotors were quite hot (duh), even after a minute or two of driving at lower speed down a long driveway. The pattern is deep enough to easily feel, maybe one or two thou deep/built-up -not sure which- already. I haven't noticed any sound or shudder.

I was planning on going to the track next week, so I'm hoping this is a simple thing.

Anybody have any thoughts? Pics below!

Driver's Side (Abnormal)


Passenger's Side (Normal)
stragen is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:07 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.