Welcome to the North American Subaru Impreza Owners Club Saturday July 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-06-2013, 08:34 AM   #1
10seckid
Scooby Newbie
 
Member#: 309081
Join Date: Feb 2012
Default Bugeye says hi!

Hey guys and girls....had an account for an year however never made a post so here goes. Been a Subaru fan since about 07 thought they sounded cool. Own an 02 wrx which has been fun but has had more than it's fair share of reliability issues.

Had if for about 2 and half years and I've lost the motor twice. The first the alcohol pump failed, resulting in a spun bearing and second I don't really know...well maybe i do, but lets just say it threw in the towel and quit....left me with a cracked piston and scored cylinder walls...did I mention the car only had 600k since rebuild. U
* Registered users of the site do not see these ads.
10seckid is offline   Reply With Quote
Old 02-06-2013, 08:36 AM   #2
Loyale93
Scooby Guru
 
Member#: 91347
Join Date: Jul 2005
Chapter/Region: NESIC
Location: Moscow, Russia
Vehicle:
'13 XV Crosstrek,
1050 Triumph Speed Triple

Default

600k... 600 kilometers? I'm assuming you don't mean 600 thousand miles.

Welcome either way.

Whatever you're doing while installing these motors, stop it.
Who ever you're using to install these motors, don't.

These engines are fairly reliable when properly worked on and maintained. Seems like something is awry.
Loyale93 is offline   Reply With Quote
Old 02-06-2013, 08:52 AM   #3
Jack
Add Lightness
Moderator
 
Member#: 13699
Join Date: Dec 2001
Chapter/Region: NESIC
Location: Hopkinton, MA
Vehicle:
2007 Lotus Elise
(From General)

Default

A worthwhile path to consider might be:
1) find good running WRX stock engine
2) Put it in your car
3) Don't do anything else
Jack is offline   Reply With Quote
Old 02-06-2013, 08:54 AM   #4
Mr Wrex
Scooby Specialist
 
Member#: 332887
Join Date: Sep 2012
Chapter/Region: Tri-State
Location: Orange County, NY
Vehicle:
2012 WRX stage 2+
DGM (sedan)

Default

^
4) maintanence
Mr Wrex is offline   Reply With Quote
Old 02-06-2013, 08:59 AM   #5
10seckid
Scooby Newbie
 
Member#: 309081
Join Date: Feb 2012
Default

Just posted up build spec on my Facebook page...check it out:

www.facebook.com/10seckid

Feel free to like and follow the saga!
10seckid is offline   Reply With Quote
Old 02-06-2013, 10:21 AM   #6
mhoerath
Scooby Specialist
 
Member#: 131379
Join Date: Nov 2006
Chapter/Region: MAIC
Location: richmond, va
Vehicle:
2003 354 ftlb@3k rpm
justablue hatch

Default

you're running lots of boost and meth too. Forged internals I hope. Suggest you set goals and match your mods...DD, rallycross, track?
mhoerath is offline   Reply With Quote
Old 02-06-2013, 11:31 AM   #7
10seckid
Scooby Newbie
 
Member#: 309081
Join Date: Feb 2012
Default

Check the link just posted up build spec...car is a track car ... I have to confirm with a few experts as to why my motor let go but I'm pretty sure I have a good idea...will have an answer by the end of the day!
10seckid is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:20 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.