Welcome to the North American Subaru Impreza Owners Club Saturday July 23, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Bay Area Impreza Club
Go Back   NASIOC > NASIOC Chapters > Bay Area Impreza Club Forum -- BAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-08-2013, 10:15 PM   #1
Walwezzy23
Scooby Newbie
 
Member#: 337851
Join Date: Nov 2012
Chapter/Region: BAIC
Location: Sacramento, CA
Vehicle:
2006 WRX
CGM

Default Ca Smog Help!!

hey guys i keep failing smog! EVERYTHING is completely stock but the car is running rich, though it was a bad cat changed that. thinking it is my front 02 but not sure. i got a Cell for a small evap leak (P0442 i think) any thoughts? Thanks in advanced for any helpful input.

Walwezzy23 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:30 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.