Welcome to the North American Subaru Impreza Owners Club Wednesday November 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-07-2013, 01:18 AM   #1
jrat
Scooby Newbie
 
Member#: 284932
Join Date: Jun 2011
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
2006 STi
WRB

Default 07 STi Stereo in an 06 STi

Hey guys, I rooted and researched for a long time to try and figure this out. I wanted that darn AUX port in my ash tray and everyone says "oh, plug and play, dude!" but what they don't say is that there's no plug in the back of the 07 head unit for your sub. So, yes, the stereo worked just fine but I didn't have my under-seat sub anymore. So, there's no clear examples/walkthroughs of this process so I thought I'd help out anyone (in case this is still an issue for people).

Keep in mind that your wire colors may be different. You should read these two threads too. That's where you'll learn how to remove your stereo and also learn more about the wiring.
http://forums.nasioc.com/forums/showthread.php?t=974142
http://forums.nasioc.com/forums/showthread.php?t=749402


Long story short, around 2005, Subaru started splitting off the sub connectors to have their own plug. Funny thing is though that those two wires going into the head unit are simply connecting to the rear speakers. So, you simply have to attach the two wires coming from your sub to the rear speaker wires going into your head unit. Go to radio shack and buy vampire clips (i think that's what they're called). They will attach the wires very easily. Everyone seems to get the red ones...those are the right size. Anyway, to convert your 2006 sub plug to an 07 HU, here's what you do...

(Disclaimer: I don't know much about wiring/stereos but this is my understanding)

This is what your sub plug looks like...



This is what your head unit plug looks like...



This is your head unit plug from the back. Notice, the purple and orange wires in the second column from the right. Those are PINS 5 and 13 and those are what you need to connect your sub wires to.



Here are those two wires back from the plug a little bit...



Now, cut your sub plug off. In case this didn't work or if I wanted to revert back to the 06 stereo, I left I gave myself enough slack on both sides to reverse what I've done.



Get your vampire clip and insert the purple wire going into the head unit. Also insert the clipped purple wire you took from your sub cable...



Clamp down and repeat with orange...



You should be good to go!
* Registered users of the site do not see these ads.
jrat is offline   Reply With Quote
Old 02-08-2013, 12:20 AM   #2
krarks
Scooby Newbie
 
Member#: 287192
Join Date: Jul 2011
Chapter/Region: W. Canada
Location: Canada
Vehicle:
2005 WRX STi
CGM

Default

That clip is called a "Scotch Lock" FYI haha. Good write up! I'm desperately searching for an 07 STI headunit with AUX to do the same to my 05! (yes I'm QUITE aware that aftermarket options may be cheaper/easily available but I'm not interested in doing that!)
krarks is offline   Reply With Quote
Old 02-09-2013, 05:54 PM   #3
jrat
Scooby Newbie
 
Member#: 284932
Join Date: Jun 2011
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
2006 STi
WRB

Default

Hah, yeah. I (obviously) didn't want to get aftermarket either - I think they look odd because of how much they stand out. The 07 HU worked great once I figured everything out. Good luck finding one; it took me a few months of waiting but I think I picked mine up for 120 or 150 (aux port included).
jrat is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:00 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.