Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-09-2013, 11:29 PM   #26
Badtiming
Scooby Newbie
 
Member#: 254996
Join Date: Aug 2010
Chapter/Region: Tri-State
Vehicle:
2010 Impreza 2.5i
White

Default

Quote:
Originally Posted by Akatc View Post
Whats the difference between 2010 and the 2011 wrx that would make this not work with it? I have the 2011wrx and this is exactly what I want.
Nothing as far as I know
* Registered users of the site do not see these ads.
Badtiming is offline   Reply With Quote
Old 02-09-2013, 11:31 PM   #27
Badtiming
Scooby Newbie
 
Member#: 254996
Join Date: Aug 2010
Chapter/Region: Tri-State
Vehicle:
2010 Impreza 2.5i
White

Default

Quote:
Originally Posted by max6spd View Post
Does it include a hands free kit?
It's built in!
Badtiming is offline   Reply With Quote
Old 02-11-2013, 05:00 PM   #28
Trustkevin13
Scooby Specialist
 
Member#: 259184
Join Date: Sep 2010
Chapter/Region: MWSOC
Location: Kansas
Vehicle:
2008 Subaru WRX
Silver

Default

i realized that i have some more questions. can the navi be more of a 2d? noticed in the video that it was a top down 3d look. i like the factory like look. much easier to see. along with how you get your iphone 4 to play through the navi, cause when i asked rosen, they said that i'd lose my aux jack in my car. plus where did you mount your anten thing? Xp

Last edited by Trustkevin13; 02-11-2013 at 05:11 PM.
Trustkevin13 is online now   Reply With Quote
Old 02-11-2013, 05:41 PM   #29
Badtiming
Scooby Newbie
 
Member#: 254996
Join Date: Aug 2010
Chapter/Region: Tri-State
Vehicle:
2010 Impreza 2.5i
White

Default

Quote:
Originally Posted by Trustkevin13 View Post
i realized that i have some more questions. can the navi be more of a 2d? noticed in the video that it was a top down 3d look. i like the factory like look. much easier to see. along with how you get your iphone 4 to play through the navi, cause when i asked rosen, they said that i'd lose my aux jack in my car. plus where did you mount your anten thing? Xp
Yes there is an icon on the navi screen to just put it in 2D view. I thought I mentioned that in the video. The aux jack still works, idk why they told you that. There is also an ipod cable it comes with that hooks directly up to the system. I didn't hook it up to mine because I don't have an ipod anymore. But if you just want to use your aux jack it still works as well.
Badtiming is offline   Reply With Quote
Old 02-11-2013, 05:54 PM   #30
Trustkevin13
Scooby Specialist
 
Member#: 259184
Join Date: Sep 2010
Chapter/Region: MWSOC
Location: Kansas
Vehicle:
2008 Subaru WRX
Silver

Default

woo! youre the best. I just need 150 more before i can afford this. which means one more weekend of work!
Trustkevin13 is online now   Reply With Quote
Old 02-14-2013, 01:33 PM   #31
Badtiming
Scooby Newbie
 
Member#: 254996
Join Date: Aug 2010
Chapter/Region: Tri-State
Vehicle:
2010 Impreza 2.5i
White

Default

Anyone interested in buying mine? I am about to switch to the 2013 legacy sport lol. I'd sell it for $300!
Badtiming is offline   Reply With Quote
Old 02-14-2013, 03:32 PM   #32
toms03se
Scooby Newbie
 
Member#: 345677
Join Date: Feb 2013
Default

I might be interested. Any pics?
toms03se is offline   Reply With Quote
Old 02-14-2013, 05:51 PM   #33
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

does this use the factory satellite tuner or aftermarket?
flyboy1100 is offline   Reply With Quote
Old 02-14-2013, 06:07 PM   #34
Kentrik
Scooby Specialist
 
Member#: 125937
Join Date: Sep 2006
Chapter/Region: RMIC
Location: 4894' above sea level.
Vehicle:
03 WRX I do not
like your tweed, chap.

Default

Looks OEM. I like it.




......but how does it sound? Say, compared to an Alpine or Eclipse headunit.
Kentrik is offline   Reply With Quote
Old 02-14-2013, 07:25 PM   #35
Badtiming
Scooby Newbie
 
Member#: 254996
Join Date: Aug 2010
Chapter/Region: Tri-State
Vehicle:
2010 Impreza 2.5i
White

Default

I have never own Alpine or Eclipse, but it sounds awesome! I am not sure what I am doing right now. My lease is up in another month and I need to decide if I am buying this car out or leasing a nice new Legacy.
Badtiming is offline   Reply With Quote
Old 02-15-2013, 10:29 PM   #36
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by Akatc View Post
Whats the difference between 2010 and the 2011 wrx that would make this not work with it? I have the 2011wrx and this is exactly what I want.
In cars with the phone/Bluetooth buttons on the steering wheel, the factory 20-pin harness has 3 pins for the steering wheel controls (pins 4, 13, and 14). Models without the BT buttons only use 2 pins (4 and 14). The two styles (BT vs. no-BT) also use completely different resistors inside the SWC pod.

Since Rosen specifically says this unit won't work in 2011-up Impreza or Forester -- "Supports the vehicle’s factory steering wheel controls (excluding Bluetooth controls)" -- that says they don't have a wire at pin 13. That has been the case with other similar "factory look" Chinese HUs.

Often, those Chinese HUs do have menu functions which allow you to program the function you want each SWC button to do. So in cars with the BT buttons, you could reprogram the HU to recognize the volume +/- and tune up/down buttons to work. But without pin 13, your phone and MODE buttons will be invisible to the HU.

The other big difference in 2011-up models is the harness for the factory 3.5mm aux jack. In 2008-up Impreza & Foresters without BT, the car's aux harness (plugged into the rear of the HU) has an 8-pin plug. Since this Rosen retains the factory aux jack, that means it has the same style of 8-pin socket.

2011-up models with BT switched to a 16-pin aux plug at the back of the HU. So the aux jack in those cars won't work without adapting that connection (either getting a custom 16-to-8 pin adapter from me, or extracting the pins from Rosen's 8-pin socket and sliding them "naked" into the newer car's 16-pin aux harness plug).

@Badtiming: When you have a chance, pull your HU and look at Rosen's harness to check whether it has a wire on Subaru pin 13. Here's my 20-pin pin-out for reference. I doubt it does, though.

Also look to see if their harness has an additional pin or wire for their SWC input. Those are often labeled "KEY 1" and 2, "AD1" and 2, or something similar. If it has a second wire that you can connect to Subaru's pin 13, and if it has the ability for the user to reprogram the SWCs, then it should be possible to make it work in a 2011-up car.

Incidentally, it could also work in an Impreza or Forester that had the OEM Kenwood Navi HU. You'd need several different harnesses to make that happen (to convert to the older style Subaru 14-pin power/speaker harness, and to the 24-pin harness the Navi uses for the aux input and SWCs).
SVXdc is offline   Reply With Quote
Old 02-17-2013, 03:31 PM   #37
2011rexowner
Scooby Newbie
 
Member#: 280094
Join Date: Apr 2011
Chapter/Region: NESIC
Location: rhode island
Vehicle:
2011 sti limited
Wrb,lots of upgrades

Default

mine, which is being put in tuesday specifically said for 2011-2013. there are several different rosen models. only bad thing ive heard is some units came through defective and depending on who you talk to they either were sent another one right away or had a real hard time with customer service. so the reviews were seriously mixed.

you did however get me thinking. im hoping this guy who i bought it from didnt make a mistake on the model/year.
2011rexowner is offline   Reply With Quote
Old 02-19-2013, 05:51 PM   #38
2011rexowner
Scooby Newbie
 
Member#: 280094
Join Date: Apr 2011
Chapter/Region: NESIC
Location: rhode island
Vehicle:
2011 sti limited
Wrb,lots of upgrades

Default

@badtiming. Hey i just had this installed and was wondering where you ended up putting the antenna. For that matter where do people typically put them? The guy said because of subarus design he had to go out the back and mount it on on the trunk lid.

If someone has a better idea and it maintains a good reception let me know please so i can have it changed

Last edited by 2011rexowner; 02-19-2013 at 05:53 PM. Reason: more info
2011rexowner is offline   Reply With Quote
Old 02-20-2013, 08:03 AM   #39
Trustkevin13
Scooby Specialist
 
Member#: 259184
Join Date: Sep 2010
Chapter/Region: MWSOC
Location: Kansas
Vehicle:
2008 Subaru WRX
Silver

Default

Can't you just put it inside the car and still get decent reception with it? i'd put mine near the A pillar once I get it. but that is after I purchase my vf52 Cant put it on till i know i can get a protune in june though
Trustkevin13 is online now   Reply With Quote
Old 02-20-2013, 11:15 AM   #40
2011rexowner
Scooby Newbie
 
Member#: 280094
Join Date: Apr 2011
Chapter/Region: NESIC
Location: rhode island
Vehicle:
2011 sti limited
Wrb,lots of upgrades

Default

ok so after getting this installed my initial review is "not to bad". one thing im a little irritated about is i dont see a interface for playing music straight from my galaxy s3. only thing i can figure is i have to add music to the sd card and hopefully play using the dvd setting, according to the manual. not sure why they would specifically cater to ipod only but thats the way it is. if anyone else has a similar nav system they had issues with please chime in. im hoping theres other systems out there that may have a similar setup.
2011rexowner is offline   Reply With Quote
Old 02-20-2013, 12:28 PM   #41
2011rexowner
Scooby Newbie
 
Member#: 280094
Join Date: Apr 2011
Chapter/Region: NESIC
Location: rhode island
Vehicle:
2011 sti limited
Wrb,lots of upgrades

Default

Ok so I just want to update on this. CDs work fine. Phone paired fine and receives calls. All the steering controls work. Radio works great.nav system seems to be good.

Now for the bad. DVD player doesn't work and keeps telling me car is in motion when it is clearly stopped with parking brake on. Not sure if there was a specific hook up dealer was suppose to do to allow this. It did say plug and play. Other thing I find incredibly annoying is I can't play music from my phone. I mean why have a blue tooth interface if you can't even include music from a phone?? It also comes with a 4 gig sd card. So I converted iTunes songs to mp3s and threw some on it. Lol the thing won't even read the card I put in.

After spending the money I did on the install I'm pretty f@@king aggravated. So now the question is. Do I uninstall and go back factory or do I accept it for what it is. There's no actual phone number to contact them. All through emails. Just bulls@it.

Nitwit alert: I finally got around to watching badtimings video to find out in order to use music through the phone you have to hit the little Bluetooth icon. In my defense nowhere does it say this in any of the manuals I have lol. So the only issue I have is the DVD not working because it thinks I'm in motion. Once again, I think the guy installing didn't understand that he needed to connect to the e brake.

So overall for the money you can get this for I'd recommend it.

Last edited by 2011rexowner; 02-20-2013 at 01:12 PM. Reason: More info
2011rexowner is offline   Reply With Quote
Old 02-20-2013, 02:21 PM   #42
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

I watched their install video on YouTube and it says you need to connect to the e brake switch somehow, so not 100% plug and play
flyboy1100 is offline   Reply With Quote
Old 02-20-2013, 04:12 PM   #43
Trustkevin13
Scooby Specialist
 
Member#: 259184
Join Date: Sep 2010
Chapter/Region: MWSOC
Location: Kansas
Vehicle:
2008 Subaru WRX
Silver

Default

2011rexowner. hows the navi in it? little laggy or anything?
Trustkevin13 is online now   Reply With Quote
Old 02-20-2013, 05:48 PM   #44
2011rexowner
Scooby Newbie
 
Member#: 280094
Join Date: Apr 2011
Chapter/Region: NESIC
Location: rhode island
Vehicle:
2011 sti limited
Wrb,lots of upgrades

Default

Quote:
Originally Posted by Trustkevin13 View Post
2011rexowner. hows the navi in it? little laggy or anything?
Its not bad. But let me say this. My father in law has a cadi suv with nav and even that plays catch up. Ive seen and used tons of different nav units. So far nothing is going to be as smooth as google lol. So yes its good but it can be a touch laggy but still worth the money. The bluetooth can be a little touchy connecting and playing through your phone. But once again my factory one was like that sometimes.
2011rexowner is offline   Reply With Quote
Old 02-20-2013, 05:53 PM   #45
2011rexowner
Scooby Newbie
 
Member#: 280094
Join Date: Apr 2011
Chapter/Region: NESIC
Location: rhode island
Vehicle:
2011 sti limited
Wrb,lots of upgrades

Default

Quote:
Originally Posted by flyboy1100 View Post
I watched their install video on YouTube and it says you need to connect to the e brake switch somehow, so not 100% plug and play
lol yeah i told the subaru guy that. I dont think they wanted to admit they messed up. Needless to say im going to just fix it with my buddy instead of letting them touch it again. Btw your better off just going to any ground so you bypass the driving feature hehe
2011rexowner is offline   Reply With Quote
Old 02-20-2013, 07:59 PM   #46
Trustkevin13
Scooby Specialist
 
Member#: 259184
Join Date: Sep 2010
Chapter/Region: MWSOC
Location: Kansas
Vehicle:
2008 Subaru WRX
Silver

Default

My mom's lexus' navigation is always spot on, rarely is it lagging. but then again, those lexus if only the is-f was 24k and awd
Trustkevin13 is online now   Reply With Quote
Old 02-20-2013, 10:37 PM   #47
miteemike3
Scooby Newbie
 
Member#: 338732
Join Date: Nov 2012
Location: Bay Area, CA
Vehicle:
2013 WRX

Default

Thanks for the update 2011rexowner - I've been following this thread rather closely and for the price, it seems this is probably one of the most cost effective navi upgrades. Ordered my navi and it should be here mid next week. I'll be sure to update once I finish the install
miteemike3 is offline   Reply With Quote
Old 02-21-2013, 12:10 AM   #48
Badtiming
Scooby Newbie
 
Member#: 254996
Join Date: Aug 2010
Chapter/Region: Tri-State
Vehicle:
2010 Impreza 2.5i
White

Default

Quote:
Originally Posted by 2011rexowner View Post
Ok so I just want to update on this. CDs work fine. Phone paired fine and receives calls. All the steering controls work. Radio works great.nav system seems to be good.

Now for the bad. DVD player doesn't work and keeps telling me car is in motion when it is clearly stopped with parking brake on. Not sure if there was a specific hook up dealer was suppose to do to allow this. It did say plug and play. Other thing I find incredibly annoying is I can't play music from my phone. I mean why have a blue tooth interface if you can't even include music from a phone?? It also comes with a 4 gig sd card. So I converted iTunes songs to mp3s and threw some on it. Lol the thing won't even read the card I put in.

After spending the money I did on the install I'm pretty f@@king aggravated. So now the question is. Do I uninstall and go back factory or do I accept it for what it is. There's no actual phone number to contact them. All through emails. Just bulls@it.

Nitwit alert: I finally got around to watching badtimings video to find out in order to use music through the phone you have to hit the little Bluetooth icon. In my defense nowhere does it say this in any of the manuals I have lol. So the only issue I have is the DVD not working because it thinks I'm in motion. Once again, I think the guy installing didn't understand that he needed to connect to the e brake.

So overall for the money you can get this for I'd recommend it.

Hahah yeah man I hit that icon by accident and found out I can play music via blue tooth. I would have never had a clue otherwise..
Badtiming is offline   Reply With Quote
Old 02-21-2013, 03:07 AM   #49
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Some Chinese HUs have a menu option to disable the parking brake lockout. If yours has that, you won't need to pull the HU and connect the wire.

If you don't have a menu option, with many Chinese models you can simply connect the HU's brake lead to chassis ground.

See this for potential GPS antenna location.
SVXdc is offline   Reply With Quote
Old 02-21-2013, 03:24 PM   #50
2011rexowner
Scooby Newbie
 
Member#: 280094
Join Date: Apr 2011
Chapter/Region: NESIC
Location: rhode island
Vehicle:
2011 sti limited
Wrb,lots of upgrades

Default

Quote:
Originally Posted by SVXdc View Post
Some Chinese HUs have a menu option to disable the parking brake lockout. If yours has that, you won't need to pull the HU and connect the wire.

If you don't have a menu option, with many Chinese models you can simply connect the HU's brake lead to chassis ground.

See this for potential GPS antenna location.
Yeah your the second guy to tell me a lot of aftermarket have that disabling feature. I'll check it out later when I'm off work. Also the guy ran the antenna all the way out the back to my back trunk lid??? Lmao. I really wish they would call before doing stupid stuff like this. Anyway, knowing its not really weatherproof I moved it inside under the trunk lid. So far it seems to have no problem. I just wish he would have used the damn metal piece and stuck it above the clock on the dash.

And yes, if it has no bypass I plan on running it straight to ground so it always works
2011rexowner is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:19 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.