Welcome to the North American Subaru Impreza Owners Club Sunday December 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-20-2013, 09:37 PM   #1
fatso
Scooby Newbie
 
Member#: 227527
Join Date: Oct 2009
Location: San Juan
Vehicle:
2005 WRX
Black

Default Pioneer X4500BT Wiring Harness Noob QuestionS

I'm almost done with the installation of my new Pionner AVH_X4500BT.


I Still have a few (probably dumb) questions about how to wire my 05 WRX. Where these cables go?




WRX PLUG:
A- ILLUMINATION/DASH LIGHT (ORANGE)
B- POWER ANTENNA (BLUE)

PIONEER PLUG:
C- PARKING BRAKE (LIGHT GREEN)
D- ? (ORANGE/WHITE)

I'm gapping the following:

E- SYSTEM REMOTE CONTROL (BLUE/WHITE)
F- MUTE (YELLOW/BLACK)
G- REVERSE GEAR SIGN INPUT (PURPLE/WHITE)

Any help would be greatly appreciated.


*Will Ground Both black cables.
* Registered users of the site do not see these ads.
fatso is offline   Reply With Quote
Old 02-20-2013, 10:40 PM   #2
dbmonster
Scooby Newbie
 
Member#: 335675
Join Date: Oct 2012
Chapter/Region: TXIC
Vehicle:
2013 WRX hatch
Obsidian Black Pearl

Default

The orange wire (A) on the wrx harness goes to the orange/white wire (D) on the pioneer harness, this is optional though, only if you want the screen and buttons on the pioneer to dim down when you turn your lights on.

The blue wire (on the wrx harness) I don't recommend using. On cars with a motorized antenna, some people will connect the amp turn on lead (blue/white wire) to this wire since pioneers don't have a true power antenna wire, but our cars don't have a motorized antenna. I'm not 100% sure, but I think that wire may be used to power a stock antenna booster (if there is one), and if so it may require more current then the pioneers turn on wire can provide. if you actually listen to FM radio you may want to try connecting this wire, I usually don't bother with mine.

The green parking brake wire, this is SUPPOSED to be tapped onto to the wire that comes from your parking brake that tells your cars computer that the parking brake is engaged. this is the LEGAL way to do it, and your pioneer unit will only display video when the parking brake is engaged. If you want to watch video while driving PM me and I will explain how.
dbmonster is offline   Reply With Quote
Old 02-20-2013, 10:43 PM   #3
fatso
Scooby Newbie
 
Member#: 227527
Join Date: Oct 2009
Location: San Juan
Vehicle:
2005 WRX
Black

Default

Thanks! You've been very helpful.
fatso is offline   Reply With Quote
Old 02-20-2013, 10:49 PM   #4
dbmonster
Scooby Newbie
 
Member#: 335675
Join Date: Oct 2012
Chapter/Region: TXIC
Vehicle:
2013 WRX hatch
Obsidian Black Pearl

Default

No problem, and congrats on picking a great head unit.
dbmonster is offline   Reply With Quote
Old 02-24-2013, 11:40 PM   #5
pezcore
Scooby Specialist
 
Member#: 178045
Join Date: Apr 2008
Chapter/Region: South East
Vehicle:
06 WRX
CGM

Default

If the Pioneer has a blue antenna lead you definitely need to hookup the power antenna wire. Without it, you'll get no radio reception.

I know this is the case on my Alpine stereo, but if Pioneer doesn't have this wire then I guess you don't need to worry about it.

Also, been thinking of getting one of the new Pioneers, how do you like yours?
pezcore is offline   Reply With Quote
Old 02-25-2013, 11:36 AM   #6
razzmatazz_21
Scooby Newbie
 
Member#: 348221
Join Date: Feb 2013
Location: Kansas City
Vehicle:
2008 impreza
blue

Default

Orange wire connect to orange/white wire
blue wire to blue/white
green parking break wire to the vehicle's parking break wire (or you could attach it to a simple 2 prong switch with a ground to the radios ground...pick one up at any auto parts store for $6)
Yellow/black forget about it
And the reverse gear wire you would only need if you had a back up camera
razzmatazz_21 is offline   Reply With Quote
Old 03-01-2013, 12:16 PM   #7
pezcore
Scooby Specialist
 
Member#: 178045
Join Date: Apr 2008
Chapter/Region: South East
Vehicle:
06 WRX
CGM

Default

So I bought this radio, for a Subaru (with the antenna in the rear glass) you have to connect the Car's blue antenna wire to the Pioneer Blue remote wire if you want your radio to work, these cars need power to the antenna. If you have an amp it's the same lead, you can use it for both amp turn-on and antenna power.

So, if you haven't finished this already:

A to D
B to E
C to parking brake or bypass
F leave alone
pezcore is offline   Reply With Quote
Old 03-14-2013, 10:40 AM   #8
yudangorgor
Scooby Newbie
 
Member#: 151107
Join Date: Jun 2007
Location: Toronto
Vehicle:
2011 WRX
SWP

Default

i'm going to install this unit next week.
quite excited

Last edited by yudangorgor; 03-14-2013 at 06:12 PM.
yudangorgor is offline   Reply With Quote
Old 03-15-2013, 04:12 AM   #9
Dika213
Scooby Newbie
 
Member#: 350243
Join Date: Mar 2013
Default

Hey I just installed an Alpine headunit on my Impreza WRX just recently, I have bad reception sometimes any suggestion? I think I installed everything properly, left out the yellow/blue stipe wire out and yellow/black stripe wire (any idea what are those for?).
Dika213 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:03 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.