Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Reviews > Car Part Reviews

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-19-2009, 03:57 PM   #26
mystilexzero
Scooby Specialist
Member Sales Rating: (15)
 
Member#: 154674
Join Date: Jul 2007
Chapter/Region: BAIC
Location: Nor cal
Vehicle:
2007 wrx
ugm

Default

oic, my set-up is ewg with both ports being used like the diagram

, new update after i did some real pulls on the freeway i got some spikes so right now its at 4.0 crack and 75% duty cycle, what is your settings Turbodxsti
* Registered users of the site do not see these ads.
mystilexzero is offline   Reply With Quote
Old 04-19-2009, 05:06 PM   #27
TurboDXsti
Scooby Specialist
Member Sales Rating: (9)
 
Member#: 106671
Join Date: Feb 2006
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2006 Sti
grey

Default

on my red , it's 4.0 and 38% duty , boost " A " is a constant 20.6 . What I figured out is reduce your crack pressure it reduces spike but causes more lag , so what I did was reduce the crack to 3.0 and duty to 30 then slowly increased the crack by .5 and the duty by (2) untill i got the # I was looking for. Once your hitting stable boost then increase the WG duty cycle only to achieve target boost
TurboDXsti is offline   Reply With Quote
Old 02-02-2010, 10:40 PM   #28
xgilx
Scooby Newbie
Member Sales Rating: (0)
 
Member#: 233770
Join Date: Dec 2009
Chapter/Region: SWIC
Location: Reno, NV
Vehicle:
2006 WRX LTD.
CGM

Default

Can anyone tell me what fittings and size hose came with the kit? i picked up the controller and the solenoid from a friend.
xgilx is offline   Reply With Quote
Old 02-03-2010, 09:03 AM   #29
scoobin'
Scooby Newbie
Member Sales Rating: (4)
 
Member#: 14754
Join Date: Jan 2002
Location: agapitoonline.com
Vehicle:
02 WRX(X)FXT(X)
08sti, 11outlander, 03evo

Default

it should come with all of this
scoobin' is offline   Reply With Quote
Old 02-03-2010, 02:58 PM   #30
xgilx
Scooby Newbie
Member Sales Rating: (0)
 
Member#: 233770
Join Date: Dec 2009
Chapter/Region: SWIC
Location: Reno, NV
Vehicle:
2006 WRX LTD.
CGM

Default

Quote:
Originally Posted by scoobin' View Post
it should come with all of this
yea i picked it up from my friend who owns an evo. the current setup on the boost solenoid is the muffler is on the right side port, the 1/8" barb is on the front and one of the 3/16" barb is on the left side when looking head on at the solenoid. now im wondering if thats correct for my wrx?
xgilx is offline   Reply With Quote
Old 02-03-2010, 03:26 PM   #31
scoobin'
Scooby Newbie
Member Sales Rating: (4)
 
Member#: 14754
Join Date: Jan 2002
Location: agapitoonline.com
Vehicle:
02 WRX(X)FXT(X)
08sti, 11outlander, 03evo

Default

i have a vf22 with the stock wastegate and i have my muffler on the side...i'll double-check which side it's on
scoobin' is offline   Reply With Quote
Old 02-03-2010, 10:07 PM   #32
xgilx
Scooby Newbie
Member Sales Rating: (0)
 
Member#: 233770
Join Date: Dec 2009
Chapter/Region: SWIC
Location: Reno, NV
Vehicle:
2006 WRX LTD.
CGM

Default

Quote:
Originally Posted by scoobin' View Post
i have a vf22 with the stock wastegate and i have my muffler on the side...i'll double-check which side it's on
could you take a pic of your setup

Last edited by xgilx; 02-05-2010 at 12:42 AM. Reason: wanted to quote
xgilx is offline   Reply With Quote
Old 02-11-2010, 02:47 PM   #33
scoobin'
Scooby Newbie
Member Sales Rating: (4)
 
Member#: 14754
Join Date: Jan 2002
Location: agapitoonline.com
Vehicle:
02 WRX(X)FXT(X)
08sti, 11outlander, 03evo

Default

this is how i have mine set up...the front port goes to the compressor and the left port goes to the wastegate

scoobin' is offline   Reply With Quote
Old 10-08-2010, 08:18 PM   #34
spoolinIT
Scooby Newbie
Member Sales Rating: (3)
 
Member#: 259598
Join Date: Oct 2010
Chapter/Region: South East
Location: Davie, FL
Vehicle:
2002 Miata

Default

really silly question im sure, and i have looked around a bit. but i cant seem to get a straight answer on if this product shows current boost aside from controlling it. im pretty sure it would just really wanna make sure. thank you.
spoolinIT is offline   Reply With Quote
Old 10-08-2010, 11:55 PM   #35
dr3w
Scooby Specialist
Member Sales Rating: (9)
 
Member#: 222318
Join Date: Sep 2009
Chapter/Region: E. Canada
Location: Montreal
Vehicle:
1993 RHD GC8
Silver

Default

^ Yes its also a boost gauge
dr3w is offline   Reply With Quote
Old 10-09-2010, 05:23 PM   #36
spoolinIT
Scooby Newbie
Member Sales Rating: (3)
 
Member#: 259598
Join Date: Oct 2010
Chapter/Region: South East
Location: Davie, FL
Vehicle:
2002 Miata

Default

Quote:
Originally Posted by dr3w
^ Yes its also a boost gauge
Awesome ty
spoolinIT is offline   Reply With Quote
Old 11-14-2010, 07:12 PM   #37
metoo
Scooby Guru
Member Sales Rating: (4)
 
Member#: 4764
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Houston
Vehicle:
2004 STi sold :(
forizzle

Default

So is TurboDXsti the only guy here with a Truboost that is getting boost spikes?

Actually, I'm not so sure that's a spike, just a peaky curve due to a turbo that doesn't have a lot of breath at those pressures. In other words, it needs to be turned down a bit if he wants 23psi max.

22 mo
metoo is offline   Reply With Quote
Old 02-04-2011, 07:10 PM   #38
Icebound
Scooby Newbie
Member Sales Rating: (3)
 
Member#: 235648
Join Date: Jan 2010
Chapter/Region: TXIC
Location: Hurst,TX
Vehicle:
2006 Impreza Sti
SGM

Default

i was using my truboost as just a gauge till i fixd my 02 wrx. recently installed the BPS after the car was fixd, and now im spiking 34psi. I have no tune just stock. and im trying to set the controller to stock settings for now till, i mod more later on down the line.

Can anyone help me out?
Icebound is offline   Reply With Quote
Old 02-04-2011, 10:26 PM   #39
dr3w
Scooby Specialist
Member Sales Rating: (9)
 
Member#: 222318
Join Date: Sep 2009
Chapter/Region: E. Canada
Location: Montreal
Vehicle:
1993 RHD GC8
Silver

Default

I have the truboost and i don't spike, if your spiking its becouse you didn't set the crack pressure properly.
dr3w is offline   Reply With Quote
Old 02-05-2011, 03:34 AM   #40
Icebound
Scooby Newbie
Member Sales Rating: (3)
 
Member#: 235648
Join Date: Jan 2010
Chapter/Region: TXIC
Location: Hurst,TX
Vehicle:
2006 Impreza Sti
SGM

Default

Right now after lookin at it. Wg crack pressure was at .20 read install instructions and now im at 5psi wg crack pressure and Still spiking.
Icebound is offline   Reply With Quote
Old 05-27-2011, 03:49 PM   #41
1cleenwrx
Scooby Specialist
Member Sales Rating: (6)
 
Member#: 170542
Join Date: Jan 2008
Chapter/Region: MAIC
Location: HAMPTON,VA
Vehicle:
08 AGILEbuilt-STI
93Soarer/01RSTI/06SPEC-B

Default

I just got the aemtru boost and i am about to switch from the prodrive EBC to this. i will post picks of it and the set up once complete, this thread has helped a lot in my install so far. i have a custom rotated 30r ewg set up just to let you guys know. i am going to try to set boost at round 19-20 until i get back to my tuner for more boost.
1cleenwrx is offline   Reply With Quote
Old 03-26-2012, 02:57 PM   #42
twp5253
Scooby Newbie
Member Sales Rating: (0)
 
Member#: 314695
Join Date: Mar 2012
Default How does it "Crack open" the Wastegate?

I have just installed this unit in a RZR that was turboed with a Garret Hybrid turbo with an Internal single port wastegate. Can anyone tell me how the AEM True Boost Controller is able to "crack the wastegate" prior to the boost pressure that would normally be required to override the spring? Does the little solenoid have the ability to create a high pressure signal that it sends to the wastegate? Thank you so much, I really need to answer this question.

My motor is having trouble producing boost whether the controller is running or not. Feels to me like the linkage leading to the W/G is holding the W/G valve open just slightly. I can get boost, but it only happened reliably at night when very cool and after long periods of full throttle application...it was a fun ride!
Thorne
twp5253 is offline   Reply With Quote
Old 10-19-2012, 08:13 AM   #43
sackytar
Scooby Guru
Member Sales Rating: (43)
 
Member#: 149262
Join Date: May 2007
Chapter/Region: MWSOC
Location: Grand Rapids MI
Vehicle:
03WR Rally/XTDD/98SJ
PrimerGrey

Default

Anyone using this feature to help spool up?:


User selectable waste gate delay for quick turbo spool


Rob
sackytar is offline   Reply With Quote
Old 02-04-2013, 12:16 AM   #44
05subaru_94
Scooby Newbie
Member Sales Rating: (1)
 
Member#: 321271
Join Date: May 2012
Chapter/Region: MAIC
Location: Lehigh valley
Vehicle:
05 wrx wagon
Silver

Default

I have a quick question..

When the power is cut from entire car does the tru boost system have a memory function so when the power is back on you do not have to reset every thing? Or anything at all?

If this thread is still alive just trying to clearify an important concern
05subaru_94 is offline   Reply With Quote
Old 02-20-2013, 10:29 PM   #45
djoye
Scooby Specialist
Member Sales Rating: (4)
 
Member#: 50072
Join Date: Dec 2003
Chapter/Region: South East
Location: TN
Vehicle:
2003 WRX
12.3@112 20psi

Default

I've had it in my car since 2007 and I've removed the battery power many times since then and never lost the settings so it probably stores them in memory in the gauge itself.
djoye is offline   Reply With Quote
Old 02-21-2013, 07:40 AM   #46
sackytar
Scooby Guru
Member Sales Rating: (43)
 
Member#: 149262
Join Date: May 2007
Chapter/Region: MWSOC
Location: Grand Rapids MI
Vehicle:
03WR Rally/XTDD/98SJ
PrimerGrey

Default

Quote:
Originally Posted by twp5253 View Post
I have just installed this unit in a RZR that was turboed with a Garret Hybrid turbo with an Internal single port wastegate. Can anyone tell me how the AEM True Boost Controller is able to "crack the wastegate" prior to the boost pressure that would normally be required to override the spring? Does the little solenoid have the ability to create a high pressure signal that it sends to the wastegate? Thank you so much, I really need to answer this question.

My motor is having trouble producing boost whether the controller is running or not. Feels to me like the linkage leading to the W/G is holding the W/G valve open just slightly. I can get boost, but it only happened reliably at night when very cool and after long periods of full throttle application...it was a fun ride!
Thorne
Sounds like boost leak issues. Test it.
sackytar is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Electronic Boost Controller.....port question?? Tempest1o1 Newbies & FAQs 3 06-03-2010 07:39 PM
Tru-Boost Electronic Boost & Wideband 02 jpjester General Community 3 09-02-2009 05:29 PM
Turbosmart E-Boost electronic boost controller kpowell12 Engine/Power/Exhaust 17 05-17-2009 04:46 PM
Electronic boost controllers...which one are you using? Black-STi North West Impreza Club Forum -- NWIC 12 10-06-2006 05:27 PM
what electronic boost controller, you all using? WRXout Texas Impreza Club Forum -- TXIC 34 11-05-2005 01:21 PM


All times are GMT -4. The time now is 08:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.