Welcome to the North American Subaru Impreza Owners Club Wednesday November 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Interior & Exterior Modification

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-20-2013, 08:11 PM   #1
Daddy_Digital
Scooby Specialist
 
Member#: 274205
Join Date: Feb 2011
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2002 WRX Sport Wagon
World Rally Blue

Question Hella Horns pushing up against grill on 2002 WRX

I just received my hella horns, bracket and wiring harness from Subimods.com in the mail today. Everything during the installation went great. It wasn't until it was time to reinstall the grill that I had a problem. I noticed that the horns are making contact with the back of the grill and I can not put the grill on properly. I tried contacting Subimods and I am waiting for an email reply from them. I dont think they designed the bracket to be this way. But I could be wrong. Yes, I could just bend the bracket or something, but I am trying to avoid that if I can.

Has anyone who has/had this kit run into this problem? How did you over come it? Thanks in advance.
* Registered users of the site do not see these ads.
Daddy_Digital is offline   Reply With Quote
Old 02-20-2013, 08:13 PM   #2
BluewaterAWD
Scooby Newbie
 
Member#: 262210
Join Date: Oct 2010
Chapter/Region: International
Vehicle:
2011

Default

Look at the install videos on Youtube ; May see your issue there?
BluewaterAWD is offline   Reply With Quote
Old 02-20-2013, 08:42 PM   #3
Daddy_Digital
Scooby Specialist
 
Member#: 274205
Join Date: Feb 2011
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2002 WRX Sport Wagon
World Rally Blue

Default

Quote:
Originally Posted by BluewaterAWD View Post
Look at the install videos on Youtube ; May see your issue there?
They have one? I searched for one and didnt find it. I am using the subimods bracket by the way. I contacted subimods and they are supposedly in the works of getting a install write up (rolls eyes). So they weren't very much help at all except for explaining how to install the kit. Which was pretty easy.
Daddy_Digital is offline   Reply With Quote
Old 02-20-2013, 08:59 PM   #4
07wrxstage2
NASIOC Supporter
 
Member#: 262366
Join Date: Oct 2010
Chapter/Region: MAIC
Location: MD
Vehicle:
2006 OBP STI
2000 BRP IMPREZA 2.5RS

Default

Looks like this guy just took the grille out. http://forums.nasioc.com/forums/show....php?t=2146657

Also here's another link. Not really the answer your looking for but some other suggestions in here. http://www.perth-wrx.com/vb/mechanic...lp-02-sti.html
07wrxstage2 is online now   Reply With Quote
Old 02-20-2013, 09:06 PM   #5
Daddy_Digital
Scooby Specialist
 
Member#: 274205
Join Date: Feb 2011
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2002 WRX Sport Wagon
World Rally Blue

Default

Quote:
Originally Posted by 07wrxstage2 View Post
Looks like this guy just took the grille out. http://forums.nasioc.com/forums/show....php?t=2146657

Also here's another link. Not really the answer your looking for but some other suggestions in here. http://www.perth-wrx.com/vb/mechanic...lp-02-sti.html
Thank you for your reply. I was thinking about not using the bracket, but then Id have to send it back or sell it for a cheaper price. Why doesn't this just work like it is suppose to?
Daddy_Digital is offline   Reply With Quote
Old 02-20-2013, 09:23 PM   #6
07wrxstage2
NASIOC Supporter
 
Member#: 262366
Join Date: Oct 2010
Chapter/Region: MAIC
Location: MD
Vehicle:
2006 OBP STI
2000 BRP IMPREZA 2.5RS

Default

Quote:
Originally Posted by Daddy_Digital View Post
Thank you for your reply. I was thinking about not using the bracket, but then Id have to send it back or sell it for a cheaper price. Why doesn't this just work like it is suppose to?
Wish I could answer that. You would've thought they would of had enough customers comment on it and they or someone would make a specific bracket or something to make it work.
07wrxstage2 is online now   Reply With Quote
Old 02-20-2013, 09:25 PM   #7
Daddy_Digital
Scooby Specialist
 
Member#: 274205
Join Date: Feb 2011
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2002 WRX Sport Wagon
World Rally Blue

Default

Quote:
Originally Posted by 07wrxstage2 View Post
Wish I could answer that. You would've thought they would of had enough customers comment on it and they or someone would make a specific bracket or something to make it work.
Exactly. This was suppose to be the correct bracket for my car. I guess I will have to wait until subimods gets back to me or someone who has had this problem before. I swear, the oddest things happen when I work on my car fml.
Daddy_Digital is offline   Reply With Quote
Old 02-20-2013, 09:28 PM   #8
krambte79
NASIOC Supporter
 
Member#: 97452
Join Date: Oct 2005
Chapter/Region: South East
Location: Broussard, LA
Vehicle:
05 STi, 02 STi
& 09Ltd Tribeca

Default

I just bent the bracket back once installed and works fine for me. But yes it doesnt fit.
krambte79 is offline   Reply With Quote
Old 02-20-2013, 09:29 PM   #9
Daddy_Digital
Scooby Specialist
 
Member#: 274205
Join Date: Feb 2011
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2002 WRX Sport Wagon
World Rally Blue

Default

Quote:
Originally Posted by krambte79 View Post
I just bent the bracket back once installed and works fine for me. But yes it doesnt fit.
So it doesnt fit. Hmm interesting. Thanks for the reply. I think I know what must be done now. anyone want to buy a subimods hella horn bracket hahaha?
Daddy_Digital is offline   Reply With Quote
Old 02-20-2013, 09:33 PM   #10
07wrxstage2
NASIOC Supporter
 
Member#: 262366
Join Date: Oct 2010
Chapter/Region: MAIC
Location: MD
Vehicle:
2006 OBP STI
2000 BRP IMPREZA 2.5RS

Default

Actually found two answers in here how to do it. http://www.perth-wrx.com/vb/mechanic...lp-02-sti.html
07wrxstage2 is online now   Reply With Quote
Old 02-20-2013, 10:12 PM   #11
SubieMonte
Scooby Specialist
 
Member#: 264803
Join Date: Nov 2010
Chapter/Region: MWSOC
Location: Michigan
Vehicle:
2005 WRX Wagon
OBP

Default

I had this problem too. Carefully jammed it on and it rubbed some paint off. Oh well. And their harness is $##+ too. What a joke. I have an octopus in my engine bay.
SubieMonte is offline   Reply With Quote
Old 02-20-2013, 11:33 PM   #12
Daddy_Digital
Scooby Specialist
 
Member#: 274205
Join Date: Feb 2011
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2002 WRX Sport Wagon
World Rally Blue

Default

Quote:
Originally Posted by SubieMonte View Post
I had this problem too. Carefully jammed it on and it rubbed some paint off. Oh well. And their harness is $##+ too. What a joke. I have an octopus in my engine bay.
The wiring was a bit messy. But I did my best to keep the rat's nest at bay.
Daddy_Digital is offline   Reply With Quote
Old 02-20-2013, 11:37 PM   #13
Daddy_Digital
Scooby Specialist
 
Member#: 274205
Join Date: Feb 2011
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2002 WRX Sport Wagon
World Rally Blue

Default

I found a solution for the time being. I will need to relocate the transmission cooler I have mounted in front of the AC condenser. But mean while I get the trans cooler, instead of having them held out to the side, i pointed them down. So only top half of the horn shows above the bumper. I dont see how they fit that way and not the way they should. Once I relocate the trans cooler, I will have some room to bend the bracket a bit so it doesn't rub up on the grill.
Daddy_Digital is offline   Reply With Quote
Old 02-21-2013, 01:23 AM   #14
silverF4turbo
Scooby Guru
 
Member#: 20492
Join Date: Jun 2002
Chapter/Region: MAIC
Location: DC
Vehicle:
` BUGEYE GARAGE

Default

I have the same issue with my Subimods bracket. I basically "modified" it by bending it on my knee. If you do it this way be careful not to smoosh in the radiator fins.

But I don't know why people locate them there anyway... never a fan of the look personally
silverF4turbo is offline   Reply With Quote
Old 02-21-2013, 07:45 AM   #15
wirebiter
Scooby Newbie
 
Member#: 327574
Join Date: Jul 2012
Chapter/Region: NESIC
Vehicle:
2002 WRX
Silver

Default

you can also mound them on the top bar that runs across the front. there should be 2 evenly spaced holes that will allow them to be seen nicely behind the grill.
wirebiter is offline   Reply With Quote
Old 02-21-2013, 04:29 PM   #16
Daddy_Digital
Scooby Specialist
 
Member#: 274205
Join Date: Feb 2011
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2002 WRX Sport Wagon
World Rally Blue

Default

Quote:
Originally Posted by wirebiter View Post
you can also mound them on the top bar that runs across the front. there should be 2 evenly spaced holes that will allow them to be seen nicely behind the grill.
I was going to do that but then I saw that one of the holes is being occupied by the plug that holds the hood cable. I dont want to mess with that incase doing that messes the tension on the cable. its all good. Ill post pics . I think they came out nice.
Daddy_Digital is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:53 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.