Welcome to the North American Subaru Impreza Owners Club Saturday August 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-25-2013, 10:31 PM   #1
james_international
Scooby Newbie
 
Member#: 342651
Join Date: Jan 2013
Chapter/Region: MWSOC
Location: wausau wi
Vehicle:
94 L-sti

At the Track v3 sti in 95 coupe turbo lag !_!

Hi fellow enthusiasts, I have a 95 impreza L coupe around 5 months ago and here's Whatsup . V3 1997 sti ej20k motor with fmic,koyo radiator , 3" tbe and cai d2 coilovers . It pulls hard holding 20-21 psi on stock vf23 turbo and I run 93 octane here in wi

After purchasing , tightened all the loose bolts and mounts , fixed notchy shifting, replaced the squeaking, slipping six puck clutch with an exedy stage 1 hd and act light flywheel, new alternator , new starter , ss uel headers and up pipe .

After finally resolving my random stalling issues and constant idle hunting in neutral by getting new iacv and having idle reset and adjusted with tps and other things , I still have some issues .. all work done has been from my neighbor and traceys auto in town so that's good . Idk why I get random cels when flooring in higher gears , and also when coasting /decelerating in those gears . the codes are still idle air codes when logged but my idle is finally smooth and not dropping to low anymore or hunting .

I did some research and figured out how to use aem true boost ebc that's installed in here and when going through settings I see that the whole time I've had this car running strong , my iwg spring pressure is set to 23.5 , and duty cycle 12% in A and 15% in B .

this thing pulls hard but has a lot of lag , it's not fully spooled pulling hard til around 4500rpm which makes it difficult to race my friends Evo 9s that spool up by 3k! Not sure how normal this is to have such extreme lag on a stock turbo with no exhaust leaks or vacuum leaks.. I even took long pulls in 3rd and 4th gear today after adjusting wastegate spring pressure to 6 psi and duty cycle to 25% and other combos but my results were either more lag and/or less boost .. I even turned it to off setting to see what psi my wg is running on and that was around 9 psi ..

I've had problems diagnosed with this cheap aftermarket bov installed by a previous owner that were found out last week and are temporarily fixed til tonite when I get my gfb hybrid adjustable bov installed and routed to recirculate 50% and be adjusted with Allen wrench maybe that could change somethings .

Idk what else to do to find out wtf is going on with this lag but it just can't be right ! I just want a reliable tune from Shane @ dbperformance in rogers mn asap to utilize all my bolt ons n such to maximize power .

Oh btw I have an apexi power fc and commander standalone I picked up used for a steal $400 but atm I'm still running my Jdm no 6 ecu til tune time . I've researched anything and everything for months with any upgrades or issues I've had and I know this is a lot of information , but hopefully ppl know something and can enlighten me ]
* Registered users of the site do not see these ads.
james_international is offline   Reply With Quote
Old 02-25-2013, 11:33 PM   #2
chulooz
Scooby Newbie
 
Member#: 159438
Join Date: Sep 2007
Chapter/Region: NESIC
Location: south CT
Vehicle:
99 GC8
Black

Default

What is the current tune situation on your ride?
chulooz is offline   Reply With Quote
Old 02-26-2013, 12:04 AM   #3
james_international
Scooby Newbie
 
Member#: 342651
Join Date: Jan 2013
Chapter/Region: MWSOC
Location: wausau wi
Vehicle:
94 L-sti

Default

Dude what do u mean ? My ebc ? Stated above . My dyno tune ? Stated above for future .
james_international is offline   Reply With Quote
Old 02-26-2013, 01:33 AM   #4
james_international
Scooby Newbie
 
Member#: 342651
Join Date: Jan 2013
Chapter/Region: MWSOC
Location: wausau wi
Vehicle:
94 L-sti

Default

Is it possible I have a turbo who's billet wheel is shot on the turbine ?
james_international is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:23 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.