Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-26-2013, 11:03 AM   #1
sdnasioc
Scooby Newbie
 
Member#: 235912
Join Date: Jan 2010
Default wierd smell when heat is turned on

When I turn on the heat there is a weird smell. I think it goes away after 5 minutes or so... or maybe I get used to it. My wife says its terrible. I don't find it that bad, but it is noticeable. Its not gas. I don't know what it is. What should I look at to find the source of the smell?

I am changing the cabin air filter this week. Could that be it, even if it only happens when I turn on the heat?

I don't think this is related but I recently started hearing a subtle metal noise. Like if a piece of metal was dangling and hitting another piece of metal every now and then. I think its very subtle and most people would not notice it. It doesn't happen continuously. I sorta think ti happens when I accelerate, but I am not sure. Does that give any hints about the smell issue or is it totally unrelated?
* Registered users of the site do not see these ads.
sdnasioc is offline   Reply With Quote
Old 02-26-2013, 11:08 AM   #2
mmyykkee
Scooby Newbie
 
Member#: 288863
Join Date: Jul 2011
Default

Maybe an exhaust leak?

Found a post here on cleaning the system if you find that the cabin filter doesn't do the trick.
mmyykkee is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:53 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.