Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-17-2011, 03:04 AM   #1
jayeeyee
Scooby Newbie
 
Member#: 233640
Join Date: Dec 2009
Chapter/Region: Tri-State
Location: NYC
Vehicle:
'04 Subaru STi
WRB

Default '04 STi Ticking Noise Under Full Boost/WOT

This noise is starting to bother me more and more. It sounds like it's coming from the driver side and ONLY happens past 3000 rpm when it's under full boost/wot and keeps making the noise till I let go. It's a very audible "tick tick tick tick tick tick" like popcorn popping (best comparison I can think of).

If I were to drive it normally past 3000 rpm even with moderate boost the ticking noise doesn't occur. I'm just worried one day I'll blow my motor. I understand the fuel injectors make ticking noises but it doesn't make sense to me that it would get that loud even on full load. It's not the all familiar heatshield noise either since I removed mine.

My mods consist of:
K&N Typhoon Intake
APS BOV 50/50
Invidia Catless Bellmouth DP
Apexi N1 copy Catback
Grimspeed AOS
Cobb AP Stage 2 Tune

Are there anyone who came across this issue and had it resolved? I'm going to check my stock boost solenoid next to see if thats the culprit but then again... I am pretty sure I'm hearing this from the driver side. I might need to sit on the pass. side to see if I can hear it from there too. Any help/insight is greatly appreciate!

Kudos,
Jay
* Registered users of the site do not see these ads.
jayeeyee is offline   Reply With Quote
Old 09-17-2011, 03:33 PM   #2
thecleaner691
Scooby Newbie
 
Member#: 224641
Join Date: Sep 2009
Chapter/Region: SCIC
Location: Southern California
Vehicle:
2004 sti
wrb

Default

Could be any number of things....loose timing belt guide or tensioner, bent valve, knock, loose metal or bolt banging against something....you really need to have a Subaru mechanic look at it. We can't diagnose odd noises over the internetz without at least a video with good audio....log your knock parameters with your ap and post.
thecleaner691 is offline   Reply With Quote
Old 02-27-2013, 02:11 AM   #3
Karlot
Scooby Newbie
 
Member#: 339923
Join Date: Dec 2012
Location: Gainesville, VA
Vehicle:
2006 Impreza WRX STi
grey

Default

did you ever figure this out? im having a similar issue, only difference is mine is one loud pop instead of multiple pops, just like you said, mine is only under WOT.
Karlot is offline   Reply With Quote
Old 03-01-2013, 04:33 AM   #4
DHRDAN
Scooby Specialist
 
Member#: 204358
Join Date: Feb 2009
Chapter/Region: SCIC
Location: Santa Paula, CA.
Vehicle:
01 2.5RS W/ EJ257
Black

Default

take a video.


Ticking.. means a lot of things.
DHRDAN is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ticking noise under acceleration Spore Normally Aspirated Powertrain 2 12-21-2008 12:39 PM
Loud noise from turbo area under full boost chris124816 Factory 2.0L Turbo Powertrain 10 06-19-2008 06:37 AM
'04 STi, forged pistons, under 28k miles, under 8k miles on new built motor, 373 WHP size18boarder Private Vehicle 'For Sale' Classifieds 50 08-04-2007 11:19 AM
Noise under full wheel lock, anyone know what's wrong with my car ? itachi1314 Vancouver Impreza Club Forum -- VIC 7 07-06-2007 03:22 AM
'04/'05 Turbo gauge, stock reading under full boost? UltimateLurker Newbies & FAQs 18 04-21-2005 09:40 AM


All times are GMT -4. The time now is 11:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.