Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-03-2013, 04:03 PM   #26
nhat
#Belieber
Moderator
 
Member#: 140163
Join Date: Feb 2007
Chapter/Region: MAIC
Location: 3MI Racing
Vehicle:
03 STi
hellaflunctional

Default

Quote:
Originally Posted by subi-T View Post
Hey guys I hope I can get some help here, I have a 2002 subaru wrx and a mechanic replaced my clutch but now it won't turn on only when I put starting fluid??
Any help? Thanks
Take it back to your mechanic? If it started up fine before the clutch replacement and doesn't afterwards, your mechanic should fix it free of charge.
* Registered users of the site do not see these ads.
nhat is offline   Reply With Quote
Old 03-03-2013, 04:44 PM   #27
EJ20cosworth
Scooby Specialist
 
Member#: 253551
Join Date: Jul 2010
Chapter/Region: MWSOC
Location: Cleveland Ohio
Vehicle:
2002 Wrx
Black

Default

Quote:
Originally Posted by SnowmanFX View Post
Check your compression.

Air
Fuel
Spark
Compression
Timing
Exactly. Check for unplugged connectors, just look over everything with a fine tooth comb before you start digging around.
EJ20cosworth is offline   Reply With Quote
Old 03-03-2013, 09:44 PM   #28
subi-T
Scooby Newbie
 
Member#: 348082
Join Date: Feb 2013
Chapter/Region: SCIC
Location: Downey CA
Vehicle:
2002 impreza
World Rally Blue

Default

I have found a unplugged connector under the fuel regulator its not for the injectors I can't find where it goes. I have pictures but I'm using my phone and don't know how to post pics. I took it to the mechanic and he's giving me a real hard time.
subi-T is offline   Reply With Quote
Old 03-03-2013, 10:08 PM   #29
EJ20cosworth
Scooby Specialist
 
Member#: 253551
Join Date: Jul 2010
Chapter/Region: MWSOC
Location: Cleveland Ohio
Vehicle:
2002 Wrx
Black

Default

Quote:
Originally Posted by subi-T View Post
I have found a unplugged connector under the fuel regulator its not for the injectors I can't find where it goes. I have pictures but I'm using my phone and don't know how to post pics. I took it to the mechanic and he's giving me a real hard time.
I just saw this, if no one else chimes in, I will take a look at what connectors are around there. What's the color and amount of pins?
EJ20cosworth is offline   Reply With Quote
Old 03-03-2013, 10:40 PM   #30
recce02
Scooby Specialist
 
Member#: 13815
Join Date: Jan 2002
Chapter/Region: SCIC
Location: Good ol Temecula
Vehicle:
02 GCRally prepped
277TQ 281HP 19PSI

Default

Might be tgv plug?
recce02 is offline   Reply With Quote
Old 03-04-2013, 12:23 AM   #31
subi-T
Scooby Newbie
 
Member#: 348082
Join Date: Feb 2013
Chapter/Region: SCIC
Location: Downey CA
Vehicle:
2002 impreza
World Rally Blue

Default

What is that plug used for. I read it can be deleted but why
subi-T is offline   Reply With Quote
Old 03-04-2013, 02:11 AM   #32
subi-T
Scooby Newbie
 
Member#: 348082
Join Date: Feb 2013
Chapter/Region: SCIC
Location: Downey CA
Vehicle:
2002 impreza
World Rally Blue

Default

Quote:
Originally Posted by EJ20cosworth View Post

I just saw this, if no one else chimes in, I will take a look at what connectors are around there. What's the color and amount of pins?
The connector is gray and inside its Orange it has 2 pins it looks similar to the fuel injector connector, its also wired along the same bunch of wires that connect on the right side fender. Thanks

And hues what! Don't make fun of me but I found out why it didn't start, ready?.... the intercooler was not connected :'( lol
I'm an idiot but the mechanic said it does not need to be attached to start the car but I new it did so when he left I attached it and bam!!!
subi-T is offline   Reply With Quote
Old 03-04-2013, 10:47 AM   #33
nhat
#Belieber
Moderator
 
Member#: 140163
Join Date: Feb 2007
Chapter/Region: MAIC
Location: 3MI Racing
Vehicle:
03 STi
hellaflunctional

Default

Quote:
Originally Posted by subi-T View Post
I have pictures but I'm using my phone and don't know how to post pics.
Please learn how to. It'll help us all out. Use Photobucket or Imageshack to host then post the link here.
nhat is offline   Reply With Quote
Old 03-05-2013, 05:37 AM   #34
EJ20cosworth
Scooby Specialist
 
Member#: 253551
Join Date: Jul 2010
Chapter/Region: MWSOC
Location: Cleveland Ohio
Vehicle:
2002 Wrx
Black

Default

Quote:
Originally Posted by subi-T View Post
I have found a unplugged connector under the fuel regulator its not for the injectors I can't find where it goes. I have pictures but I'm using my phone and don't know how to post pics. I took it to the mechanic and he's giving me a real hard time.
Figure it out?

Download the photobucket Mobil app. It will upload photos out of your pictures that you select. You then click on the ! Icon on the bottom right of the screen for image code. It auto copy's the link and then you just post the link here.


Last edited by EJ20cosworth; 03-05-2013 at 05:43 AM.
EJ20cosworth is offline   Reply With Quote
Old 03-05-2013, 10:46 PM   #35
02suub87
Scooby Newbie
 
Member#: 311634
Join Date: Feb 2012
Default

I had this problem shortly after my build on my car. I started panicking and double checked everything. turned out that my Crank and Cam Sensor were both loose. Maybe check that? best of luck
02suub87 is offline   Reply With Quote
Old 03-06-2013, 10:38 PM   #36
Legatron02
Scooby Newbie
 
Member#: 295810
Join Date: Sep 2011
Chapter/Region: NESIC
Location: South County RI
Vehicle:
98 LGT EJ205 swap
Spruce Pearl

Default

Quote:
Originally Posted by subi-T View Post
Hey guys I hope I can get some help here, I have a 2002 subaru wrx and a mechanic replaced my clutch but now it won't turn on only when I put starting fluid??
Any help? Thanks
Your probably not getting fuel... check your fuel pump and filter
Legatron02 is offline   Reply With Quote
Old 06-18-2013, 03:43 PM   #37
TykoSubs
Scooby Newbie
 
Member#: 324900
Join Date: Jul 2012
Chapter/Region: PRSIC
Location: San Juan, Puerto Rico
Vehicle:
2005 Impreza
Crown Blue

Default

hey guys, can i get some rescue please! my 2005 Impreza RS2.5 wont start. The interior electronic accessories do come on, but when i turn the key to ignition nothing happens, literally. Battery's good and I've checked all the fuses.

Thanks in advance for any suggestion of what might be happening
TykoSubs is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help Help *wrx Wont Start* Help Help hawaiifosho Newbies & FAQs 11 05-27-2011 08:22 AM
02 wrx wont start after timing please help ej20wagon02 Service & Maintenance 6 04-03-2009 02:05 PM
Help 03 WRX wont start after new battery! newgensti Factory 2.0L Turbo Powertrain 18 01-20-2009 01:58 AM
Help My WRX wont start! Jokoso Newbies & FAQs 9 10-30-2002 10:02 AM
need help wrx wont start Brewmaster New England Impreza Club Forum -- NESIC 8 06-15-2002 09:06 PM


All times are GMT -4. The time now is 08:56 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.