Welcome to the North American Subaru Impreza Owners Club Thursday November 26, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-07-2013, 05:21 PM   #1
Scooby Newbie
Member#: 337257
Join Date: Nov 2012
Chapter/Region: Tri-State
2013 wrx
Crystal black silica

Default Violent shaking during acceleration

Changed my maf sensor Monday cause of check engine light need also to change o2 sensor.
After changing the maf the car runs like crap.
Idles fine but no power. Hesitates at acceleration then at around 3k rpm and up it violently shaked from front to back so hard made me think It was going to explode. Crazy.
I pulled into a gas station on the highway filled up a full tank from a quarter tank. After leaving the gas station and having to accelerate to merge on the highway it started to shake again for a sec then smoothed out. Didn't do it the rest of the 30 min highway ride.
After the changing te maf it's no where near the same.
Things I'm think it could be
I have to change the clutch it really in its way out. Not sure if that could contribute to it cause it felt like when you shift into a gear and its low of a rpm an it shakes but it felt like 100 times worse.
I know I have to change the rear o2 sensor
I have 2 little vac leaks
Maybe after disconnecting the battery during the maf changing it has reboot or read the way I drive
Maybe I need a tune I'm just trying to see what other people's suggestions are before i go need with it myself
Perrin intake and cat back
Any suggestions or advice would be greatly appreciated
grimzwrx720 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:26 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.