Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-08-2013, 01:02 PM   #1
MG rex
Scooby Newbie
 
Member#: 341359
Join Date: Dec 2012
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2013 WRX Hatch
DGM

Default Help setting up defi cr

Hi guys, I am planning to install Defi advance CR series on a pillar pod. Running into trouble connecting the gauges together as the meter wire supplied is too short. Bought some defi meter wires from JSC speed but the connection head is different.

Anyone know where i can get the correct wires?

I am assuming I bought the defi racer series and not the cr wires.
* Registered users of the site do not see these ads.
MG rex is offline   Reply With Quote
Old 03-08-2013, 01:34 PM   #2
Loyale93
Scooby Guru
 
Member#: 91347
Join Date: Jul 2005
Chapter/Region: NESIC
Location: Moscow, Russia
Vehicle:
'13 XV Crosstrek,
1050 Triumph Speed Triple

Default

check out these guys. they should be able to help you.

http://www.jscspeed.com/
Loyale93 is offline   Reply With Quote
Old 03-08-2013, 06:16 PM   #3
MG rex
Scooby Newbie
 
Member#: 341359
Join Date: Dec 2012
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2013 WRX Hatch
DGM

Default

Problem solved. Thanks for the reply.


Have to be careful ordering the wires as the LINK wire will not work if you have The advance system
MG rex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:08 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.