Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-04-2012, 12:14 AM   #1
2009OutbackSport
Scooby Newbie
 
Member#: 203009
Join Date: Feb 2009
Vehicle:
2009 Outback Sport
Sage Green Metallic

Default 08+ Impreza 100K mile club - how's it going?

So I would like to hear from all of you who have 2008 and up Imprezas with 100K miles or more on the clock.

How's it going?

My '09 OBS has just under 30K and of course, it's running perfectly and smoothly. Haven't had any issues as of yet with the car.

At this rate it will take me another 6 years to get to 100K, but I am hoping to hear about issues with this generation of car around 100K miles.

Any issues? Problems? Head gaskets? Timing belts?

Would love to hear from every owner of one of these generation of Imprezas.
* Registered users of the site do not see these ads.
2009OutbackSport is offline   Reply With Quote
Old 05-04-2012, 07:47 AM   #2
daigledangle8
Scooby Specialist
 
Member#: 253642
Join Date: Aug 2010
Chapter/Region: NESIC
Location: Manchester, CT
Vehicle:
2008 Impreza 2.5i
SSM

Default

I have an 08 and I'm only at 56k.

So far no issues, but I have that 60k check up coming up soon so we ll see!
daigledangle8 is offline   Reply With Quote
Old 05-04-2012, 02:26 PM   #3
Bluefoton
Scooby Specialist
 
Member#: 141373
Join Date: Feb 2007
Chapter/Region: E. Canada
Location: Quebec, QC
Vehicle:
2008 2.5i-hatch -
now with a HID retrofit

Default

Curious when the 08+ blown HG club will start ...
Bluefoton is offline   Reply With Quote
Old 05-04-2012, 03:45 PM   #4
mtarr07
Scooby Specialist
 
Member#: 246990
Join Date: May 2010
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2010 Wrx

Default

Quote:
Originally Posted by Bluefoton View Post
Curious when the 08+ blown HG club will start ...
NEVARRRRRRRR
mtarr07 is offline   Reply With Quote
Old 05-04-2012, 03:53 PM   #5
Steve2.5i
Scooby Specialist
 
Member#: 293006
Join Date: Aug 2011
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2010 Impreza 2.5i
Newport Blue

Default

Quote:
Originally Posted by daigledangle8
I have an 08 and I'm only at 56k.

So far no issues, but I have that 60k check up coming up soon so we ll see!
I lol'd I think he missed the memo
Steve2.5i is offline   Reply With Quote
Old 05-04-2012, 07:23 PM   #6
Tope
Scooby Newbie
 
Member#: 245045
Join Date: Apr 2010
Location: Ohio
Vehicle:
2008 2.5i
Topaz

Default

Got an 08, 130n change on the clock. Changed the timing belt at 100. Throwout bearing went out at like 120, and replaced clutch to. Wheel bearing just went. Drivers side. Otherwise engine seems fine. Still getting 29-30 mpg highway.
Tope is offline   Reply With Quote
Old 05-04-2012, 10:28 PM   #7
f4umt
Scooby Newbie
 
Member#: 283246
Join Date: May 2011
Chapter/Region: MWSOC
Location: Oshkosh
Vehicle:
06 OutbackSport SE

Default

Quote:
Originally Posted by Tope View Post
Got an 08, 130n change on the clock. Changed the timing belt at 100. Throwout bearing went out at like 120, and replaced clutch to. Wheel bearing just went. Drivers side. Otherwise engine seems fine. Still getting 29-30 mpg highway.
i have a 06, same engine. but had a factory clutch up to 151k for my throw out bearing went out. i'm at 152kl right now. only had to replace main rear seal, camshaft, and crankshaft seals.
f4umt is offline   Reply With Quote
Old 05-05-2012, 12:44 PM   #8
Ralph47
Scooby Newbie
 
Member#: 214774
Join Date: Jun 2009
Location: Southern NH
Vehicle:
2009 Impreza 2.5i
Dark Grey

Default

My 08 is ~68K and the only issue I have developed is a tire hop or something similar at high speeds. 99% sure that was my parents crappy dirt road tho, it was nasty this year with the bizarre winter we had.

I hope nothing major comes up in this thread lol, I want mine to last a LONG time before it gets needy
Ralph47 is offline   Reply With Quote
Old 03-10-2013, 07:35 AM   #9
neilburns
Scooby Newbie
 
Member#: 90834
Join Date: Jul 2005
Chapter/Region: E. Canada
Location: Ottawa, ON
Vehicle:
2007 WRX Wagooon
Satin Pearl White

Default

Any more input from you 08+ owners?
neilburns is offline   Reply With Quote
Old 03-10-2013, 02:06 PM   #10
Zordos
Scooby Newbie
 
Member#: 165121
Join Date: Nov 2007
Chapter/Region: VIC
Location: Abbotsford, BC
Vehicle:
08 2.5i
WRB

Default

just rolled 182k km
did the timing at 160.
got the cold rattle on the throw out bearing going other that everything else seems fine.
Zordos is offline   Reply With Quote
Old 03-10-2013, 02:11 PM   #11
Duvanator
Scooby Newbie
 
Member#: 217257
Join Date: Jul 2009
Location: Niagara Falls, Canada
Vehicle:
2008 2.5i hatch
Satin White Wrap

Default

105k Km, no issues at all, just regular maintenance.
Still going strong!
Duvanator is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
100k Miles Club? andyC Legacy Forum 51 04-14-2005 07:20 AM
How's It Going AKGC8 Alaskan Impreza Club Forum -- AKIC 2 10-28-2003 01:43 PM
hey Dan R how's it going? scoobyruman New England Impreza Club Forum -- NESIC 6 07-02-2003 09:22 AM
Ft Myers Nat Tour.... How's it going? KC Motorsports 2 02-25-2002 12:51 AM
Azenis owners: how's it going? Jon Bogert Brakes, Steering & Suspension 49 08-17-2001 08:59 AM


All times are GMT -4. The time now is 10:45 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.